summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-04-10 20:24:56 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-04-10 20:24:56 +0000
commit49c553ac50753eb2ade46c1afd77b3db9d52edb4 (patch)
treed7836e00c1af5900cfd0202faad2bb5ed9a1e439 /eclass/cmake-utils.eclass
parentVersion bump, fixes bug #209301 and bug #228265 (diff)
downloadhistorical-49c553ac50753eb2ade46c1afd77b3db9d52edb4.tar.gz
historical-49c553ac50753eb2ade46c1afd77b3db9d52edb4.tar.bz2
historical-49c553ac50753eb2ade46c1afd77b3db9d52edb4.zip
Die when there is no CMakeLists.txt
Diffstat (limited to 'eclass/cmake-utils.eclass')
-rw-r--r--eclass/cmake-utils.eclass10
1 files changed, 9 insertions, 1 deletions
diff --git a/eclass/cmake-utils.eclass b/eclass/cmake-utils.eclass
index 7b9babe1940b..4423e4fd3685 100644
--- a/eclass/cmake-utils.eclass
+++ b/eclass/cmake-utils.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/cmake-utils.eclass,v 1.23 2009/04/04 12:28:10 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/cmake-utils.eclass,v 1.24 2009/04/10 20:24:56 scarabeus Exp $
# @ECLASS: cmake-utils.eclass
# @MAINTAINER:
@@ -227,6 +227,14 @@ Install path: ${CMAKE_INSTALL_PREFIX}\n")' >> CMakeLists.txt
cmake-utils_src_configure() {
debug-print-function ${FUNCNAME} "$@"
+ # check if CMakeLists.txt exist and if no then die
+ if [[ ! -e "${S}"/CMakeLists.txt ]] ; then
+ eerror "I was unable to locate CMakeLists.txt under:"
+ eerror "\"${S}/CMakeLists.txt\""
+ eerror "You should consider not inheriting the cmake eclass."
+ die "FATAL: Unable to find CMakeLists.txt"
+ fi
+
# Remove dangerous things.
_modify-cmakelists