summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2010-03-15 03:35:39 +0000
committerMaciej Mrozowski <reavertm@gentoo.org>2010-03-15 03:35:39 +0000
commit4286cf7b5e83abc153eb6f138e77a64e325aee36 (patch)
tree51450654bb03bcbbbfb5c9b71241cbcd6fd7648a /eclass/kde4-meta.eclass
parentbuilt_with_use -> has_version (diff)
downloadhistorical-4286cf7b5e83abc153eb6f138e77a64e325aee36.tar.gz
historical-4286cf7b5e83abc153eb6f138e77a64e325aee36.tar.bz2
historical-4286cf7b5e83abc153eb6f138e77a64e325aee36.zip
Added kdepim-related CMake-checks overriding
Diffstat (limited to 'eclass/kde4-meta.eclass')
-rw-r--r--eclass/kde4-meta.eclass10
1 files changed, 9 insertions, 1 deletions
diff --git a/eclass/kde4-meta.eclass b/eclass/kde4-meta.eclass
index 8c450387b947..60c3a24b5034 100644
--- a/eclass/kde4-meta.eclass
+++ b/eclass/kde4-meta.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-meta.eclass,v 1.33 2010/02/02 14:20:16 reavertm Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-meta.eclass,v 1.34 2010/03/15 03:35:39 reavertm Exp $
#
# @ECLASS: kde4-meta.eclass
# @MAINTAINER:
@@ -573,7 +573,15 @@ kde4-meta_change_cmakelists() {
sed -r -e '/find_package\(KdepimLibs/s/REQUIRED//' \
-e '/find_package\((KdepimLibs|Boost|QGpgme|Akonadi|ZLIB|Strigi|SharedDesktopOntologies|Soprano|Nepomuk)/{/macro_optional_/!s/find/macro_optional_&/}' \
-e '/macro_log_feature\((Boost|QGPGME|Akonadi|ZLIB|STRIGI|SHAREDDESKTOPONTOLOGIES|Soprano|Nepomuk)_FOUND/s/ TRUE / FALSE /' \
+ -e '/if[[:space:]]*([[:space:]]*BUILD_.*)/s/^/#OVERRIDE /' \
+ -e '/if[[:space:]]*([[:space:]]*[[:alnum:]]*_FOUND[[:space:]]*)/s/^/#OVERRIDE /' \
-i CMakeLists.txt || die "failed to disable hardcoded checks"
+ # Disable broken or redundant build logic
+ if ( has kontact ${IUSE//+} && use kontact ) || [[ ${PN} = kontact ]]; then
+ sed -e '/if[[:space:]]*([[:space:]]*BUILD_.*)/s/^/#OVERRIDE /' \
+ -e '/if[[:space:]]*([[:space:]]*[[:alnum:]]*_FOUND[[:space:]]*)/s/^/#OVERRIDE /' \
+ -i kontact/plugins/CMakeLists.txt || die 'failed to override build logic'
+ fi
if ! slot_is_at_least 4.5 ${SLOT}; then
case ${PN} in
kalarm|kmailcvt|kontact|korganizer|korn)