summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetre Rodan <kaiowas@gentoo.org>2007-07-07 16:21:07 +0000
committerPetre Rodan <kaiowas@gentoo.org>2007-07-07 16:21:07 +0000
commit237099bc33c9c33308bf7ef36b28c2ed5ba8279f (patch)
treeb0cbeaedff286c6902a12f80941c6db35217edcf /eclass/selinux-policy-2.eclass
parentmasked selinux-lpd and selinux-munin to keep repoman happy (diff)
downloadhistorical-237099bc33c9c33308bf7ef36b28c2ed5ba8279f.tar.gz
historical-237099bc33c9c33308bf7ef36b28c2ed5ba8279f.tar.bz2
historical-237099bc33c9c33308bf7ef36b28c2ed5ba8279f.zip
added support for POLICY_PATCH
Diffstat (limited to 'eclass/selinux-policy-2.eclass')
-rw-r--r--eclass/selinux-policy-2.eclass8
1 files changed, 7 insertions, 1 deletions
diff --git a/eclass/selinux-policy-2.eclass b/eclass/selinux-policy-2.eclass
index 2275a0a8c4e9..ae4d411a8658 100644
--- a/eclass/selinux-policy-2.eclass
+++ b/eclass/selinux-policy-2.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/selinux-policy-2.eclass,v 1.2 2006/10/25 11:27:36 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/selinux-policy-2.eclass,v 1.3 2007/07/07 16:21:07 kaiowas Exp $
# Eclass for installing SELinux policy, and optionally
# reloading the reference-policy based modules
@@ -40,6 +40,12 @@ selinux-policy-2_src_unpack() {
cp ${S}/refpolicy/doc/Makefile.example ${S}/${i}/Makefile
cp ${modfiles} ${S}/${i}
+
+ if [ -n "${POLICY_PATCH}" ]; then
+ cd ${S}/${i}
+ epatch "${POLICY_PATCH}" || die "failed patch ${i}"
+ fi
+
done
}