summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-01-09 01:08:59 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-01-09 01:08:59 +0000
commit1b7c4cdc7b8c3f184aeca7bc9f4aeab562bc277b (patch)
treeea6c3b439248e517d98296ab653c6159c730920a /eclass
parentversion bump to the latest devel version. mirroring versioned source on gento... (diff)
downloadhistorical-1b7c4cdc7b8c3f184aeca7bc9f4aeab562bc277b.tar.gz
historical-1b7c4cdc7b8c3f184aeca7bc9f4aeab562bc277b.tar.bz2
historical-1b7c4cdc7b8c3f184aeca7bc9f4aeab562bc277b.zip
smartness to speedup ./configure for plugins - remove 90% of unneeded Makefiles
Diffstat (limited to 'eclass')
-rw-r--r--eclass/gst-plugins.eclass20
1 files changed, 17 insertions, 3 deletions
diff --git a/eclass/gst-plugins.eclass b/eclass/gst-plugins.eclass
index 4c92e522fe98..b0cfc0e45709 100644
--- a/eclass/gst-plugins.eclass
+++ b/eclass/gst-plugins.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/gst-plugins.eclass,v 1.3 2003/09/07 18:04:20 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/gst-plugins.eclass,v 1.4 2004/01/09 01:08:59 liquidx Exp $
# Author : foser <foser@gentoo.org>
@@ -55,7 +55,7 @@ SLOT=${PV_MAJ_MIN}
S=${WORKDIR}/${MY_P}
-newdepend "=${MY_P}*"
+newdepend "=${MY_P}*" ">=sys-apps/sed-4"
#
# internal functions
@@ -116,6 +116,20 @@ gst-plugins_update_registry() {
# public inheritable functions
#
+gst-plugins_src_unpack() {
+ local makefiles
+ unpack ${A}
+
+ # Remove generation of any other Makefiles except the plugin's Makefile
+ if [ -d "${S}/sys/${GST_PLUGINS_BUILD_DIR}" ]; then
+ makefiles="Makefile sys/Makefile sys/${GST_PLUGINS_BUILD_DIR}/Makefile"
+ elif [ -d "${S}/ext/${GST_PLUGINS_BUILD_DIR}" ]; then
+ makefiles="Makefile ext/Makefile ext/${GST_PLUGINS_BUILD_DIR}/Makefile"
+ fi
+ sed -e "s:ac_config_files=.*:ac_config_files='${makefiles}':" \
+ -i ${S}/configure
+}
+
gst-plugins_src_compile() {
gst-plugins_src_configure ${@}
@@ -146,4 +160,4 @@ gst-plugins_pkg_postrm() {
}
-EXPORT_FUNCTIONS src_compile src_install pkg_postinst pkg_postrm
+EXPORT_FUNCTIONS src_unpack src_compile src_install pkg_postinst pkg_postrm