summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-10-24 22:43:18 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-10-24 22:43:18 +0000
commit18789540670eb28be5c423ea668e46bbc903aa3a (patch)
tree68040f4fe0cdbf371c9843093cb817e29dfd4f55 /games-action/fakk2
parentMoved cdrom_get_cds to src_unpack since binary packages don't require the ori... (diff)
downloadhistorical-18789540670eb28be5c423ea668e46bbc903aa3a.tar.gz
historical-18789540670eb28be5c423ea668e46bbc903aa3a.tar.bz2
historical-18789540670eb28be5c423ea668e46bbc903aa3a.zip
Moved cdrom_get_cds to src_unpack since binary packages don't require the original media to install as well as some general cleanup.
Package-Manager: portage-2.1.2_pre3-r5
Diffstat (limited to 'games-action/fakk2')
-rw-r--r--games-action/fakk2/ChangeLog6
-rw-r--r--games-action/fakk2/fakk2-1.02.ebuild16
2 files changed, 12 insertions, 10 deletions
diff --git a/games-action/fakk2/ChangeLog b/games-action/fakk2/ChangeLog
index adad15cf7bb2..25c2983e2f40 100644
--- a/games-action/fakk2/ChangeLog
+++ b/games-action/fakk2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/fakk2
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/fakk2/ChangeLog,v 1.14 2006/04/13 19:45:25 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/fakk2/ChangeLog,v 1.15 2006/10/24 22:43:18 wolf31o2 Exp $
+
+ 24 Oct 2006; Chris Gianelloni <wolf31o2@gentoo.org> fakk2-1.02.ebuild:
+ Moved cdrom_get_cds to src_unpack since binary packages don't require the
+ original media to install as well as some general cleanup.
13 Apr 2006; Chris Gianelloni <wolf31o2@gentoo.org> fakk2-1.02.ebuild:
Moved games_pkg_setup to the beginning of pkg_setup and changed to use
diff --git a/games-action/fakk2/fakk2-1.02.ebuild b/games-action/fakk2/fakk2-1.02.ebuild
index 9cd619d7240a..739e5444ced4 100644
--- a/games-action/fakk2/fakk2-1.02.ebuild
+++ b/games-action/fakk2/fakk2-1.02.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/fakk2/fakk2-1.02.ebuild,v 1.13 2006/04/13 19:45:25 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/fakk2/fakk2-1.02.ebuild,v 1.14 2006/10/24 22:43:18 wolf31o2 Exp $
inherit eutils games
@@ -29,21 +29,19 @@ pkg_setup() {
if use nocd ; then
ewarn "The installed game takes about 378MB of space!"
fi
- cdrom_get_cds fakk
}
src_install() {
- dodir ${dir}
+ cdrom_get_cds fakk
einfo "Copying files... this may take a while..."
- exeinto ${dir}
+ exeinto "${dir}"
doexe ${CDROM_ROOT}/bin/x86/glibc-2.1/${PN}
- insinto ${dir}
+ insinto "${dir}"
doins ${CDROM_ROOT}/{README,icon.{bmp,xpm}}
- dodir ${dir}/fakk
- exeinto ${dir}/fakk
+ exeinto "${dir}"/fakk
doexe ${CDROM_ROOT}/bin/x86/glibc-2.1/fakk/{c,f}game.so
if use nocd ; then
- insinto ${dir}/fakk
+ insinto "${dir}"/fakk
doins ${CDROM_ROOT}/fakk/pak{0,1,2,3}.pk3
doins ${CDROM_ROOT}/fakk/default.cfg
fi
@@ -51,7 +49,7 @@ src_install() {
# now, since these files are coming off a cd, the times/sizes/md5sums wont
# be different ... that means portage will try to unmerge some files (!)
# we run touch on ${D} so as to make sure portage doesnt do any such thing
- find ${Ddir} -exec touch '{}' \;
+ find "${Ddir}" -exec touch '{}' \;
games_make_wrapper ${PN} ./${PN} "${dir}" "${dir}"
newicon ${CDROM_ROOT}/icon.xpm ${PN}.xpm