summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-07-26 21:53:12 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-07-26 21:53:12 +0000
commit019982b2ed9cf0c663a1000c98a704819b5a0ff5 (patch)
tree6f174123b44c51bd514c2e7a823404e119140917 /games-action
parentKilling package that should never have been added... stupid epkgmove... (diff)
downloadhistorical-019982b2ed9cf0c663a1000c98a704819b5a0ff5.tar.gz
historical-019982b2ed9cf0c663a1000c98a704819b5a0ff5.tar.bz2
historical-019982b2ed9cf0c663a1000c98a704819b5a0ff5.zip
Add patch from Loz Hygate to address gcc 3.4 compile (bug #58287)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/shootingstar/ChangeLog6
-rw-r--r--games-action/shootingstar/Manifest5
-rw-r--r--games-action/shootingstar/files/1.2.0-gcc34.patch23
-rw-r--r--games-action/shootingstar/shootingstar-1.2.0.ebuild10
4 files changed, 39 insertions, 5 deletions
diff --git a/games-action/shootingstar/ChangeLog b/games-action/shootingstar/ChangeLog
index 9a06f48b69ba..50ad524e4064 100644
--- a/games-action/shootingstar/ChangeLog
+++ b/games-action/shootingstar/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/shootingstar
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/shootingstar/ChangeLog,v 1.2 2004/06/24 21:59:04 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/shootingstar/ChangeLog,v 1.3 2004/07/26 21:53:12 mr_bones_ Exp $
+
+ 26 Jul 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/1.2.0-gcc34.patch, shootingstar-1.2.0.ebuild:
+ Add patch from Loz Hygate to address gcc 3.4 compile (bug #58287)
*shootingstar-1.2.0 (23 Feb 2004)
diff --git a/games-action/shootingstar/Manifest b/games-action/shootingstar/Manifest
index 699a44ba82af..b768e5d4e02c 100644
--- a/games-action/shootingstar/Manifest
+++ b/games-action/shootingstar/Manifest
@@ -1,4 +1,5 @@
-MD5 56eb8fb545cd86c9b1966b1c60197496 shootingstar-1.2.0.ebuild 670
-MD5 8f79b74bd499ff22bc39345f18679372 ChangeLog 440
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 24c1dc28aa9db7ce678a06b21fb02ca9 shootingstar-1.2.0.ebuild 758
+MD5 9f90f4885c52346a2c4cbdf44403e56d ChangeLog 620
+MD5 be5aab019239b5659c6f5f5bb61b0085 files/1.2.0-gcc34.patch 1053
MD5 e213ef0a24782b487d5eabba35b82063 files/digest-shootingstar-1.2.0 71
diff --git a/games-action/shootingstar/files/1.2.0-gcc34.patch b/games-action/shootingstar/files/1.2.0-gcc34.patch
new file mode 100644
index 000000000000..b55997552fc8
--- /dev/null
+++ b/games-action/shootingstar/files/1.2.0-gcc34.patch
@@ -0,0 +1,23 @@
+diff -ur shootingstar-1.2.0/src/engine/cTextureFont.cpp shootingstar-1.2.0.loz/src/engine/cTextureFont.cpp
+--- shootingstar-1.2.0/src/engine/cTextureFont.cpp 2003-07-06 19:31:10.000000000 +0100
++++ shootingstar-1.2.0.loz/src/engine/cTextureFont.cpp 2004-07-26 20:51:16.992768063 +0100
+@@ -31,6 +31,7 @@
+ #include <stdio.h>
+ #include <GL/gl.h>
+ #include <GL/glu.h>
++#include <math.h>
+ #include "cTextureManager.hpp"
+ #include "Debug.hpp"
+ //------------------------------------------------------------------------------
+diff -ur shootingstar-1.2.0/src/game/cOptions.cpp shootingstar-1.2.0.loz/src/game/cOptions.cpp
+--- shootingstar-1.2.0/src/game/cOptions.cpp 2003-12-22 05:09:06.000000000 +0000
++++ shootingstar-1.2.0.loz/src/game/cOptions.cpp 2004-07-26 21:00:25.265284270 +0100
+@@ -201,7 +201,7 @@
+ dbgError () << "Unable to read from options file\n";
+ throw runtime_error ("Unable to load options");
+ }
+- int (keys.keys[i]) = key; // IS THIS SAFE?
++ keys.keys[i] = (SDLKey)key; // IS THIS SAFE?
+
+ fin >> key;
+ keys.buttons[i] = key;
diff --git a/games-action/shootingstar/shootingstar-1.2.0.ebuild b/games-action/shootingstar/shootingstar-1.2.0.ebuild
index 1b36a26d48b0..db92aa369c17 100644
--- a/games-action/shootingstar/shootingstar-1.2.0.ebuild
+++ b/games-action/shootingstar/shootingstar-1.2.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/shootingstar/shootingstar-1.2.0.ebuild,v 1.2 2004/06/24 21:59:04 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/shootingstar/shootingstar-1.2.0.ebuild,v 1.3 2004/07/26 21:53:12 mr_bones_ Exp $
-inherit games
+inherit eutils games
DESCRIPTION="A topdown shooter"
HOMEPAGE="http://www.2ndpoint.fi/ss"
@@ -20,6 +20,12 @@ DEPEND="virtual/x11
media-libs/sdl-mixer
media-libs/sdl-image"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${FILESDIR}/1.2.0-gcc34.patch"
+}
+
src_install () {
make DESTDIR=${D} install || die "make install failed"
dodoc AUTHORS ChangeLog NEWS README TODO