summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-02-29 10:12:34 +0000
committerMike Frysinger <vapier@gentoo.org>2004-02-29 10:12:34 +0000
commitdd8dbd5b587e06785aa295d1711bfa00c36b20cc (patch)
tree7091df1b545ad2fdd1455178d783ba42f8809185 /games-arcade
parentmetadata (diff)
downloadhistorical-dd8dbd5b587e06785aa295d1711bfa00c36b20cc.tar.gz
historical-dd8dbd5b587e06785aa295d1711bfa00c36b20cc.tar.bz2
historical-dd8dbd5b587e06785aa295d1711bfa00c36b20cc.zip
make it stable
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/tuxracer/tuxracer-0.61-r3.ebuild5
-rw-r--r--games-arcade/xbill/xbill-2.1-r1.ebuild11
-rw-r--r--games-arcade/xgalaga/xgalaga-2.0.34-r4.ebuild20
3 files changed, 18 insertions, 18 deletions
diff --git a/games-arcade/tuxracer/tuxracer-0.61-r3.ebuild b/games-arcade/tuxracer/tuxracer-0.61-r3.ebuild
index b41cb245649f..7a158edc1d90 100644
--- a/games-arcade/tuxracer/tuxracer-0.61-r3.ebuild
+++ b/games-arcade/tuxracer/tuxracer-0.61-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/tuxracer/tuxracer-0.61-r3.ebuild,v 1.6 2004/02/05 14:16:45 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/tuxracer/tuxracer-0.61-r3.ebuild,v 1.7 2004/02/29 10:09:08 vapier Exp $
inherit games eutils gcc flag-o-matic
@@ -8,11 +8,10 @@ DESCRIPTION="take on the role of Tux, the Linux Penguin, as he races down steep,
HOMEPAGE="http://tuxracer.sourceforge.net/"
SRC_URI="mirror://sourceforge/tuxracer/${PN}-data-${PV}.tar.gz
mirror://sourceforge/tuxracer/${P}.tar.gz"
-RESTRICT="nomirror"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc ~amd64 ~alpha"
+KEYWORDS="x86 ppc alpha amd64"
IUSE="stencil-buffer"
DEPEND="virtual/opengl
diff --git a/games-arcade/xbill/xbill-2.1-r1.ebuild b/games-arcade/xbill/xbill-2.1-r1.ebuild
index 274c7da76bac..a24e10d5db62 100644
--- a/games-arcade/xbill/xbill-2.1-r1.ebuild
+++ b/games-arcade/xbill/xbill-2.1-r1.ebuild
@@ -1,26 +1,25 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/xbill/xbill-2.1-r1.ebuild,v 1.1 2004/01/24 13:20:39 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/xbill/xbill-2.1-r1.ebuild,v 1.2 2004/02/29 10:10:43 vapier Exp $
inherit games
DESCRIPTION="A game about evil hacker called Bill!"
-HOMEPAGE="http://www.xbill.org"
+HOMEPAGE="http://www.xbill.org/"
SRC_URI="http://www.xbill.org/download/${P}.tar.gz"
-KEYWORDS="x86 ppc ~amd64"
LICENSE="GPL-1"
SLOT="0"
-IUSE=""
+KEYWORDS="x86 ppc amd64"
-DEPEND=">=gtk+-1.0"
+DEPEND=">=x11-libs/gtk+-1.0"
src_compile() {
egamesconf --enable-gtk || die
emake || die "emake failed"
}
-src_install () {
+src_install() {
make DESTDIR="${D}" install || die "make install failed"
prepgamesdirs
}
diff --git a/games-arcade/xgalaga/xgalaga-2.0.34-r4.ebuild b/games-arcade/xgalaga/xgalaga-2.0.34-r4.ebuild
index 39db56b4eb11..fd51efee193f 100644
--- a/games-arcade/xgalaga/xgalaga-2.0.34-r4.ebuild
+++ b/games-arcade/xgalaga/xgalaga-2.0.34-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/xgalaga/xgalaga-2.0.34-r4.ebuild,v 1.5 2004/02/22 16:46:14 brad_mssw Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/xgalaga/xgalaga-2.0.34-r4.ebuild,v 1.6 2004/02/29 10:12:34 vapier Exp $
inherit eutils
@@ -9,25 +9,27 @@ HOMEPAGE="http://rumsey.org/xgal.html"
SRC_URI="http://http.us.debian.org/debian/pool/main/x/${PN}/${PN}_${PV}.orig.tar.gz
http://http.us.debian.org/debian/pool/main/x/${PN}/${PN}_${PV}-27.diff.gz"
-KEYWORDS="x86 ppc alpha ~sparc amd64"
LICENSE="GPL-2"
SLOT="0"
-IUSE=""
+KEYWORDS="x86 ppc alpha sparc amd64"
DEPEND="virtual/x11"
src_unpack() {
- unpack ${A} && cd "${S}"
- epatch "${WORKDIR}/${PN}_${PV}-27.diff"
+ unpack ${A}
+ cd ${S}
+ epatch ${WORKDIR}/${PN}_${PV}-27.diff
}
src_compile() {
- econf --prefix=/usr/share/xgalaga --bindir=/usr/bin
+ econf \
+ --prefix=/usr/share/xgalaga \
+ --bindir=/usr/bin || die
emake CPPFLAGS="-D__NO_STRING_INLINES" || die "compile problem"
}
-src_install () {
- dobin xgalaga
+src_install() {
+ dobin xgalaga || die
dodoc README README.SOUND CHANGES INSTALL
insinto /usr/share/xgalaga/sounds
@@ -39,7 +41,7 @@ src_install () {
exeinto /usr/share/xgalaga
doexe xgal.sndsrv.linux
- touch "${D}/usr/share/xgalaga/scores"
+ touch ${D}/usr/share/xgalaga/scores
fperms 660 /usr/share/xgalaga/scores
fowners games:games /usr/share/xgalaga/scores
}