summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 17:46:27 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 17:46:27 +0000
commitfb8c4cf310fc6a66ecddbe48c1b77a183baa6141 (patch)
tree179b6d7697d589a3888e34ab007a4d76082e89ee /games-board/daemonshogi/daemonshogi-0.1.3.ebuild
parentChanges to make the eclass more flexible (diff)
downloadhistorical-fb8c4cf310fc6a66ecddbe48c1b77a183baa6141.tar.gz
historical-fb8c4cf310fc6a66ecddbe48c1b77a183baa6141.tar.bz2
historical-fb8c4cf310fc6a66ecddbe48c1b77a183baa6141.zip
board board games
Diffstat (limited to 'games-board/daemonshogi/daemonshogi-0.1.3.ebuild')
-rw-r--r--games-board/daemonshogi/daemonshogi-0.1.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/games-board/daemonshogi/daemonshogi-0.1.3.ebuild b/games-board/daemonshogi/daemonshogi-0.1.3.ebuild
new file mode 100644
index 000000000000..a880ac5eff5b
--- /dev/null
+++ b/games-board/daemonshogi/daemonshogi-0.1.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/daemonshogi/daemonshogi-0.1.3.ebuild,v 1.1 2003/09/10 17:46:27 vapier Exp $
+
+inherit games
+
+DESCRIPTION="A GTK+ based, simple shogi (Japanese chess) program"
+HOMEPAGE="http://www.users.yun.co.jp/~tokita/daemonshogi/"
+SRC_URI="http://www.users.yun.co.jp/~tokita/daemonshogi/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc sparc"
+IUSE="nls"
+
+DEPEND="gnome-base/gnome-libs"
+RDEPEND="nls? ( >=sys-devel/gettext-0.10.38 )"
+
+src_compile() {
+ egamesconf `use_enable nls` || die
+ emake || die
+}
+
+src_install() {
+ egamesinstall || die
+ dodoc ChangeLog README* NEWS
+ prepgamesdirs
+}