summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-03-28 16:28:14 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-03-28 16:28:14 +0000
commit4bf6ba96feb70af6d3da7aac3124b665df2e02de (patch)
treef983271d2055dd6669d14ea52df429f4d9155920 /games-board/pychess/pychess-0.8.1.ebuild
parentunmask openrc on fbsd as baselayout 2 needs it (diff)
downloadhistorical-4bf6ba96feb70af6d3da7aac3124b665df2e02de.tar.gz
historical-4bf6ba96feb70af6d3da7aac3124b665df2e02de.tar.bz2
historical-4bf6ba96feb70af6d3da7aac3124b665df2e02de.zip
version bump
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'games-board/pychess/pychess-0.8.1.ebuild')
-rw-r--r--games-board/pychess/pychess-0.8.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/games-board/pychess/pychess-0.8.1.ebuild b/games-board/pychess/pychess-0.8.1.ebuild
new file mode 100644
index 000000000000..37e0ce4f5d70
--- /dev/null
+++ b/games-board/pychess/pychess-0.8.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/pychess/pychess-0.8.1.ebuild,v 1.1 2008/03/28 16:28:14 mr_bones_ Exp $
+
+inherit python games distutils
+
+DESCRIPTION="A chess client for Gnome"
+HOMEPAGE="http://pychess.googlepages.com/home"
+SRC_URI="http://pychess.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gstreamer"
+
+DEPEND="dev-python/pygtk
+ dev-python/pygobject
+ dev-python/pycairo
+ dev-python/pysqlite
+ gstreamer? ( dev-python/gst-python )
+ dev-python/gnome-python-desktop
+ x11-themes/gnome-icon-theme"
+
+src_install() {
+ python_version
+ distutils_src_install --install-scripts="${GAMES_BINDIR}"
+ dodoc AUTHORS README
+ prepgamesdirs
+}