summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-05-07 23:01:39 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-05-07 23:01:39 +0000
commit9153e99a1d7e57102911645fe5280f2faae8c855 (patch)
treeabeba271e7833f6d59dd4e900cfca439178b6e9a /games-board/xgammon
parentUse epatch. (diff)
downloadhistorical-9153e99a1d7e57102911645fe5280f2faae8c855.tar.gz
historical-9153e99a1d7e57102911645fe5280f2faae8c855.tar.bz2
historical-9153e99a1d7e57102911645fe5280f2faae8c855.zip
fix compile for >=gcc3.3 (bug #50364)
Diffstat (limited to 'games-board/xgammon')
-rw-r--r--games-board/xgammon/ChangeLog6
-rw-r--r--games-board/xgammon/Manifest5
-rw-r--r--games-board/xgammon/files/gcc33.patch59
-rw-r--r--games-board/xgammon/xgammon-0.98.ebuild9
4 files changed, 72 insertions, 7 deletions
diff --git a/games-board/xgammon/ChangeLog b/games-board/xgammon/ChangeLog
index 15a1f7f9d614..df380aa8b459 100644
--- a/games-board/xgammon/ChangeLog
+++ b/games-board/xgammon/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for games-board/xgammon
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
# $ Header: $
+ 07 May 2004; Michael Sterrett <mr_bones_@gentoo.org> xgammon-0.98.ebuild,
+ files/gcc33.patch:
+ fix compile for >=gcc3.3 (bug #50364)
+
04 Nov 2003; Jason Wever <weeve@gentoo.org> xgammon-0.98.ebuild:
Added ~sparc keyword.
diff --git a/games-board/xgammon/Manifest b/games-board/xgammon/Manifest
index 30d500c67dcd..5fc697ded395 100644
--- a/games-board/xgammon/Manifest
+++ b/games-board/xgammon/Manifest
@@ -1,6 +1,7 @@
-MD5 980517606fd579e00c0fce203b74e07f ChangeLog 733
-MD5 64e5ee8fa1f34658596497230a162e84 xgammon-0.98.ebuild 847
+MD5 0e5e1bd0e8d8d2cdeb1007406d23909b ChangeLog 871
+MD5 1f5f6c964e698e84f503c5363fb143f6 xgammon-0.98.ebuild 871
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 30d019c96ba991fbc030e1acab5d1f4d files/gcc33.patch 3672
MD5 713a4a778934c4793f43df1ba783d07c files/digest-xgammon-0.98 64
MD5 5e492c857cd63f9bc13aced6d469814f files/xgammon-0.98-broken.patch 263
MD5 9a1350fd77ab6f36cd2539f73c4b0a6a files/xgammon-0.98-config.patch 823
diff --git a/games-board/xgammon/files/gcc33.patch b/games-board/xgammon/files/gcc33.patch
new file mode 100644
index 000000000000..90b001f2a196
--- /dev/null
+++ b/games-board/xgammon/files/gcc33.patch
@@ -0,0 +1,59 @@
+--- xgammon.c.orig 2004-05-07 14:44:07.000000000 -0700
++++ xgammon.c 2004-05-07 14:45:52.000000000 -0700
+@@ -944,31 +944,31 @@
+ for (option=1; option<argc; option++) {
+ if (strcmp (argv[option], "-?") == 0 ||
+ strcmp (argv[option], "-help") == 0) {
+-puts ("xgammon [-otherdisplay (display)]
+- [-boardgeometry (string)]
+- [-boardcolor (color)] [-bc (color)]
+- [-darkcolor (color)] [-dc (color)]
+- [-lightcolor (color)] [-lc (color)]
+- [-barcolor (color)] [-b (color)]
+- [-whitecolor (color)] the stone color for \"white\"
+- [-blackcolor (color)] the stone color for \"black\"
+- [-doublerfont (font)] sets the (big) font for the doubler dice
+- [-doubling +doubling] sets if you wish the computer to double
+- [-h (black|white)] set the color for the human player
+- (implies a human versus computer game)
+- [-gamekind -g (hvc|cvc|hvh)] sets the gamekind to either
+- human vs. human computer vs. computer
+- or human vs. computer (default)
+- [-winat (points)] play a tournament up to \"points\" points
+- [-watchmove +wachmove] if you wish to see the flying stones
+- [-buttonmove +buttonmove] set stones by simply pressing button
+- [-autoplay +autoplay] automatic play when only one move
+- is possible
+- [-stonesteps (number)] sets the stepsize the stones fly
+- in pixel (implies +watchmove)
+- [-delaytime (tsec.)] sets the time the cumputer waits
+- after each turn (implies -watchmove)
+- [-?] [-help] print this string");
++puts ("xgammon [-otherdisplay (display)]\n"
++" [-boardgeometry (string)]\n"
++" [-boardcolor (color)] [-bc (color)]\n"
++" [-darkcolor (color)] [-dc (color)]\n"
++" [-lightcolor (color)] [-lc (color)]\n"
++" [-barcolor (color)] [-b (color)]\n"
++" [-whitecolor (color)] the stone color for \"white\"\n"
++" [-blackcolor (color)] the stone color for \"black\"\n"
++" [-doublerfont (font)] sets the (big) font for the doubler dice\n"
++" [-doubling +doubling] sets if you wish the computer to double\n"
++" [-h (black|white)] set the color for the human player\n"
++" (implies a human versus computer game)\n"
++" [-gamekind -g (hvc|cvc|hvh)] sets the gamekind to either\n"
++" human vs. human computer vs. computer\n"
++" or human vs. computer (default)\n"
++" [-winat (points)] play a tournament up to \"points\" points\n"
++" [-watchmove +wachmove] if you wish to see the flying stones\n"
++" [-buttonmove +buttonmove] set stones by simply pressing button\n"
++" [-autoplay +autoplay] automatic play when only one move\n"
++" is possible\n"
++" [-stonesteps (number)] sets the stepsize the stones fly\n"
++" in pixel (implies +watchmove)\n"
++" [-delaytime (tsec.)] sets the time the cumputer waits\n"
++" after each turn (implies -watchmove)\n"
++" [-?] [-help] print this string");
+ exit (0);
+ } else {
+ fprintf (stderr,"xgammon: unknown option %s (ignored)\n", argv[option]);
diff --git a/games-board/xgammon/xgammon-0.98.ebuild b/games-board/xgammon/xgammon-0.98.ebuild
index 052d2a9947d4..2dbbd6e62556 100644
--- a/games-board/xgammon/xgammon-0.98.ebuild
+++ b/games-board/xgammon/xgammon-0.98.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/xgammon/xgammon-0.98.ebuild,v 1.4 2004/04/13 09:32:48 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/xgammon/xgammon-0.98.ebuild,v 1.5 2004/05/07 23:01:39 mr_bones_ Exp $
inherit eutils
-S=${WORKDIR}/${P}a
+S="${WORKDIR}/${P}a"
DESCRIPTION="very nice backgammon game for X"
HOMEPAGE="http://fawn.unibw-hamburg.de/steuer/xgammon/xgammon.html"
SRC_URI="http://fawn.unibw-hamburg.de/steuer/xgammon/Downloads/${P}a.tar.gz"
@@ -20,8 +20,9 @@ src_unpack() {
unpack ${A}
cd ${S}
- epatch ${FILESDIR}/xgammon-0.98-broken.patch
- epatch ${FILESDIR}/xgammon-0.98-config.patch
+ epatch "${FILESDIR}/${P}-broken.patch"
+ epatch "${FILESDIR}/${P}-config.patch"
+ epatch "${FILESDIR}/gcc33.patch"
}
src_compile() {