summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-12-30 00:41:23 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-12-30 00:41:23 +0000
commitb015422b9856e5fbad5836b1f306a35bb95046ed (patch)
treeed860577be5bc71ec51f16f0921548388709354d /games-board
parentversion bump (bug #74979); clean old ebuilds (diff)
downloadhistorical-b015422b9856e5fbad5836b1f306a35bb95046ed.tar.gz
historical-b015422b9856e5fbad5836b1f306a35bb95046ed.tar.bz2
historical-b015422b9856e5fbad5836b1f306a35bb95046ed.zip
gcc-34 patch from upstream (bug #69492)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/slibo/ChangeLog6
-rw-r--r--games-board/slibo/Manifest5
-rw-r--r--games-board/slibo/files/0.4.4-gcc34.patch51
-rw-r--r--games-board/slibo/slibo-0.4.4.ebuild17
4 files changed, 74 insertions, 5 deletions
diff --git a/games-board/slibo/ChangeLog b/games-board/slibo/ChangeLog
index ee9ca62bd845..46df7bf1abed 100644
--- a/games-board/slibo/ChangeLog
+++ b/games-board/slibo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/slibo
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/slibo/ChangeLog,v 1.6 2004/08/05 23:33:47 arj Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/slibo/ChangeLog,v 1.7 2004/12/30 00:41:23 mr_bones_ Exp $
+
+ 29 Dec 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/0.4.4-gcc34.patch, slibo-0.4.4.ebuild:
+ gcc-34 patch from upstream (bug #69492)
05 Aug 2004; Anders Rune Jensen <arj@gentoo.org> slibo-0.4.4.ebuild:
Depend on version 2 of sqlite.
diff --git a/games-board/slibo/Manifest b/games-board/slibo/Manifest
index e55317bc0e80..da9577e0852a 100644
--- a/games-board/slibo/Manifest
+++ b/games-board/slibo/Manifest
@@ -1,4 +1,5 @@
-MD5 a0e2a1d12f953ec515345d65c2c8e58d ChangeLog 646
-MD5 989aeee3a7829a2218e3bc61f421e60d slibo-0.4.4.ebuild 485
+MD5 75e91af84bd534d7cfb9fd86d2fe879b ChangeLog 798
+MD5 8a3f793fc831f69a2b8e179b20946af0 slibo-0.4.4.ebuild 810
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 edaca2f8718114ab18c48cda4794b2d1 files/digest-slibo-0.4.4 64
+MD5 2956467632bec1b5ec193090cccbdca9 files/0.4.4-gcc34.patch 2638
diff --git a/games-board/slibo/files/0.4.4-gcc34.patch b/games-board/slibo/files/0.4.4-gcc34.patch
new file mode 100644
index 000000000000..8b4bab4487d2
--- /dev/null
+++ b/games-board/slibo/files/0.4.4-gcc34.patch
@@ -0,0 +1,51 @@
+diff -r -U 2 /tmp/slibo-0.4.4/src/engine.cpp /var/tmp/portage/slibo-0.4.4/work/slibo-0.4.4/src/engine.cpp
+--- /tmp/slibo-0.4.4/src/engine.cpp 2003-08-31 18:23:45.000000000 +0200
++++ /var/tmp/portage/slibo-0.4.4/work/slibo-0.4.4/src/engine.cpp 2004-12-29 19:09:26.941957930 +0100
+@@ -18,4 +18,5 @@
+ #include <sys/types.h>
+ #include <signal.h>
++#include <errno.h>
+
+ #include <qmessagebox.h>
+@@ -80,5 +81,5 @@
+ //build argument list
+ int argc = (args.isEmpty()) ? 0 : args.contains(' ')+1;
+- argv = new (char *)[argc+1];
++ argv = new char *[argc+1];
+ int i;
+ argv[0] = strdup(fname.latin1());
+diff -r -U 2 /tmp/slibo-0.4.4/src/sliboengine/search.c /var/tmp/portage/slibo-0.4.4/work/slibo-0.4.4/src/sliboengine/search.c
+--- /tmp/slibo-0.4.4/src/sliboengine/search.c 2003-08-30 01:45:00.000000000 +0200
++++ /var/tmp/portage/slibo-0.4.4/work/slibo-0.4.4/src/sliboengine/search.c 2004-12-29 19:07:47.439235741 +0100
+@@ -68,7 +68,7 @@
+ FILE *logfile = 0;
+
+-static float searchq1(Board *, float beta, float alpha, int) __attribute__ ((regparm(1)));
+-static float searchq(Board *, float beta, float alpha, int) __attribute__ ((regparm(1)));
+-float search(Board *, int nullMove, int verifyNull, float beta, float alpha, int) __attribute__ ((regparm(1)));
++__attribute__ ((regparm(1))) static float searchq1(Board *, float beta, float alpha, int);
++__attribute__ ((regparm(1))) static float searchq(Board *, float beta, float alpha, int);
++__attribute__ ((regparm(1))) float search(Board *, int nullMove, int verifyNull, float beta, float alpha, int);
+
+ //main search function.
+@@ -78,5 +78,5 @@
+ //returns the score of the position and the best line.
+
+-float search(Board *b, int nullMove, int verifyNull, float alpha, float beta, int ply) {
++__attribute__((regparm(1))) float search(Board *b, int nullMove, int verifyNull, float alpha, float beta, int ply) {
+ static unsigned int clockCounter = 0;
+
+@@ -648,5 +648,5 @@
+ //of a caller of opposite color it always returns a value less or equal
+ //the current postion, which allows some optimizations.
+-float searchq(Board * b, float alpha, float beta, int ply) {
++__attribute__ ((regparm(1))) float searchq(Board * b, float alpha, float beta, int ply) {
+ BEGIN_PROFILE(TIME_SEARCHQ);
+ float bestEval;
+@@ -816,5 +816,5 @@
+ //of a caller of opposite color it always returns a value less or equal
+ //the current postion, which allows some optimizations.
+-float searchq1(Board * b, float alpha, float beta, int ply) {
++__attribute__ ((regparm(1))) float searchq1(Board * b, float alpha, float beta, int ply) {
+ BEGIN_PROFILE(TIME_SEARCHQ);
+ float bestEval;
diff --git a/games-board/slibo/slibo-0.4.4.ebuild b/games-board/slibo/slibo-0.4.4.ebuild
index 6a50f35e754f..adcb8ecb1a3f 100644
--- a/games-board/slibo/slibo-0.4.4.ebuild
+++ b/games-board/slibo/slibo-0.4.4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/slibo/slibo-0.4.4.ebuild,v 1.8 2004/12/11 06:55:13 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/slibo/slibo-0.4.4.ebuild,v 1.9 2004/12/30 00:41:23 mr_bones_ Exp $
-inherit kde
+inherit eutils kde
DESCRIPTION="A comfortable replacement for the xboard chess interface"
HOMEPAGE="http://slibo.sourceforge.net/"
@@ -15,3 +15,16 @@ IUSE=""
DEPEND="=dev-db/sqlite-2*"
need-kde 3
+
+src_unpack() {
+ kde_src_unpack
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-gcc34.patch"
+}
+
+pkg_postinst() {
+ einfo "If you updated from an older version, please do a"
+ einfo " rm ~/.kde/share/apps/slibo/sliboui.rc"
+ einfo "to get rid of old configuration files, otherwise"
+ einfo "new menu items etc. will not appear"
+}