summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2005-03-21 15:01:24 +0000
committerDon Seiler <rizzo@gentoo.org>2005-03-21 15:01:24 +0000
commitbf5fc004dbc564bd71a818a824d9d6b2ef4da656 (patch)
tree2414f1ff0651d19042cad6c1d5afb8fed30c226b /games-board
parentnew upstream release (development branch). (diff)
downloadhistorical-bf5fc004dbc564bd71a818a824d9d6b2ef4da656.tar.gz
historical-bf5fc004dbc564bd71a818a824d9d6b2ef4da656.tar.bz2
historical-bf5fc004dbc564bd71a818a824d9d6b2ef4da656.zip
Version bump
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'games-board')
-rw-r--r--games-board/gnocatan/ChangeLog7
-rw-r--r--games-board/gnocatan/Manifest4
-rw-r--r--games-board/gnocatan/files/digest-gnocatan-0.8.1.591
-rw-r--r--games-board/gnocatan/gnocatan-0.8.1.59.ebuild47
4 files changed, 57 insertions, 2 deletions
diff --git a/games-board/gnocatan/ChangeLog b/games-board/gnocatan/ChangeLog
index 574764e0d146..3953c96fcae3 100644
--- a/games-board/gnocatan/ChangeLog
+++ b/games-board/gnocatan/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/gnocatan
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/gnocatan/ChangeLog,v 1.33 2005/03/09 15:11:08 rizzo Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/gnocatan/ChangeLog,v 1.34 2005/03/21 15:01:24 rizzo Exp $
+
+*gnocatan-0.8.1.59 (21 Mar 2005)
+
+ 21 Mar 2005; Don Seiler <rizzo@gentoo.org> +gnocatan-0.8.1.59.ebuild:
+ Version bump
09 Mar 2005; Don Seiler <rizzo@gentoo.org> gnocatan-0.8.1.54.ebuild:
Depends on glib >= 2.0, fixes bug #84483. Thanks to Thomas Schürger.
diff --git a/games-board/gnocatan/Manifest b/games-board/gnocatan/Manifest
index b6ea79832eba..5eb35f134f77 100644
--- a/games-board/gnocatan/Manifest
+++ b/games-board/gnocatan/Manifest
@@ -1,4 +1,6 @@
-MD5 7335b68449fa474c86ce1c132837b7f9 ChangeLog 5826
+MD5 9a0e257907af70e65f3d4db8912f92a9 ChangeLog 5948
MD5 cfd29f58e6f9fb057c83c8eb26c1a101 metadata.xml 315
MD5 54304709b0efe9a98bf6a8bb6ea929e3 gnocatan-0.8.1.54.ebuild 1098
+MD5 40d01dfddd45a20fe8b1af2fc27d4965 gnocatan-0.8.1.59.ebuild 1099
+MD5 4e3c392ec0eb6076e0c6105856db8540 files/digest-gnocatan-0.8.1.59 70
MD5 f5cbb9df7d1f26c804a8e8886dc901de files/digest-gnocatan-0.8.1.54 70
diff --git a/games-board/gnocatan/files/digest-gnocatan-0.8.1.59 b/games-board/gnocatan/files/digest-gnocatan-0.8.1.59
new file mode 100644
index 000000000000..e20ac8901d1a
--- /dev/null
+++ b/games-board/gnocatan/files/digest-gnocatan-0.8.1.59
@@ -0,0 +1 @@
+MD5 909aeb08a3f4990ffa53f1769b3a5111 gnocatan-0.8.1.59.tar.gz 2074119
diff --git a/games-board/gnocatan/gnocatan-0.8.1.59.ebuild b/games-board/gnocatan/gnocatan-0.8.1.59.ebuild
new file mode 100644
index 000000000000..d43758399e0e
--- /dev/null
+++ b/games-board/gnocatan/gnocatan-0.8.1.59.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/gnocatan/gnocatan-0.8.1.59.ebuild,v 1.1 2005/03/21 15:01:24 rizzo Exp $
+
+inherit eutils gnome2 debug
+
+DESCRIPTION="A clone of the popular board game The Settlers of Catan"
+HOMEPAGE="http://gnocatan.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gnocatan/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="nls debug X"
+
+RDEPEND=">=dev-libs/glib-2.0
+ X? ( >=gnome-base/libgnomeui-2.6.1.1
+ >=app-text/scrollkeeper-0.3* )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ export G2CONF="${G2CONF} `use_enable nls`"
+ export G2CONF="${G2CONF} `use_enable debug`"
+
+ if use X ; then
+ gnome2_src_compile
+ else
+ einfo
+ einfo "Only building console server"
+ einfo
+
+ econf ${G2CONF} || die "./configure failure"
+ emake || die "emake failed"
+ fi
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog README COPYING INSTALL TODO NEWS"
+ if use X ; then
+ gnome2_src_install
+ else
+ make DESTDIR=${D} install
+ dodoc ${DOCS}
+ fi
+}