summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-09-12 10:04:41 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-09-12 10:04:41 +0000
commit151f8ded382b532999b9c73867dd21b047b1d036 (patch)
tree5aa95fcd4e7f2708573b7f042969509fde0dbc5e /games-emulation/fakenes
parentSmall fixes (diff)
downloadhistorical-151f8ded382b532999b9c73867dd21b047b1d036.tar.gz
historical-151f8ded382b532999b9c73867dd21b047b1d036.tar.bz2
historical-151f8ded382b532999b9c73867dd21b047b1d036.zip
make the patch use PV so I can clean easier later; no backticks
Diffstat (limited to 'games-emulation/fakenes')
-rw-r--r--games-emulation/fakenes/ChangeLog6
-rw-r--r--games-emulation/fakenes/fakenes-0.3.1.ebuild8
-rw-r--r--games-emulation/fakenes/files/0.3.1-allegro.patch55
3 files changed, 64 insertions, 5 deletions
diff --git a/games-emulation/fakenes/ChangeLog b/games-emulation/fakenes/ChangeLog
index 75a8147725a7..c144c4f4ef3a 100644
--- a/games-emulation/fakenes/ChangeLog
+++ b/games-emulation/fakenes/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/fakenes
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/fakenes/ChangeLog,v 1.7 2004/09/02 02:06:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fakenes/ChangeLog,v 1.8 2004/09/12 10:04:41 mr_bones_ Exp $
+
+ 12 Sep 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/0.3.1-allegro.patch, fakenes-0.3.1.ebuild:
+ make the patch use PV so I can clean easier later; no backticks
*fakenes-0.3.1 (01 Sep 2004)
diff --git a/games-emulation/fakenes/fakenes-0.3.1.ebuild b/games-emulation/fakenes/fakenes-0.3.1.ebuild
index 2f9f26a5b3d1..acf7e403d6cc 100644
--- a/games-emulation/fakenes/fakenes-0.3.1.ebuild
+++ b/games-emulation/fakenes/fakenes-0.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/fakenes/fakenes-0.3.1.ebuild,v 1.1 2004/09/02 02:06:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fakenes/fakenes-0.3.1.ebuild,v 1.2 2004/09/12 10:04:41 mr_bones_ Exp $
inherit eutils games
@@ -22,12 +22,12 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# this is a hack simply because upstream seems kind
# of dead atm ... if they ever revive, we can do this
# properly by making an autoconf patch ...
- epatch ${FILESDIR}/0.3.0-allegro.patch
+ epatch "${FILESDIR}/${PV}-allegro.patch"
if ! use fbcon ; then
sed -i \
-e '/sedfbme/s:.*::' \
@@ -54,7 +54,7 @@ src_unpack() {
src_compile() {
egamesconf \
--with-hawknl \
- `use_with zlib` \
+ $(use_with zlib) \
|| die
emake || die "emake failed"
}
diff --git a/games-emulation/fakenes/files/0.3.1-allegro.patch b/games-emulation/fakenes/files/0.3.1-allegro.patch
new file mode 100644
index 000000000000..646fe5a6f43c
--- /dev/null
+++ b/games-emulation/fakenes/files/0.3.1-allegro.patch
@@ -0,0 +1,55 @@
+--- src/gui.c.orig 2003-09-25 22:29:25.830731224 -0400
++++ src/gui.c 2003-09-25 22:30:29.575040616 -0400
+@@ -716,9 +716,9 @@
+
+ TOGGLE_MENU (options_video_driver_linux_menu, 4, (gfx_driver -> id == GFX_VBEAF));
+
+- TOGGLE_MENU (options_video_driver_linux_menu, 6, (gfx_driver -> id == GFX_FBCON));
++ TOGGLE_MENU (options_video_driver_linux_menu, 6, (gfx_driver -> id == GFX_FBCON)); //sedfbme
+
+- TOGGLE_MENU (options_video_driver_linux_menu, 8, (gfx_driver -> id == GFX_SVGALIB));
++ TOGGLE_MENU (options_video_driver_linux_menu, 8, (gfx_driver -> id == GFX_SVGALIB)); //sedsvgalibme
+
+ #endif
+
+@@ -3238,9 +3238,9 @@
+
+ DRIVER_MENU_HANDLER (linux, vesa_vbe_af, GFX_VBEAF)
+
+-DRIVER_MENU_HANDLER (linux, framebuffer, GFX_FBCON)
++DRIVER_MENU_HANDLER (linux, framebuffer, GFX_FBCON) //sedfbme
+
+-DRIVER_MENU_HANDLER (linux, svgalib, GFX_SVGALIB)
++DRIVER_MENU_HANDLER (linux, svgalib, GFX_SVGALIB) //sedsvgalibme
+
+ #endif
+
+--- src/include/gui/menus.h.orig 2003-09-25 22:29:33.099626184 -0400
++++ src/include/gui/menus.h 2003-09-25 22:31:12.231555840 -0400
+@@ -593,9 +593,9 @@
+
+ static int options_video_driver_linux_menu_vesa_vbe_af (void);
+
+-static int options_video_driver_linux_menu_framebuffer (void);
++static int options_video_driver_linux_menu_framebuffer (void); //sedfbme
+
+-static int options_video_driver_linux_menu_svgalib (void);
++static int options_video_driver_linux_menu_svgalib (void); //sedsvgalibme
+
+
+ static MENU options_video_driver_linux_menu [] =
+@@ -606,10 +606,10 @@
+ { "", NIL, NIL, 0, NIL },
+ { "VESA VBE/&AF", options_video_driver_linux_menu_vesa_vbe_af, NIL, 0, NIL },
+ { "", NIL, NIL, 0, NIL },
+- { "&Framebuffer", options_video_driver_linux_menu_framebuffer, NIL, 0, NIL },
+- { "", NIL, NIL, 0, NIL },
+- { "&SVGAlib", options_video_driver_linux_menu_svgalib, NIL, 0, NIL },
+- { NIL, NIL, NIL, 0, NIL }
++ { "&Framebuffer", options_video_driver_linux_menu_framebuffer, NIL, 0, NIL }, //sedfbme
++ { "", NIL, NIL, 0, NIL }, //sedfbme
++ { "&SVGAlib", options_video_driver_linux_menu_svgalib, NIL, 0, NIL }, //sedsvgalibme
++ { NIL, NIL, NIL, 0, NIL } //sedsvgalibme
+ };
+
+ #else