summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-07 07:46:26 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-07 07:46:26 +0000
commit6c99825a14b2a7b330d69f3e87ca84aee16d9fbe (patch)
treee76019b89a2d9e157a8dfee69045b9c685aa0804 /games-emulation/pcsx2
parentmake sure unrar worked (diff)
downloadhistorical-6c99825a14b2a7b330d69f3e87ca84aee16d9fbe.tar.gz
historical-6c99825a14b2a7b330d69f3e87ca84aee16d9fbe.tar.bz2
historical-6c99825a14b2a7b330d69f3e87ca84aee16d9fbe.zip
quote more and add USB support #65374 by Luke-Jr
Diffstat (limited to 'games-emulation/pcsx2')
-rw-r--r--games-emulation/pcsx2/Manifest10
-rw-r--r--games-emulation/pcsx2/files/pcsx245
2 files changed, 28 insertions, 27 deletions
diff --git a/games-emulation/pcsx2/Manifest b/games-emulation/pcsx2/Manifest
index cb9b74104d59..ce86e8e8465b 100644
--- a/games-emulation/pcsx2/Manifest
+++ b/games-emulation/pcsx2/Manifest
@@ -1,7 +1,9 @@
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 9451ba36170ab3bb1816ff11ac52030f pcsx2-0.8.1.ebuild 1439
-MD5 b71eba64749046828ebbba5bbc991c3a pcsx2-0.6.ebuild 1517
-MD5 2bd9f3e8e341d589221d84c9dcd5846d ChangeLog 814
+MD5 c682f106baa8968236f43cfed2bc5871 pcsx2-0.6.ebuild 1516
+MD5 1067681697ba11f950f2f50c21581f45 pcsx2-0.8.1.ebuild 1598
+MD5 4299324836422f7abde881ca0e6922c7 ChangeLog 948
MD5 7f767cd968c92287092f1677b680d93c files/digest-pcsx2-0.8.1 62
-MD5 7551d03e7ced84cf691f0d8669bff617 files/pcsx2 1343
+MD5 4117c94231158b69fecb21aa7f049626 files/pcsx2-0.8.1-amd64.patch 609
MD5 7824dc74e2dffea379d9aa075d6dbecd files/digest-pcsx2-0.6 62
+MD5 4bdc90cba4d2039218051770ee1fff2f files/pcsx2 1368
+MD5 98a9029664c06eed7f435badf6397b4d files/pcsx2.png 11497
diff --git a/games-emulation/pcsx2/files/pcsx2 b/games-emulation/pcsx2/files/pcsx2
index 5af3207aff9d..86bb52266e9f 100644
--- a/games-emulation/pcsx2/files/pcsx2
+++ b/games-emulation/pcsx2/files/pcsx2
@@ -1,23 +1,21 @@
#!/bin/bash
-source /sbin/functions.sh
+if [[ ! -f ${HOME}/.pcsx2/Pcsx2.cfg ]] ; then
+ echo You are running PCSX2 for the first time.
+ echo Setting up your PCSX2 environment... Please wait...
-if [ ! -f "${HOME}/.pcsx2/Pcsx2.cfg" ]; then
- einfo You are running PCSX2 for the first time.
- einfo Setting up your PCSX2 environment... Please wait...
-
- mkdir -p "${HOME}/.pcsx2"
- cd "${HOME}/.pcsx2"
+ mkdir -p "${HOME}"/.pcsx2
+ cd "${HOME}"/.pcsx2
mkdir Bios Docs Plugins host memcards snap
- ln -s GAMES_BINDIR/pcsx2.bin pcsx2
- ln -s GAMES_LIBDIR/ps2emu/plugins/* Plugins/
- ln -s GAMES_LIBDIR/ps2emu/Langs Langs
- ln -s GAMES_LIBDIR/ps2emu/cfg cfg
+ ln -s "GAMES_BINDIR"/pcsx2.bin pcsx2
+ ln -s "GAMES_LIBDIR"/ps2emu/plugins/* Plugins/
+ ln -s "GAMES_LIBDIR"/ps2emu/Langs Langs
+ ln -s "GAMES_LIBDIR"/ps2emu/cfg cfg
cd Bios
- if [ -f GAMES_LIBDIR/ps2emu/bios/scph1001.bin ]; then
- ln -s GAMES_LIBDIR/ps2emu/bios/scph1001.bin .
+ if [[ -f GAMES_LIBDIR/ps2emu/bios/scph1001.bin ]] ; then
+ ln -s "GAMES_LIBDIR"/ps2emu/bios/scph1001.bin .
biosname=scph1001.bin
else
biosname=HLE
@@ -25,14 +23,15 @@ if [ ! -f "${HOME}/.pcsx2/Pcsx2.cfg" ]; then
cd ..
firstplugin() { echo $(basename $(ls "$@" | cut -f1 -d\ ) ) 2>/dev/null ; }
- cat > "${HOME}/.pcsx2/Pcsx2.cfg" <<EOF
+ cat > "${HOME}"/.pcsx2/Pcsx2.cfg <<EOF
Bios = $biosname
-GS = $(firstplugin Plugins/libGS* )
-SPU2 = $(firstplugin Plugins/libSPU2* )
-CDVD = $(firstplugin Plugins/libCDVD* )
-PAD1 = $(firstplugin Plugins/libPADxwin* )
-PAD2 = $(firstplugin Plugins/libPADxwin* )
-DEV9 = $(firstplugin Plugins/libDEV9null* )
+GS = $(firstplugin Plugins/libGS*)
+SPU2 = $(firstplugin Plugins/libSPU2*)
+CDVD = $(firstplugin Plugins/libCDVD*)
+PAD1 = $(firstplugin Plugins/libPADxwin*)
+PAD2 = $(firstplugin Plugins/libPADxwin*)
+DEV9 = $(firstplugin Plugins/libDEV9null*)
+USB = $(firstplugin Plugins/libUSBlinuz*)
Mcd1 = ${HOME}/.pcsx2/memcards/Mcd001.mcr
Mcd2 = ${HOME}/.pcsx2/memcards/Mcd002.mcr
PluginsDir = ${HOME}/.pcsx2/Plugins/
@@ -45,9 +44,9 @@ EOF
fi
-cd "${HOME}/.pcsx2/"
+cd "${HOME}"/.pcsx2/
-ln -s GAMES_LIBDIR/ps2emu/cfg/* cfg/ &> /dev/null
-ln -s GAMES_LIBDIR/ps2emu/plugins/* plugins/ &> /dev/null
+ln -s "GAMES_LIBDIR"/ps2emu/cfg/* cfg/ &> /dev/null
+ln -s "GAMES_LIBDIR"/ps2emu/plugins/* plugins/ &> /dev/null
exec ./pcsx2 "$@"