summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-01-18 01:08:26 +0000
committerTim Harder <radhermit@gentoo.org>2013-01-18 01:08:26 +0000
commitdf8a31f234cd88cfdb2e0cf70b73862ec1b679ca (patch)
treea5398fac01e142eb5a2530f1f162f0aa76afc35f /games-emulation/vbam/vbam-9999.ebuild
parentWorks on alpha, tested on monolith.alpha.dev.gentoo.org. (diff)
downloadhistorical-df8a31f234cd88cfdb2e0cf70b73862ec1b679ca.tar.gz
historical-df8a31f234cd88cfdb2e0cf70b73862ec1b679ca.tar.bz2
historical-df8a31f234cd88cfdb2e0cf70b73862ec1b679ca.zip
Update live ebuild and call games_pkg_(pre|post)inst functions.
Package-Manager: portage-2.2.0_alpha154/cvs/Linux x86_64 Manifest-Sign-Key: 0x4AB3E85B4F064CA3
Diffstat (limited to 'games-emulation/vbam/vbam-9999.ebuild')
-rw-r--r--games-emulation/vbam/vbam-9999.ebuild30
1 files changed, 26 insertions, 4 deletions
diff --git a/games-emulation/vbam/vbam-9999.ebuild b/games-emulation/vbam/vbam-9999.ebuild
index b292a36eee85..0b5461717a86 100644
--- a/games-emulation/vbam/vbam-9999.ebuild
+++ b/games-emulation/vbam/vbam-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/vbam/vbam-9999.ebuild,v 1.2 2012/09/09 22:10:18 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/vbam/vbam-9999.ebuild,v 1.3 2013/01/18 01:08:23 radhermit Exp $
EAPI=4
WX_GTK_VER="2.8"
@@ -44,7 +44,8 @@ src_prepare() {
# Fix issue with zlib-1.2.5.1 macros (bug #383179)
sed -i '1i#define OF(x) x' src/common/memgzio.c || die
- sed -i -e "s:\(DESTINATION\) bin:\1 ${GAMES_BINDIR}:" CMakeLists.txt || die
+ sed -i "s:\(DESTINATION\) bin:\1 ${GAMES_BINDIR}:" \
+ CMakeLists.txt src/wx/CMakeLists.txt || die
}
src_configure() {
@@ -60,7 +61,6 @@ src_configure() {
$(cmake-utils_use_enable wxwidgets WX)
$(cmake-utils_use_enable x86 ASM_CORE)
$(cmake-utils_use_enable x86 ASM_SCALERS)
- -DCMAKE_INSTALL_PREFIX="${GAMES_PREFIX}"
-DCMAKE_SKIP_RPATH=ON
-DDATA_INSTALL_DIR=share/games/${PN}
)
@@ -81,3 +81,25 @@ src_install() {
prepgamesdirs
}
+
+pkg_preinst() {
+ games_pkg_preinst
+ if use gtk || use wxwidgets ; then
+ gnome2_icon_savelist
+ fi
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ if use gtk || use wxwidgets ; then
+ gnome2_icon_cache_update
+ fi
+ use gtk && fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ if use gtk || use wxwidgets ; then
+ gnome2_icon_cache_update
+ fi
+ use gtk && fdo-mime_desktop_database_update
+}