summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-06 02:07:05 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-06 02:07:05 +0000
commit2fa5575d73c229eecb5e77af533f5e9594907f78 (patch)
tree68817e12b057c7faca83a0eb85cbb64c0ccb19d1 /games-emulation
parentAdd switch capabilities #91182 by Ekatalog and BSD support #90847 by Diego Pe... (diff)
downloadhistorical-2fa5575d73c229eecb5e77af533f5e9594907f78.tar.gz
historical-2fa5575d73c229eecb5e77af533f5e9594907f78.tar.bz2
historical-2fa5575d73c229eecb5e77af533f5e9594907f78.zip
fix autotool usage #91567
Package-Manager: portage-2.0.51.21-r1
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/tuxnes/Manifest4
-rw-r--r--games-emulation/tuxnes/files/tuxnes-0.75-configure.in.patch (renamed from games-emulation/tuxnes/files/configure.in-tuxnes-0.75-gentoo.diff)21
-rw-r--r--games-emulation/tuxnes/tuxnes-0.75.ebuild30
3 files changed, 18 insertions, 37 deletions
diff --git a/games-emulation/tuxnes/Manifest b/games-emulation/tuxnes/Manifest
index 54abd597e5b3..85797cfb7edd 100644
--- a/games-emulation/tuxnes/Manifest
+++ b/games-emulation/tuxnes/Manifest
@@ -1,6 +1,6 @@
-MD5 105585fc749e36604e288052b7fa31d8 tuxnes-0.75.ebuild 1151
MD5 9c4b38765196a88da27cfe53917d0c1d ChangeLog 647
+MD5 1961a09b473c153821cce8a1ca7f5710 tuxnes-0.75.ebuild 1078
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 55a5bee2cd9089545a3b10f1833f5a9a files/digest-tuxnes-0.75 63
MD5 39e9a0b8849012419b53f70ddc8a8127 files/tuxnes-0.75-gcc34.patch 1068
-MD5 9369efb94f81b1043189d4f72ae048d7 files/configure.in-tuxnes-0.75-gentoo.diff 1739
+MD5 3f5e896bcd95b5bd6c6c8b3a9cb3c0ee files/tuxnes-0.75-configure.in.patch 1360
diff --git a/games-emulation/tuxnes/files/configure.in-tuxnes-0.75-gentoo.diff b/games-emulation/tuxnes/files/tuxnes-0.75-configure.in.patch
index 73204ae0e3da..06c011fc6298 100644
--- a/games-emulation/tuxnes/files/configure.in-tuxnes-0.75-gentoo.diff
+++ b/games-emulation/tuxnes/files/tuxnes-0.75-configure.in.patch
@@ -1,16 +1,15 @@
---- tuxnes-0.75/configure.in 2001-04-15 20:08:07.000000000 -0500
-+++ tuxnes-0.75-gentoo/configure.in 2002-12-03 00:38:41.000000000 -0500
-@@ -31,7 +31,8 @@
+--- tuxnes-0.75/configure.in
++++ tuxnes-0.75/configure.in
+@@ -31,7 +31,7 @@
dnl Don't assume we want high level optimisations, it is known to
dnl produce broken code on certain architectures using certain compilers
dnl --------------------------------------------------------------------
-CFLAGS="-O"
-+dnl We'll fix this the Gentoo way
+dnl CFLAGS="-O"
AC_SUBST(CFLAGS)
dnl --------------------------------------------------------------------
-@@ -46,12 +47,12 @@
+@@ -46,12 +46,10 @@
AC_ARG_ENABLE(warnings, [ --enable-warnings enable more compilation warning checks [default=no]], enable_warnings="yes", enable_warnings="no")
if test "x$enable_warnings" = "xyes"; then
@@ -19,14 +18,12 @@
-Wcast-align -Wcast-qual -Wchar-subscripts -Wconversion -Winline \
-Wmissing-prototypes -Wnested-externs -Wpointer-arith \
-Wredundant-decls -Wshadow -Wstrict-prototypes -Wwrite-strings"
- else
+-else
- CFLAGS="$CFLAGS -pipe -Wall"
-+ CFLAGS="$CFLAGS"
fi
AC_SUBST(CFLAGS)
-@@ -144,12 +145,9 @@
- [ --without-ggi disable check for GGI (General Graphics Interface)])
+@@ -144,10 +144,7 @@
if test "x$with_ggi" != "xno"; then
- OCPPFLAGS="$CPPFLAGS"
@@ -38,9 +35,3 @@
- CPPFLAGS="$OCPPFLAGS"
fi
- dnl --------------------------------------------------------------------
-@@ -210,3 +208,4 @@
- AC_CHECK_FUNCS(gettimeofday strtod strtoul)
-
- AC_OUTPUT(Makefile)
-+
diff --git a/games-emulation/tuxnes/tuxnes-0.75.ebuild b/games-emulation/tuxnes/tuxnes-0.75.ebuild
index 2f1ee454a9ae..5376e814dbd4 100644
--- a/games-emulation/tuxnes/tuxnes-0.75.ebuild
+++ b/games-emulation/tuxnes/tuxnes-0.75.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/tuxnes/tuxnes-0.75.ebuild,v 1.4 2004/09/27 15:04:28 sekretarz Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/tuxnes/tuxnes-0.75.ebuild,v 1.5 2005/05/06 02:07:05 vapier Exp $
inherit flag-o-matic eutils
@@ -19,36 +19,26 @@ DEPEND=">=media-libs/netpbm-9.12
src_unpack() {
unpack ${A}
- cd ${S}
-
- epatch ${FILESDIR}/configure.in-${P}-gentoo.diff
-
- #gcc-3.4 fix
- epatch ${FILESDIR}/${P}-gcc34.patch
-
- autoreconf &>/dev/null
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-configure.in.patch
+ epatch "${FILESDIR}"/${P}-gcc34.patch
+ export WANT_AUTOCONF=2.5
+ aclocal && automake && autoconf || die "autoconf failed"
}
src_compile() {
replace-flags "-O?" "-O"
-
- # Don't even bother checking for W windows
econf \
--without-w \
- `use_with ggi` \
- `use_with X x` \
+ $(use_with ggi) \
+ $(use_with X x) \
|| die
emake || die
}
src_install() {
- make DESTDIR=${D} install || die
-
- # Install pixmaps
- dodir /usr/share/pixmaps
+ make DESTDIR="${D}" install || die
insinto /usr/share/pixmaps
doins tuxnes.xpm tuxnes2.xpm
-
- # Install documentation
dodoc AUTHORS BUGS ChangeLog CHANGES INSTALL NEWS README THANKS
}