summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-07 07:49:02 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-07 07:49:02 +0000
commit551bd3e60b48711ad850dc12c50bb44a789917c5 (patch)
tree5c60ec6e0f96b2a6c2eba5d87b95f20a9cddcbb2 /games-emulation
parentfix versions (diff)
downloadhistorical-551bd3e60b48711ad850dc12c50bb44a789917c5.tar.gz
historical-551bd3e60b48711ad850dc12c50bb44a789917c5.tar.bz2
historical-551bd3e60b48711ad850dc12c50bb44a789917c5.zip
Add support for amd64 #65374.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/pcsx2/ChangeLog8
-rw-r--r--games-emulation/pcsx2/Manifest10
-rw-r--r--games-emulation/pcsx2/files/pcsx2-0.8.1-amd64.patch25
-rw-r--r--games-emulation/pcsx2/pcsx2-0.8.1.ebuild17
4 files changed, 51 insertions, 9 deletions
diff --git a/games-emulation/pcsx2/ChangeLog b/games-emulation/pcsx2/ChangeLog
index a0e46f7f6cb2..2ad89ba1fc68 100644
--- a/games-emulation/pcsx2/ChangeLog
+++ b/games-emulation/pcsx2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/pcsx2
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/pcsx2/ChangeLog,v 1.6 2005/08/04 04:49:29 mr_bones_ Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/pcsx2/ChangeLog,v 1.7 2005/08/07 07:49:02 vapier Exp $
+
+ 07 Aug 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/pcsx2-0.8.1-amd64.patch, pcsx2-0.8.1.ebuild:
+ Add support for amd64 #65374.
*pcsx2-0.8.1 (04 Aug 2005)
diff --git a/games-emulation/pcsx2/Manifest b/games-emulation/pcsx2/Manifest
index ce86e8e8465b..c54926de57b8 100644
--- a/games-emulation/pcsx2/Manifest
+++ b/games-emulation/pcsx2/Manifest
@@ -1,3 +1,6 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 c682f106baa8968236f43cfed2bc5871 pcsx2-0.6.ebuild 1516
MD5 1067681697ba11f950f2f50c21581f45 pcsx2-0.8.1.ebuild 1598
@@ -7,3 +10,10 @@ MD5 4117c94231158b69fecb21aa7f049626 files/pcsx2-0.8.1-amd64.patch 609
MD5 7824dc74e2dffea379d9aa075d6dbecd files/digest-pcsx2-0.6 62
MD5 4bdc90cba4d2039218051770ee1fff2f files/pcsx2 1368
MD5 98a9029664c06eed7f435badf6397b4d files/pcsx2.png 11497
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFC9b0FgIKl8Uu19MoRAuo5AJ96SRBSoWIZDS64Dn3LXj1hyTUtCwCffNGy
+/uS3FpqLA0ZIvLj3mWqa9ek=
+=Wl8G
+-----END PGP SIGNATURE-----
diff --git a/games-emulation/pcsx2/files/pcsx2-0.8.1-amd64.patch b/games-emulation/pcsx2/files/pcsx2-0.8.1-amd64.patch
new file mode 100644
index 000000000000..49ab0d803ebf
--- /dev/null
+++ b/games-emulation/pcsx2/files/pcsx2-0.8.1-amd64.patch
@@ -0,0 +1,25 @@
+--- x86/ix86/ix86_cpudetect.c.orig 2005-08-07 03:43:45.000000000 -0400
++++ x86/ix86/ix86_cpudetect.c 2005-08-07 03:44:23.000000000 -0400
+@@ -94,16 +94,19 @@
+
+ __asm__ __volatile__ (
+ #ifdef __x86_64__
++#define AX "%%rax"
+ "sub $0x18, %%rsp\n"
++#else
++#define AX "%%eax"
+ #endif
+ "pushf\n"
+- "pop %%eax\n"
++ "pop "AX"\n"
+ "mov %%eax, %%edx\n"
+ "xor $0x200000, %%eax\n"
+- "push %%eax\n"
++ "push "AX"\n"
+ "popf\n"
+ "pushf\n"
+- "pop %%eax\n"
++ "pop "AX"\n"
+ "xor %%edx, %%eax\n"
+ "mov %%eax, %0\n"
+ #ifdef __x86_64__
diff --git a/games-emulation/pcsx2/pcsx2-0.8.1.ebuild b/games-emulation/pcsx2/pcsx2-0.8.1.ebuild
index d048c1739279..92d84f1db9c5 100644
--- a/games-emulation/pcsx2/pcsx2-0.8.1.ebuild
+++ b/games-emulation/pcsx2/pcsx2-0.8.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/pcsx2/pcsx2-0.8.1.ebuild,v 1.1 2005/08/04 04:49:29 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/pcsx2/pcsx2-0.8.1.ebuild,v 1.2 2005/08/07 07:49:02 vapier Exp $
-inherit eutils games
+inherit games eutils toolchain-funcs
DESCRIPTION="Playstation2 emulator"
HOMEPAGE="http://www.pcsx2.net/"
@@ -10,7 +10,7 @@ SRC_URI="http://www.pcsx2.net/download/0.8release/${P}src.7z"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND="virtual/x11
@@ -19,9 +19,9 @@ RDEPEND="virtual/x11
>=games-emulation/ps2emu-cddvdlinuz-0.3-r1
>=games-emulation/ps2emu-cdvdiso-0.3
)
- >=games-emulation/ps2emu-gssoft-0.61
+ >=games-emulation/ps2emu-gssoft-0.6.1
>=games-emulation/ps2emu-padxwin-0.5
- >=games-emulation/ps2emu-spu2null-0.21
+ >=games-emulation/ps2emu-spu2null-0.2.1
>=games-emulation/ps2emu-dev9null-0.1"
DEPEND="${RDEPEND}
app-arch/p7zip"
@@ -29,11 +29,12 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${P}src
src_unpack() {
- cd "${WORKDIR}"
7z x "${DISTDIR}/${P}src.7z" || die "unpack failed"
cd "${S}"
+ epatch "${FILESDIR}"/${P}-amd64.patch
sed -i \
- -e "/^CC/d" \
+ -e '/^CC/d' \
+ -e "/^CPU/s:=.*:=$(tc-arch-kernel):" \
Linux/Makefile \
|| die "sed failed"
sed -i \
@@ -55,5 +56,7 @@ src_install() {
"${D}/${GAMES_BINDIR}/pcsx2" \
|| die "sed failed"
dodoc Docs/*.txt
+ doicon "${FILESDIR}"/pcsx2.png
+ make_desktop_entry pcsx2 PCSX2 pcsx2.png
prepgamesdirs
}