summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-08-27 02:58:10 +0000
committerMike Frysinger <vapier@gentoo.org>2004-08-27 02:58:10 +0000
commitb732c97d64e7624c89f016d8058290e096ee5c38 (patch)
tree7592b52271f0f33f239f241783e3b106a7012625 /games-emulation
parentstable on ppc64 (diff)
downloadhistorical-b732c97d64e7624c89f016d8058290e096ee5c38.tar.gz
historical-b732c97d64e7624c89f016d8058290e096ee5c38.tar.bz2
historical-b732c97d64e7624c89f016d8058290e096ee5c38.zip
fix endian issues #61531
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/fbzx/ChangeLog6
-rw-r--r--games-emulation/fbzx/Manifest15
-rw-r--r--games-emulation/fbzx/fbzx-1.4.ebuild20
-rw-r--r--games-emulation/fbzx/files/1.4-endian.patch13
4 files changed, 44 insertions, 10 deletions
diff --git a/games-emulation/fbzx/ChangeLog b/games-emulation/fbzx/ChangeLog
index 5d7f849eb31d..0d3f1edbadb8 100644
--- a/games-emulation/fbzx/ChangeLog
+++ b/games-emulation/fbzx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/fbzx
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/fbzx/ChangeLog,v 1.3 2004/06/24 22:26:41 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fbzx/ChangeLog,v 1.4 2004/08/27 02:58:10 vapier Exp $
+
+ 26 Aug 2004; Mike Frysinger <vapier@gentoo.org> +files/1.4-endian.patch,
+ fbzx-1.4.ebuild:
+ Fix endian issues (like on ppc) #61531 by Maciej J. Woloszyk.
22 Apr 2004; Michael Sterrett <mr_bones_@gentoo.org> fbzx-1.4.ebuild:
keyword for x86; depend on sed >= 4; use games eclass; error check; tidy
diff --git a/games-emulation/fbzx/Manifest b/games-emulation/fbzx/Manifest
index a89027f44183..dcd2878b66e5 100644
--- a/games-emulation/fbzx/Manifest
+++ b/games-emulation/fbzx/Manifest
@@ -1,4 +1,15 @@
-MD5 59c11991bbf51c331bb4a9d8fa5f7ff4 fbzx-1.4.ebuild 943
-MD5 5243842accab3c4b15123e3d506fba1c ChangeLog 483
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 d804f54048d2a6534405966a248ce117 ChangeLog 640
+MD5 be99481d23525a3dc0911a6ce9c1842d fbzx-1.4.ebuild 1066
MD5 81bd0669b341796d12149ac4952418db metadata.xml 373
+MD5 b9606b66bd75fa27b8eaf43a28f4a4f0 files/1.4-endian.patch 510
MD5 9cc8a2493a16d022735c1a3b790a2da8 files/digest-fbzx-1.4 58
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.9.10 (GNU/Linux)
+
+iD8DBQFBLqNIHTu7gpaalycRApU+AKDBvlQU3NIFt1DNbFbuH5U9RCHy5QCfTSW3
+bMmO8OXuZ+C9gWf7BsOdVi8=
+=LTWK
+-----END PGP SIGNATURE-----
diff --git a/games-emulation/fbzx/fbzx-1.4.ebuild b/games-emulation/fbzx/fbzx-1.4.ebuild
index 861c052101b0..c1162dbef920 100644
--- a/games-emulation/fbzx/fbzx-1.4.ebuild
+++ b/games-emulation/fbzx/fbzx-1.4.ebuild
@@ -1,32 +1,38 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/fbzx/fbzx-1.4.ebuild,v 1.4 2004/06/24 22:26:41 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fbzx/fbzx-1.4.ebuild,v 1.5 2004/08/27 02:58:10 vapier Exp $
-inherit games
+inherit games eutils gcc
-S="${WORKDIR}/${PN}"
DESCRIPTION="A Sinclair Spectrum emulator, designed to work at full screen using the FrameBuffer"
HOMEPAGE="http://www.rastersoft.com/fbzx.html"
SRC_URI="http://www.rastersoft.com/programas/fbzx/${PN}14.tar.gz"
LICENSE="GPL-2"
-KEYWORDS="x86 ~ppc"
SLOT="0"
+KEYWORDS="x86 ~ppc"
IUSE=""
RDEPEND="media-libs/libsdl"
DEPEND="${RDEPEND}
>=sys-apps/sed-4"
+S="${WORKDIR}/${PN}"
+
src_unpack() {
unpack ${A}
cd ${S}
sed -i \
- -e "s|/usr/share/spectrum|${GAMES_DATADIR}/${PN}|g" emulator.c \
- || die "sed failed"
+ -e "s|/usr/share/spectrum|${GAMES_DATADIR}/${PN}|g" \
+ emulator.c || die "sed failed"
+ sed -i \
+ -e "s:gcc:$(gcc-getCC):" \
+ -e "s:-O2:${CFLAGS}:" \
+ Makefile
+ epatch ${FILESDIR}/${PV}-endian.patch
}
-src_install () {
+src_install() {
dogamesbin fbzx || die "dogamesbin failed"
insinto "${GAMES_DATADIR}/${PN}/roms"
doins roms/* || die "doins failed"
diff --git a/games-emulation/fbzx/files/1.4-endian.patch b/games-emulation/fbzx/files/1.4-endian.patch
new file mode 100644
index 000000000000..f62dc67c5d5f
--- /dev/null
+++ b/games-emulation/fbzx/files/1.4-endian.patch
@@ -0,0 +1,13 @@
+--- fbzx/Z80.h 2003-12-19 21:37:22.000000000 +0100
++++ fbzx.new/Z80.h 2004-08-24 18:26:50.696481080 +0200
+@@ -12,7 +12,10 @@
+ /*************************************************************/
+ #ifndef Z80_H
+ #define Z80_H
++#include <endian.h>
++#if __BYTE_ORDER == __LITTLE_ENDIAN
+ #define LSB_FIRST
++#endif
+ /* Compilation options: */
+ /* #define DEBUG */ /* Compile debugging version */
+ /* #define LSB_FIRST */ /* Compile for low-endian CPU */