summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2005-01-10 01:15:05 +0000
committerDaniel Goller <morfic@gentoo.org>2005-01-10 01:15:05 +0000
commitdc8b9f7807551596c0077e7df40cc31f55ebf948 (patch)
tree5d3fde6ff0a8697f7043e13605c7a3cea8e91642 /games-emulation
parentInitial import (diff)
downloadhistorical-dc8b9f7807551596c0077e7df40cc31f55ebf948.tar.gz
historical-dc8b9f7807551596c0077e7df40cc31f55ebf948.tar.bz2
historical-dc8b9f7807551596c0077e7df40cc31f55ebf948.zip
More fixes here too
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/mupen64-riceplugin/ChangeLog11
-rw-r--r--games-emulation/mupen64-riceplugin/Manifest13
-rw-r--r--games-emulation/mupen64-riceplugin/files/mupen64-riceplugin-compile.patch214
-rw-r--r--games-emulation/mupen64-riceplugin/files/mupen64-riceplugin-gcc3.patch118
-rw-r--r--games-emulation/mupen64-riceplugin/files/mupen64-riceplugin-gtk2.patch15
-rw-r--r--games-emulation/mupen64-riceplugin/files/mupen64-riceplugin-makefile.patch27
6 files changed, 265 insertions, 133 deletions
diff --git a/games-emulation/mupen64-riceplugin/ChangeLog b/games-emulation/mupen64-riceplugin/ChangeLog
index 215979019d1a..b89d3fee715f 100644
--- a/games-emulation/mupen64-riceplugin/ChangeLog
+++ b/games-emulation/mupen64-riceplugin/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for games-emulation/mupen64-riceplugin
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-riceplugin/ChangeLog,v 1.3 2005/01/07 22:47:16 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-riceplugin/ChangeLog,v 1.4 2005/01/10 01:15:05 morfic Exp $
+
+ 09 Jan 2005; Daniel Goller <morfic@gentoo.org>
+ +files/mupen64-riceplugin-compile.patch,
+ -files/mupen64-riceplugin-gcc3.patch,
+ +files/mupen64-riceplugin-gtk2.patch,
+ files/mupen64-riceplugin-makefile.patch:
+ config dialog actually works with gtk2
+ combined gcc3 patch with other compile/runtime fixs into 1 patch
+ added nasm dep
07 Jan 2005; Daniel Goller <morfic@gentoo.org> metadata.xml:
Adding maintainer
diff --git a/games-emulation/mupen64-riceplugin/Manifest b/games-emulation/mupen64-riceplugin/Manifest
index 53de6f3271f0..ca7d1743c0da 100644
--- a/games-emulation/mupen64-riceplugin/Manifest
+++ b/games-emulation/mupen64-riceplugin/Manifest
@@ -1,16 +1,17 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 f2f988ffa7d3c52fd7361f4c49da89b8 ChangeLog 602
+MD5 beed3c515fde535d43e949724acd488b ChangeLog 945
MD5 9140e3cfb94c674129562155ae54045c mupen64-riceplugin-5.1.0.ebuild 1220
MD5 a3e62bf537d9a02609601aa9ba76da7e metadata.xml 247
-MD5 e2b006764c1bac03ac2667ad60a66101 files/mupen64-riceplugin-gcc3.patch 3662
-MD5 5b0d70ba016fdc0e4eaa098f99ee65f5 files/mupen64-riceplugin-makefile.patch 734
+MD5 45e5b555bb4c252b8ebe4731dd1229f8 files/mupen64-riceplugin-makefile.patch 1013
MD5 b3400316b9d64a4bda1c9d80e9e87717 files/digest-mupen64-riceplugin-5.1.0 63
+MD5 5818587f7353a1f0bc54a08443734016 files/mupen64-riceplugin-compile.patch 6601
+MD5 c79ad1f4cdadf86d6bf4fab101ea3ae5 files/mupen64-riceplugin-gtk2.patch 631
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)
-iD8DBQFB3xG4UpKYMelfdYERAvveAJ0WNXvn0QBO0SnRgvsw8BVUaKvkYACfYyOC
-yOqHrhi/Stcmo8OB9xCl2qM=
-=RpIt
+iD8DBQFB4ddgUpKYMelfdYERArj2AJ46viZNCa5qTH111IS5IqAUqLcZqQCdFxSz
+GzKXX/9m7gDTda1w8KYd3AE=
+=gi1+
-----END PGP SIGNATURE-----
diff --git a/games-emulation/mupen64-riceplugin/files/mupen64-riceplugin-compile.patch b/games-emulation/mupen64-riceplugin/files/mupen64-riceplugin-compile.patch
new file mode 100644
index 000000000000..b442b7ca2499
--- /dev/null
+++ b/games-emulation/mupen64-riceplugin/files/mupen64-riceplugin-compile.patch
@@ -0,0 +1,214 @@
+diff -ur riceplugin.old/Config.cpp riceplugin/Config.cpp
+--- riceplugin.old/Config.cpp 2003-09-05 09:28:35.000000000 -0700
++++ riceplugin/Config.cpp 2005-01-09 16:52:09.915439032 -0800
+@@ -148,9 +148,9 @@
+ const int numberOfOpenGLRenderEngineSettings = sizeof(OpenGLRenderSettings)/sizeof(RenderEngineSetting);
+
+ #define MAIN_RICE_DAEDALUS_4 "Software\\RICEDAEDALUS510\\WINDOW"
+-#define RICE_DAEDALUS_INI_FILE "RiceDaedalus5.1.0.ini"
++#define RICE_DAEDALUS_INI_FILE "/usr/games/lib/mupen64/plugins/RiceDaedalus5.1.0.ini"
+
+-#define CONFIG_FILE "RiceDaedalus.cfg"
++#define CONFIG_FILE "/RiceDaedalus.cfg"
+
+ void WriteConfiguration(void);
+ void GenerateCurrentRomOptions();
+diff -ur riceplugin.old/DaedalusGraphics.cpp riceplugin/DaedalusGraphics.cpp
+--- riceplugin.old/DaedalusGraphics.cpp 2003-09-04 17:12:40.000000000 -0700
++++ riceplugin/DaedalusGraphics.cpp 2005-01-09 16:38:02.452745942 -0800
+@@ -18,11 +18,16 @@
+ */
+ #include "stdafx.h"
+ #include "_BldNum.h"
++#include <assert.h>
+
+ #ifndef _WIN32
+ #include <unistd.h>
+ #include <stdarg.h>
+ #include "messagebox.h"
++#include <features.h>
++#include <dlfcn.h>
++#include <errno.h>
++#include <limits.h>
+ #endif
+
+ PluginStatus status;
+@@ -97,30 +102,31 @@
+ return TRUE;
+ }
+ #endif
+-
+-void GetPluginDir( char * Directory )
+-{
+-#ifdef _WIN32
+- char path_buffer[_MAX_PATH], drive[_MAX_DRIVE] ,dir[_MAX_DIR];
+- char fname[_MAX_FNAME],ext[_MAX_EXT];
+- GetModuleFileName(myhInst,path_buffer,sizeof(path_buffer));
+- _splitpath( path_buffer, drive, dir, fname, ext );
+- strcpy(Directory,drive);
+- strcat(Directory,dir);
+-#else // _WIN32
+- int n = readlink("/proc/self/exe", Directory, MAX_PATH);
+- if (n == -1)
+- strcpy(Directory, "./");
+- else
+- {
+- Directory[n] = '\0';
+- while(Directory[strlen(Directory)-1] != '/')
+- Directory[strlen(Directory)-1] = '\0';
+- }
+- strcat(Directory, "plugins/");
+-#endif //_WIN32
+-}
+-
++
++void GetPluginDir( char * Directory )
++{
++#ifdef __USE_GNU
++ Dl_info info;
++ void *addr = (void *)GetPluginDir;
++ if (dladdr( addr, &info ) != 0) {
++ strncpy( Directory, info.dli_fname, PATH_MAX );
++ *(strrchr( Directory, '/' )) = '\0';
++ } else {
++ fprintf( stderr, "(WW) Couldn't get Directory of .so, trying to get emulator's path\n" );
++#endif // __USE_GNU
++ if (readlink( "/proc/self/exe", Directory, PATH_MAX ) == -1)
++ {
++ fprintf( stderr, "(WW) readlink() /proc/self/exe fail ed: %s\n", strerror( errno ) );
++ Directory[0] = '.';
++ Directory[1] = '\0';
++ }
++ strcat( Directory, "/plugins/");
++#ifdef __USE_GNU
++ }
++#endif
++
++}
++
+ //-------------------------------------------------------------------------------------
+ __declspec(dllexport) void CALL GetDllInfo ( PLUGIN_INFO * PluginInfo )
+ {
+diff -ur riceplugin.old/DecodedMux.cpp riceplugin/DecodedMux.cpp
+--- riceplugin.old/DecodedMux.cpp 2003-08-28 13:39:21.000000000 -0700
++++ riceplugin/DecodedMux.cpp 2005-01-09 16:22:52.951517362 -0800
+@@ -760,7 +760,7 @@
+ ShadeConstMergeMapType MergeShadeWithConstantsMaps[] =
+ {
+ 0, SHADE_DO_NOTHING,
+- 0x0007000600070006, SHADE_MOD_ENV, // SHADE * ENV
++ SHADE_DO_NOTHING, SHADE_MOD_ENV, // SHADE * ENV
+ };
+
+ // 0x05070501, 0x00070006 //(1 - PRIM) * ENV + PRIM
+diff -ur riceplugin.old/IniFile.cpp riceplugin/IniFile.cpp
+--- riceplugin.old/IniFile.cpp 2003-09-03 07:49:33.000000000 -0700
++++ riceplugin/IniFile.cpp 2005-01-09 16:41:30.433074073 -0800
+@@ -115,10 +115,7 @@
+ char readinfo[100];
+ char trim[]="{}"; //remove first and last character
+
+- char filename[256];
+- GetPluginDir(filename);
+- strcat(filename,m_szFileName);
+- inifile.open(filename);
++ inifile.open(m_szFileName);
+
+ if (inifile.fail())
+ {
+Only in riceplugin: Makefile.orig
+diff -ur riceplugin.old/OGLCombinerTNT2.cpp riceplugin/OGLCombinerTNT2.cpp
+--- riceplugin.old/OGLCombinerTNT2.cpp 2003-08-29 06:50:40.000000000 -0700
++++ riceplugin/OGLCombinerTNT2.cpp 2005-01-09 16:22:52.952517258 -0800
+@@ -120,22 +120,22 @@
+
+ GLenum COGLColorCombinerTNT2::RGBArgsMap[] =
+ {
+- {GL_ZERO, }, //MUX_0
+- {GL_ZERO, }, //MUX_1
+- {GL_PREVIOUS_EXT, }, //MUX_COMBINED,
+- {GL_TEXTURE0_ARB, }, //MUX_TEXEL0,
+- {GL_TEXTURE1_ARB, }, //MUX_TEXEL1,
+- {GL_CONSTANT_EXT, }, //MUX_PRIM,
+- {GL_PRIMARY_COLOR_EXT, }, //MUX_SHADE,
+- {GL_CONSTANT_EXT, }, //MUX_ENV,
+- {GL_PREVIOUS_EXT, }, //MUX_COMBALPHA,
+- {GL_TEXTURE0_ARB, }, //MUX_T0_ALPHA,
+- {GL_TEXTURE1_ARB, }, //MUX_T1_ALPHA,
+- {GL_CONSTANT_EXT, }, //MUX_PRIM_ALPHA,
+- {GL_PRIMARY_COLOR_EXT, }, //MUX_SHADE_ALPHA,
+- {GL_CONSTANT_EXT, }, //MUX_ENV_ALPHA,
+- {GL_CONSTANT_EXT, }, //MUX_LODFRAC,
+- {GL_CONSTANT_EXT, }, //MUX_PRIMLODFRAC,
++ GL_ZERO,
++ GL_ZERO,
++ GL_PREVIOUS_EXT,
++ GL_TEXTURE0_ARB,
++ GL_TEXTURE1_ARB,
++ GL_CONSTANT_EXT,
++ GL_PRIMARY_COLOR_EXT,
++ GL_CONSTANT_EXT,
++ GL_PREVIOUS_EXT,
++ GL_TEXTURE0_ARB,
++ GL_TEXTURE1_ARB,
++ GL_CONSTANT_EXT,
++ GL_PRIMARY_COLOR_EXT,
++ GL_CONSTANT_EXT,
++ GL_CONSTANT_EXT,
++ GL_CONSTANT_EXT,
+ };
+
+
+diff -ur riceplugin.old/OGLExtCombiner.cpp riceplugin/OGLExtCombiner.cpp
+--- riceplugin.old/OGLExtCombiner.cpp 2003-08-28 14:31:44.000000000 -0700
++++ riceplugin/OGLExtCombiner.cpp 2005-01-09 16:22:52.953517154 -0800
+@@ -474,22 +474,22 @@
+
+ GLenum COGLExtColorCombiner::RGBArgsMap[] =
+ {
+- {GL_PRIMARY_COLOR_ARB, }, //MUX_0
+- {GL_PRIMARY_COLOR_ARB, }, //MUX_1
+- {GL_PREVIOUS_ARB, }, //MUX_COMBINED,
+- {GL_TEXTURE0_ARB, }, //MUX_TEXEL0,
+- {GL_TEXTURE1_ARB, }, //MUX_TEXEL1,
+- {GL_CONSTANT_ARB, }, //MUX_PRIM,
+- {GL_PRIMARY_COLOR_ARB, }, //MUX_SHADE,
+- {GL_CONSTANT_ARB, }, //MUX_ENV,
+- {GL_PREVIOUS_ARB, }, //MUX_COMBALPHA,
+- {GL_TEXTURE0_ARB, }, //MUX_T0_ALPHA,
+- {GL_TEXTURE1_ARB, }, //MUX_T1_ALPHA,
+- {GL_CONSTANT_ARB, }, //MUX_PRIM_ALPHA,
+- {GL_PRIMARY_COLOR_ARB, }, //MUX_SHADE_ALPHA,
+- {GL_CONSTANT_ARB, }, //MUX_ENV_ALPHA,
+- {GL_CONSTANT_ARB, }, //MUX_LODFRAC,
+- {GL_CONSTANT_ARB, }, //MUX_PRIMLODFRAC,
++ GL_PRIMARY_COLOR_ARB,
++ GL_PRIMARY_COLOR_ARB,
++ GL_PREVIOUS_ARB,
++ GL_TEXTURE0_ARB,
++ GL_TEXTURE1_ARB,
++ GL_CONSTANT_ARB,
++ GL_PRIMARY_COLOR_ARB,
++ GL_CONSTANT_ARB,
++ GL_PREVIOUS_ARB,
++ GL_TEXTURE0_ARB,
++ GL_TEXTURE1_ARB,
++ GL_CONSTANT_ARB,
++ GL_PRIMARY_COLOR_ARB,
++ GL_CONSTANT_ARB,
++ GL_CONSTANT_ARB,
++ GL_CONSTANT_ARB,
+ };
+
+
+diff -ur riceplugin.old/unique.h riceplugin/unique.h
+--- riceplugin.old/unique.h 2003-08-25 15:25:58.000000000 -0700
++++ riceplugin/unique.h 2005-01-09 16:22:52.953517154 -0800
+@@ -39,6 +39,7 @@
+ //
+ //
+
++#include <assert.h>
+ #ifdef _MSC_VER
+ #include <crtdbg.h>
+ #endif
diff --git a/games-emulation/mupen64-riceplugin/files/mupen64-riceplugin-gcc3.patch b/games-emulation/mupen64-riceplugin/files/mupen64-riceplugin-gcc3.patch
deleted file mode 100644
index 28a018e22e48..000000000000
--- a/games-emulation/mupen64-riceplugin/files/mupen64-riceplugin-gcc3.patch
+++ /dev/null
@@ -1,118 +0,0 @@
-diff -ur riceplugin.orig/DaedalusGraphics.cpp riceplugin/DaedalusGraphics.cpp
---- riceplugin.orig/DaedalusGraphics.cpp 2003-09-19 01:22:36.335328472 -0400
-+++ riceplugin/DaedalusGraphics.cpp 2003-09-19 01:22:36.470307952 -0400
-@@ -18,6 +18,7 @@
- */
- #include "stdafx.h"
- #include "_BldNum.h"
-+#include <assert.h>
-
- #ifndef _WIN32
- #include <unistd.h>
-diff -ur riceplugin.orig/DecodedMux.cpp riceplugin/DecodedMux.cpp
---- riceplugin.orig/DecodedMux.cpp 2003-09-19 01:22:36.366323760 -0400
-+++ riceplugin/DecodedMux.cpp 2003-09-19 01:22:48.379497480 -0400
-@@ -760,7 +760,7 @@
- ShadeConstMergeMapType MergeShadeWithConstantsMaps[] =
- {
- 0, SHADE_DO_NOTHING,
-- 0x0007000600070006, SHADE_MOD_ENV, // SHADE * ENV
-+ SHADE_DO_NOTHING, SHADE_MOD_ENV, // SHADE * ENV
- };
-
- // 0x05070501, 0x00070006 //(1 - PRIM) * ENV + PRIM
-diff -ur riceplugin.orig/OGLCombinerTNT2.cpp riceplugin/OGLCombinerTNT2.cpp
---- riceplugin.orig/OGLCombinerTNT2.cpp 2003-09-19 01:22:36.340327712 -0400
-+++ riceplugin/OGLCombinerTNT2.cpp 2003-09-19 01:25:36.859884568 -0400
-@@ -120,22 +120,22 @@
-
- GLenum COGLColorCombinerTNT2::RGBArgsMap[] =
- {
-- {GL_ZERO, }, //MUX_0
-- {GL_ZERO, }, //MUX_1
-- {GL_PREVIOUS_EXT, }, //MUX_COMBINED,
-- {GL_TEXTURE0_ARB, }, //MUX_TEXEL0,
-- {GL_TEXTURE1_ARB, }, //MUX_TEXEL1,
-- {GL_CONSTANT_EXT, }, //MUX_PRIM,
-- {GL_PRIMARY_COLOR_EXT, }, //MUX_SHADE,
-- {GL_CONSTANT_EXT, }, //MUX_ENV,
-- {GL_PREVIOUS_EXT, }, //MUX_COMBALPHA,
-- {GL_TEXTURE0_ARB, }, //MUX_T0_ALPHA,
-- {GL_TEXTURE1_ARB, }, //MUX_T1_ALPHA,
-- {GL_CONSTANT_EXT, }, //MUX_PRIM_ALPHA,
-- {GL_PRIMARY_COLOR_EXT, }, //MUX_SHADE_ALPHA,
-- {GL_CONSTANT_EXT, }, //MUX_ENV_ALPHA,
-- {GL_CONSTANT_EXT, }, //MUX_LODFRAC,
-- {GL_CONSTANT_EXT, }, //MUX_PRIMLODFRAC,
-+ GL_ZERO,
-+ GL_ZERO,
-+ GL_PREVIOUS_EXT,
-+ GL_TEXTURE0_ARB,
-+ GL_TEXTURE1_ARB,
-+ GL_CONSTANT_EXT,
-+ GL_PRIMARY_COLOR_EXT,
-+ GL_CONSTANT_EXT,
-+ GL_PREVIOUS_EXT,
-+ GL_TEXTURE0_ARB,
-+ GL_TEXTURE1_ARB,
-+ GL_CONSTANT_EXT,
-+ GL_PRIMARY_COLOR_EXT,
-+ GL_CONSTANT_EXT,
-+ GL_CONSTANT_EXT,
-+ GL_CONSTANT_EXT,
- };
-
-
-diff -ur riceplugin.orig/OGLExtCombiner.cpp riceplugin/OGLExtCombiner.cpp
---- riceplugin.orig/OGLExtCombiner.cpp 2003-09-19 01:22:36.371323000 -0400
-+++ riceplugin/OGLExtCombiner.cpp 2003-09-19 01:24:56.994944960 -0400
-@@ -474,22 +474,22 @@
-
- GLenum COGLExtColorCombiner::RGBArgsMap[] =
- {
-- {GL_PRIMARY_COLOR_ARB, }, //MUX_0
-- {GL_PRIMARY_COLOR_ARB, }, //MUX_1
-- {GL_PREVIOUS_ARB, }, //MUX_COMBINED,
-- {GL_TEXTURE0_ARB, }, //MUX_TEXEL0,
-- {GL_TEXTURE1_ARB, }, //MUX_TEXEL1,
-- {GL_CONSTANT_ARB, }, //MUX_PRIM,
-- {GL_PRIMARY_COLOR_ARB, }, //MUX_SHADE,
-- {GL_CONSTANT_ARB, }, //MUX_ENV,
-- {GL_PREVIOUS_ARB, }, //MUX_COMBALPHA,
-- {GL_TEXTURE0_ARB, }, //MUX_T0_ALPHA,
-- {GL_TEXTURE1_ARB, }, //MUX_T1_ALPHA,
-- {GL_CONSTANT_ARB, }, //MUX_PRIM_ALPHA,
-- {GL_PRIMARY_COLOR_ARB, }, //MUX_SHADE_ALPHA,
-- {GL_CONSTANT_ARB, }, //MUX_ENV_ALPHA,
-- {GL_CONSTANT_ARB, }, //MUX_LODFRAC,
-- {GL_CONSTANT_ARB, }, //MUX_PRIMLODFRAC,
-+ GL_PRIMARY_COLOR_ARB,
-+ GL_PRIMARY_COLOR_ARB,
-+ GL_PREVIOUS_ARB,
-+ GL_TEXTURE0_ARB,
-+ GL_TEXTURE1_ARB,
-+ GL_CONSTANT_ARB,
-+ GL_PRIMARY_COLOR_ARB,
-+ GL_CONSTANT_ARB,
-+ GL_PREVIOUS_ARB,
-+ GL_TEXTURE0_ARB,
-+ GL_TEXTURE1_ARB,
-+ GL_CONSTANT_ARB,
-+ GL_PRIMARY_COLOR_ARB,
-+ GL_CONSTANT_ARB,
-+ GL_CONSTANT_ARB,
-+ GL_CONSTANT_ARB,
- };
-
-
-diff -ur riceplugin.orig/unique.h riceplugin/unique.h
---- riceplugin.orig/unique.h 2003-09-19 01:22:36.336328320 -0400
-+++ riceplugin/unique.h 2003-09-19 01:22:36.473307496 -0400
-@@ -39,6 +39,7 @@
- //
- //
-
-+#include <assert.h>
- #ifdef _MSC_VER
- #include <crtdbg.h>
- #endif
diff --git a/games-emulation/mupen64-riceplugin/files/mupen64-riceplugin-gtk2.patch b/games-emulation/mupen64-riceplugin/files/mupen64-riceplugin-gtk2.patch
new file mode 100644
index 000000000000..299f3c75482d
--- /dev/null
+++ b/games-emulation/mupen64-riceplugin/files/mupen64-riceplugin-gtk2.patch
@@ -0,0 +1,15 @@
+--- riceplugin/Makefile.old 2005-01-09 15:01:48.512722168 -0800
++++ riceplugin/Makefile 2005-01-09 15:02:34.228618182 -0800
+@@ -1,10 +1,10 @@
+ CC = gcc
+ #CFLAGS = -DUSE_GTK `sdl-config --cflags` `gtk-config --cflags` -g -mmmx -msse
+-CFLAGS = -DUSE_GTK `sdl-config --cflags` `gtk-config --cflags`
++CFLAGS = -DUSE_GTK `sdl-config --cflags` `pkg-config --cflags gtk+-2.0 glib-2.0` -D_GTK2
+ CXX = g++
+ CPPFLAGS = $(CFLAGS)
+ LD = g++
+-LDFLAGS = -lGL -lGLU `sdl-config --libs` `gtk-config --libs`
++LDFLAGS = -lGL -lGLU `sdl-config --libs` `pkg-config --libs gtk+-2.0 glib-2.0`
+
+ OBJECTS = DaedalusGraphics.o \
+ DaedalusRenderBase.o \
diff --git a/games-emulation/mupen64-riceplugin/files/mupen64-riceplugin-makefile.patch b/games-emulation/mupen64-riceplugin/files/mupen64-riceplugin-makefile.patch
index f75301fea8d8..2539e438ceb2 100644
--- a/games-emulation/mupen64-riceplugin/files/mupen64-riceplugin-makefile.patch
+++ b/games-emulation/mupen64-riceplugin/files/mupen64-riceplugin-makefile.patch
@@ -1,14 +1,25 @@
---- riceplugin/Makefile.orig 2004-07-15 21:38:45.195293640 +0000
-+++ riceplugin/Makefile 2004-07-15 21:40:31.719099560 +0000
-@@ -1,8 +1,8 @@
+--- riceplugin/Makefile.old 2005-01-09 14:57:38.882829518 -0800
++++ riceplugin/Makefile 2005-01-09 14:59:26.839945436 -0800
+@@ -1,10 +1,10 @@
CC = gcc
--#CFLAGS = -DUSE_GTK `sdl-config --cflags` `gtk-config --cflags` -g -mmmx -msse
+ #CFLAGS = -DUSE_GTK `sdl-config --cflags` `gtk-config --cflags` -g -mmmx -msse
-CFLAGS = -DUSE_GTK `sdl-config --cflags` `gtk-config --cflags` -O3 -mcpu=athlon -ffast-math -funroll-loops -fomit-frame-pointer -msse -mmmx
+CFLAGS = -DUSE_GTK `sdl-config --cflags` `gtk-config --cflags`
-+#CFLAGS = -DUSE_GTK `sdl-config --cflags` `gtk-config --cflags` -O3 -mcpu=athlon -ffast-math -funroll-loops -fomit-frame-pointer -msse -mmmx
CXX = g++
--CPPFLAGS = $(CFLAGS)
-+CPPFLAGS = -DUSE_GTK `sdl-config --cflags` `gtk-config --cflags`
+ CPPFLAGS = $(CFLAGS)
LD = g++
- LDFLAGS = -lGL -lGLU -L/usr/X11R6/lib -lSDL
+-LDFLAGS = -lGL -lGLU -L/usr/X11R6/lib -lSDL
++LDFLAGS = -lGL -lGLU `sdl-config --libs` `gtk-config --libs`
+ OBJECTS = DaedalusGraphics.o \
+ DaedalusRenderBase.o \
+@@ -49,8 +49,7 @@
+ all: ricedaedalus.so instruction
+
+ ricedaedalus.so: $(OBJECTS)
+- $(LD) -shared -Wl,-Bsymbolic `gtk-config --libs` $(LDFLAGS) -o $@ $(OBJECTS)
+- strip --strip-all $@
++ $(LD) -shared -Wl,-Bsymbolic $(LDFLAGS) -o $@ $(OBJECTS)
+
+ instruction:
+ $(warning please copy ricedaedalus.so AND RiceDaedalus5.1.0.ini in the plugins/ folder of the emulator)