summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-03-23 03:19:31 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-03-23 03:19:31 +0000
commite11767bffc0f7b6be82a8d2213b4463a799b8422 (patch)
tree7eb6334d25dadec9f1411885a9bda2c2347ecb78 /games-emulation
parentversion bump (diff)
downloadhistorical-e11767bffc0f7b6be82a8d2213b4463a799b8422.tar.gz
historical-e11767bffc0f7b6be82a8d2213b4463a799b8422.tar.bz2
historical-e11767bffc0f7b6be82a8d2213b4463a799b8422.zip
sync with xmess ebuild
Package-Manager: portage-2.1_pre6-r5
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/xmame/ChangeLog5
-rw-r--r--games-emulation/xmame/xmame-0.104.ebuild17
2 files changed, 16 insertions, 6 deletions
diff --git a/games-emulation/xmame/ChangeLog b/games-emulation/xmame/ChangeLog
index c8182ac07626..7a564c9171de 100644
--- a/games-emulation/xmame/ChangeLog
+++ b/games-emulation/xmame/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/xmame
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/ChangeLog,v 1.61 2006/02/22 22:16:38 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/ChangeLog,v 1.62 2006/03/23 03:19:31 mr_bones_ Exp $
+
+ 23 Mar 2006; Michael Sterrett <mr_bones_@gentoo.org> xmame-0.104.ebuild:
+ sync with xmess ebuild
*xmame-0.104 (22 Feb 2006)
diff --git a/games-emulation/xmame/xmame-0.104.ebuild b/games-emulation/xmame/xmame-0.104.ebuild
index 65ebcf73a776..627b104da580 100644
--- a/games-emulation/xmame/xmame-0.104.ebuild
+++ b/games-emulation/xmame/xmame-0.104.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/xmame-0.104.ebuild,v 1.1 2006/02/22 22:16:38 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/xmame-0.104.ebuild,v 1.2 2006/03/23 03:19:31 mr_bones_ Exp $
inherit flag-o-matic toolchain-funcs eutils games
@@ -172,7 +172,8 @@ src_compile() {
}
src_install() {
- local disp=0
+ local disp=0, f
+ local utils="chdman imgtool dat2html"
sed -i \
-e "s:^PREFIX.*:PREFIX=${D}/usr:" \
@@ -199,13 +200,17 @@ src_install() {
make DISPLAY_METHOD=x11 install || die "install failed (x11)"
fi
exeinto "${GAMES_LIBDIR}/${PN}"
- doexe chdman || die "doexe failed"
+ for f in $utils
+ do
+ doexe $f || die "doexe failed"
+ rm -f "${D}${GAMES_BINDIR}"/$f 2> /dev/null
+ done
if [[ ${PN} == "xmame" ]] ; then
doexe xml2info || die "doexe failed"
fi
- dodir "${GAMES_DATADIR}/${PN}"
- cp -r ctrlr "${D}/${GAMES_DATADIR}/${PN}/" || die "cp failed"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r ctrlr || die "doins failed"
dodoc doc/{changes.*,*.txt,mame/*,${TARGET}rc.dist} README todo \
|| die "dodoc failed"
dohtml -r doc/* || die "dohtml failed"
@@ -232,4 +237,6 @@ pkg_postinst() {
useq sdl && einfo " ${TARGET}.SDL"
#useq ggi && einfo " ${TARGET}.ggi"
useq svga && einfo " ${TARGET}.svgalib"
+
+ einfo "Helper utilities are located in ${GAMES_LIBDIR}/${PN}."
}