summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-03-16 09:54:43 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-03-16 09:54:43 +0000
commit6a73110d29edc4e6a2d17c6eb79edca4f03107d9 (patch)
tree4689084ff260727aaf357afbc4192652d1d16986 /games-engines
parentCleanup (diff)
downloadhistorical-6a73110d29edc4e6a2d17c6eb79edca4f03107d9.tar.gz
historical-6a73110d29edc4e6a2d17c6eb79edca4f03107d9.tar.bz2
historical-6a73110d29edc4e6a2d17c6eb79edca4f03107d9.zip
version bump (bug #44809)
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/scummvm/ChangeLog9
-rw-r--r--games-engines/scummvm/Manifest8
-rw-r--r--games-engines/scummvm/files/digest-scummvm-0.6.01
-rw-r--r--games-engines/scummvm/scummvm-0.6.0.ebuild57
4 files changed, 70 insertions, 5 deletions
diff --git a/games-engines/scummvm/ChangeLog b/games-engines/scummvm/ChangeLog
index d675a703cc43..2b3882085d08 100644
--- a/games-engines/scummvm/ChangeLog
+++ b/games-engines/scummvm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-engines/scummvm
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.4 2004/01/02 18:53:00 mr_bones_ Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.5 2004/03/16 09:54:43 mr_bones_ Exp $
+
+*scummvm-0.6.0 (16 Mar 2004)
+
+ 16 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> scummvm-0.6.0.ebuild:
+ version bump (bug #44809); ebuild submitted by Stephan Schiffel
02 Jan 2004; Michael Sterrett <mr_bones_@gentoo.org> scummvm-0.5.1.ebuild,
files/0.5.1-alsa.patch:
diff --git a/games-engines/scummvm/Manifest b/games-engines/scummvm/Manifest
index 47a738609039..4ca73cfc20bf 100644
--- a/games-engines/scummvm/Manifest
+++ b/games-engines/scummvm/Manifest
@@ -1,5 +1,7 @@
-MD5 295f121c8d01de8db47930432fdcbed2 ChangeLog 2835
-MD5 50e403116f0db8644ca90a60fafaafd8 scummvm-0.5.1.ebuild 1502
-MD5 a30c9d4ce8f9629d6d7323eaab258343 metadata.xml 241
+MD5 602c52fbd735b18e214c1b44b25affeb ChangeLog 3009
+MD5 785b1561415a32cb30d298e0c0c3c07f scummvm-0.5.1.ebuild 1439
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 1b82a34476d4c2ce381a228c7859ca12 scummvm-0.6.0.ebuild 1470
MD5 ece3781510db9d2d60fcabd88eb576a8 files/0.5.1-alsa.patch 777
MD5 a05cefcb4e86dbf7d1c4592029bf7195 files/digest-scummvm-0.5.1 67
+MD5 11d226ec4661788cb3461a72f253cd63 files/digest-scummvm-0.6.0 67
diff --git a/games-engines/scummvm/files/digest-scummvm-0.6.0 b/games-engines/scummvm/files/digest-scummvm-0.6.0
new file mode 100644
index 000000000000..885bcbbc1bb7
--- /dev/null
+++ b/games-engines/scummvm/files/digest-scummvm-0.6.0
@@ -0,0 +1 @@
+MD5 efc4207a7f10b24e9fc5afa10ed9c455 scummvm-0.6.0.tar.bz2 1631951
diff --git a/games-engines/scummvm/scummvm-0.6.0.ebuild b/games-engines/scummvm/scummvm-0.6.0.ebuild
new file mode 100644
index 000000000000..c9967450d730
--- /dev/null
+++ b/games-engines/scummvm/scummvm-0.6.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-0.6.0.ebuild,v 1.1 2004/03/16 09:54:43 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="Reimplementation of the SCUMM game engine used in Lucasarts adventures"
+HOMEPAGE="http://scummvm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/scummvm/${P}.tar.bz2"
+
+use debug && RESTRICT="nostrip"
+KEYWORDS="x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="alsa debug mad oggvorbis sdl zlib"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ >media-libs/libmpeg2-0.3.1
+ sdl? ( >=media-libs/libsdl-1.2.2 )
+ oggvorbis? (
+ media-libs/libogg
+ media-libs/libvorbis
+ )
+ alsa? ( >=media-libs/alsa-lib-0.9 )
+ mad? ( media-libs/libmad )
+ zlib? ( sys-libs/zlib )"
+
+src_compile() {
+ local myconf=
+
+ use sdl \
+ && myconf="${myconf} --backend=sdl" \
+ || myconf="${myconf} --backend=x11"
+ use debug \
+ || myconf="${myconf} --disable-debug"
+
+ # not an autoconf script.
+ ./configure \
+ `use_enable alsa` \
+ `use_enable mad` \
+ `use_enable oggvorbis vorbis` \
+ `use_enable zlib` \
+ ${myconf} \
+ || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dogamesbin scummvm || die "dobin failed"
+ doman scummvm.6 || die "doman failed"
+ dodoc NEWS README TODO || die "dodoc failed"
+ insinto /usr/share/pixmaps
+ doins scummvm.xpm || die "doins failed"
+ make_desktop_entry scummvm ScummVM
+ prepgamesdirs
+}