summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-10-24 22:56:55 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-10-24 22:56:55 +0000
commit872f65f3bc63db411e72e3a9c92f3eb15d21402d (patch)
tree9130d8d2674fcfa1140f88642b1a59a78768ffc8 /games-fps/tribes2/tribes2-25034.ebuild
parentMoved cdrom_get_cds to src_unpack since binary packages don't require the ori... (diff)
downloadhistorical-872f65f3bc63db411e72e3a9c92f3eb15d21402d.tar.gz
historical-872f65f3bc63db411e72e3a9c92f3eb15d21402d.tar.bz2
historical-872f65f3bc63db411e72e3a9c92f3eb15d21402d.zip
Moved cdrom_get_cds to src_unpack since binary packages don't require the original media to install as well as some general cleanup.
Package-Manager: portage-2.1.2_pre3-r5
Diffstat (limited to 'games-fps/tribes2/tribes2-25034.ebuild')
-rw-r--r--games-fps/tribes2/tribes2-25034.ebuild23
1 files changed, 12 insertions, 11 deletions
diff --git a/games-fps/tribes2/tribes2-25034.ebuild b/games-fps/tribes2/tribes2-25034.ebuild
index cbabac1b785a..bd1ba414fbcc 100644
--- a/games-fps/tribes2/tribes2-25034.ebuild
+++ b/games-fps/tribes2/tribes2-25034.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/tribes2/tribes2-25034.ebuild,v 1.13 2006/04/13 21:13:57 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/tribes2/tribes2-25034.ebuild,v 1.14 2006/10/24 22:56:55 wolf31o2 Exp $
inherit eutils games
@@ -29,35 +29,36 @@ Ddir=${D}/${dir}
pkg_setup() {
games_pkg_setup
ewarn "The installed game takes about 507MB of space!"
- cdrom_get_cds README.tribes2d
}
src_unpack() {
- unpack_makeself || die "unpacking patch"
+ cdrom_get_cds README.tribes2d
+ unpack_makeself
}
src_install() {
- dodir ${dir}
einfo "Copying files... this may take a while..."
- exeinto ${dir}
+ exeinto "${dir}"
doexe ${CDROM_ROOT}/bin/x86/glibc-2.1/{t2launch,tribes2,tribes2.dynamic,tribes2d,tribes2d-restart.sh,tribes2d.dynamic} || die "doexe failed"
- cp ${CDROM_ROOT}/{README,README.tribes2d,Tribes2_Manual.pdf,console_start.cs,kver.pub} ${Ddir} || die "copy failed"
+ insinto "${dir}"
+ doins ${CDROM_ROOT}/{README,README.tribes2d,Tribes2_Manual.pdf,console_start.cs,kver.pub} ${Ddir} || die "copy failed"
# Video card profiles
- tar xzf ${CDROM_ROOT}/profiles.tar.gz -C ${Ddir} || die "uncompressing profiles"
+ # TODO: move this to src_unpack where it belongs.
+ tar xzf ${CDROM_ROOT}/profiles.tar.gz -C "${Ddir}" || die "uncompressing profiles"
# Base (Music, Textures, Maps, etc.)
- cp -rf ${CDROM_ROOT}/base ${CDROM_ROOT}/menu ${Ddir} || die "copying data"
+ doins -r ${CDROM_ROOT}/base ${CDROM_ROOT}/menu || die "copying data"
- cd ${S}
+ cd "${S}"
loki_patch --verify patch.dat
- loki_patch patch.dat ${Ddir} >& /dev/null || die "patching"
+ loki_patch patch.dat "${Ddir}" >& /dev/null || die "patching"
# now, since these files are coming off a cd, the times/sizes/md5sums wont
# be different ... that means portage will try to unmerge some files (!)
# we run touch on ${D} so as to make sure portage doesnt do any such thing
- find ${Ddir} -exec touch '{}' \;
+ find "${Ddir}" -exec touch '{}' \;
newicon ${CDROM_ROOT}/icon.xpm tribes2.xpm
games_make_wrapper t2launch ./t2launch "${dir}" "${dir}"