summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-09-22 18:05:20 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-09-22 18:05:20 +0000
commit1396c35c35c843805f2e0934326d546625bd9a40 (patch)
treeb616a8eebc7df9430a8d4a94f44de21b8c3ff445 /games-fps
parentBump for #380517 (diff)
downloadhistorical-1396c35c35c843805f2e0934326d546625bd9a40.tar.gz
historical-1396c35c35c843805f2e0934326d546625bd9a40.tar.bz2
historical-1396c35c35c843805f2e0934326d546625bd9a40.zip
try to work around broken Makefiles (bug #383517)
Package-Manager: portage-2.1.10.11/cvs/Linux i686
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/xonotic/ChangeLog5
-rw-r--r--games-fps/xonotic/Manifest4
-rw-r--r--games-fps/xonotic/xonotic-0.5.0.ebuild15
3 files changed, 14 insertions, 10 deletions
diff --git a/games-fps/xonotic/ChangeLog b/games-fps/xonotic/ChangeLog
index 36275e4414ad..a9930666e341 100644
--- a/games-fps/xonotic/ChangeLog
+++ b/games-fps/xonotic/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-fps/xonotic
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/xonotic/ChangeLog,v 1.1 2011/09/16 21:52:12 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/xonotic/ChangeLog,v 1.2 2011/09/22 18:05:20 mr_bones_ Exp $
+
+ 22 Sep 2011; Michael Sterrett <mr_bones_@gentoo.org> xonotic-0.5.0.ebuild:
+ try to work around broken Makefiles (bug #383517)
*xonotic-0.5.0 (16 Sep 2011)
diff --git a/games-fps/xonotic/Manifest b/games-fps/xonotic/Manifest
index f7e9929931dc..b48d551fb434 100644
--- a/games-fps/xonotic/Manifest
+++ b/games-fps/xonotic/Manifest
@@ -1,4 +1,4 @@
DIST xonotic-0.5.0.zip 988512100 RMD160 92a56d33c11d78884639fd0d5095589ff86b8fe0 SHA1 716135609ef953f2fbed97bd6a3cf116b7afd7a9 SHA256 58e7226a8b534858f8161c378071f4dab168e2c683f1f986e6e65be75a5b730f
-EBUILD xonotic-0.5.0.ebuild 2414 RMD160 72e782fedf9bbbb814ee3822e4cdab944cfd0e63 SHA1 979a69cf72266cd0b57486a25c1e7617be3e2a3a SHA256 77667bd9a4314fb700869039a8ef6bdcef5fc7d7fa4d5a0d0e9ffed599f2dbb4
-MISC ChangeLog 413 RMD160 1917de950bdb89d1da899288780674930f49862b SHA1 4bdf5d15ea2d84d27a1cf855f489d853c45e6e2f SHA256 418a376236826c8db212ef92c36c7459201d31041f0cc4728dce2207cf01b2d2
+EBUILD xonotic-0.5.0.ebuild 2439 RMD160 4fb7773c5ab5928195526dd9b0969aeed8f7f718 SHA1 a383fe555e6300da97b781ee02c8202d359d00cb SHA256 ad655bcd94949e66d34dd4ed1b416be6e1ea8c5dbc1cd4dd8c9c230fa294ee07
+MISC ChangeLog 543 RMD160 8031132cf0120eb1659204aad04317dc36a90ce5 SHA1 bf3b2e3ec2110b2c0b3a05aa710104801eaf5eb8 SHA256 94edc0c6442fefffca81524460d230dcc4b69ce471c51da10fabb2b49eb02223
MISC metadata.xml 158 RMD160 cbd9984bb6b426c8c9cee5022fe0a26261612fea SHA1 be5251fa1dacef5c41b74761bb1c8c54fb633b9e SHA256 1423a4fdd4a79b1728a2056d9e300f7e1074253095d82726218d9e9b953888a3
diff --git a/games-fps/xonotic/xonotic-0.5.0.ebuild b/games-fps/xonotic/xonotic-0.5.0.ebuild
index 721b16e465e4..0433b178b362 100644
--- a/games-fps/xonotic/xonotic-0.5.0.ebuild
+++ b/games-fps/xonotic/xonotic-0.5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/xonotic/xonotic-0.5.0.ebuild,v 1.1 2011/09/16 21:52:12 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/xonotic/xonotic-0.5.0.ebuild,v 1.2 2011/09/22 18:05:20 mr_bones_ Exp $
EAPI=2
inherit eutils check-reqs games
@@ -73,13 +73,14 @@ src_prepare() {
src_compile() {
local t="$(use debug && echo debug || echo release)"
+ local d
- emake \
- -C source/darkplaces \
- DP_LINK_TO_LIBJPEG=1 DP_FS_BASEDIR="${GAMES_DATADIR}/${PN}" \
- sv-${t} \
- $(use !dedicated && echo "cl-${t} $(use sdl && echo sdl-${t})") \
- || die
+ for d in sv-${t} $(use !dedicated && echo "cl-${t} $(use sdl && echo sdl-${t})")
+ do
+ emake \
+ DP_LINK_TO_LIBJPEG=1 DP_FS_BASEDIR="${GAMES_DATADIR}/${PN}" \
+ -C source/darkplaces ${d} || die
+ done
}
src_install() {