summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-05-21 17:50:13 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-05-21 17:50:13 +0000
commit1a80775dfc69d7593812928b30ea606bc6920a47 (patch)
tree193980d7df1d914481f8eba0d2ccd7a946dc0673 /games-fps
parentstable on amd64, ppc and x86. introduced support for the jikes useflag (diff)
downloadhistorical-1a80775dfc69d7593812928b30ea606bc6920a47.tar.gz
historical-1a80775dfc69d7593812928b30ea606bc6920a47.tar.bz2
historical-1a80775dfc69d7593812928b30ea606bc6920a47.zip
fix bug #93446; tidy
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/prboom/Manifest8
-rw-r--r--games-fps/prboom/prboom-2.2.4-r1.ebuild31
2 files changed, 23 insertions, 16 deletions
diff --git a/games-fps/prboom/Manifest b/games-fps/prboom/Manifest
index 24ab81e082cf..2cc4b398e4f3 100644
--- a/games-fps/prboom/Manifest
+++ b/games-fps/prboom/Manifest
@@ -1,7 +1,7 @@
-MD5 09000b64648032b10dd0bc90b482378d prboom-2.2.4-r1.ebuild 1568
-MD5 7f9a6ca184700e20a19f5d2da444ecfb ChangeLog 1496
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 d8fff22fba51330be33cc8905f81d425 files/2.2.4-nvidia.patch 1761
-MD5 e3d9b24d0bbddd7177cdc13ec010c225 files/2.2.4-gcc34.patch 629
+MD5 95f50e7198021cc489cc79394c9a5762 prboom-2.2.4-r1.ebuild 1717
+MD5 7f9a6ca184700e20a19f5d2da444ecfb ChangeLog 1496
MD5 1f849cf0b94a12ff9f846fc538f27b83 files/digest-prboom-2.2.4-r1 65
+MD5 d8fff22fba51330be33cc8905f81d425 files/2.2.4-nvidia.patch 1761
MD5 6baf3ffdd34dfe4b85618dd603616a80 files/2.2.4-nvidia-test.c 90
+MD5 e3d9b24d0bbddd7177cdc13ec010c225 files/2.2.4-gcc34.patch 629
diff --git a/games-fps/prboom/prboom-2.2.4-r1.ebuild b/games-fps/prboom/prboom-2.2.4-r1.ebuild
index 544c53e0e844..c9dcfdfa8e92 100644
--- a/games-fps/prboom/prboom-2.2.4-r1.ebuild
+++ b/games-fps/prboom/prboom-2.2.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/prboom/prboom-2.2.4-r1.ebuild,v 1.4 2005/05/17 18:26:32 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/prboom/prboom-2.2.4-r1.ebuild,v 1.5 2005/05/21 17:50:13 mr_bones_ Exp $
inherit eutils toolchain-funcs games
@@ -22,12 +22,13 @@ DEPEND="virtual/x11
src_unpack() {
unpack ${A}
- epatch ${FILESDIR}/${PV}-gcc34.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-gcc34.patch
ebegin "Detecting NVidia GL/prboom bug"
- $(tc-getCC) ${FILESDIR}/${PV}-nvidia-test.c 2> /dev/null
+ $(tc-getCC) "${FILESDIR}"/${PV}-nvidia-test.c 2> /dev/null
local ret=$?
eend ${ret} "NVidia GL/prboom bug found ;("
- [ ${ret} -eq 0 ] || epatch ${FILESDIR}/${PV}-nvidia.patch
+ [ ${ret} -eq 0 ] || epatch "${FILESDIR}"/${PV}-nvidia.patch
}
src_compile() {
@@ -35,21 +36,27 @@ src_compile() {
# will append -march=i686 and crap ... let the user's CFLAGS
# handle this ...
egamesconf \
- `use_enable opengl gl` \
- `use_enable x86 i386-asm` \
+ $(use_enable opengl gl) \
+ $(use_enable x86 i386-asm) \
--disable-cpu-opt \
|| die
# configure script screws up a few things
- sed -i "/DOOMWADDIR/s:\".*\":\"${GAMES_DATADIR}/doom-data\":" config.h
- use opengl || sed -i '/GL_DOOM/s:.*::' config.h
- emake || die
+ sed -i \
+ -e "/DOOMWADDIR/s:\".*\":\"${GAMES_DATADIR}/doom-data\":" config.h \
+ || die "sed failed"
+ if use opengl ; then
+ sed -i \
+ -e '/GL_DOOM/s:.*::' config.h \
+ || die "sed failed"
+ fi
+ emake || die "emake failed"
}
src_install() {
- dogamesbin src/prboom{,-game-server} || die
+ dogamesbin src/prboom{,-game-server} || die "dogamesbin failed"
- insinto ${GAMES_DATADIR}/doom-data
- doins data/*.wad || die
+ insinto "${GAMES_DATADIR}/doom-data"
+ doins data/*.wad || die "doins failed"
doman doc/*.{5,6}
dodoc AUTHORS ChangeLog NEWS README TODO doc/README.* doc/*.txt