summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-10-05 02:42:53 +0000
committerMike Frysinger <vapier@gentoo.org>2003-10-05 02:42:53 +0000
commit96927d0660a6fd7cf594532a72ab429cf6004003 (patch)
tree09602afeacb4b70dbe972f044dd5241c22f58af6 /games-fps
parentquiet unpack makeself (diff)
downloadhistorical-96927d0660a6fd7cf594532a72ab429cf6004003.tar.gz
historical-96927d0660a6fd7cf594532a72ab429cf6004003.tar.bz2
historical-96927d0660a6fd7cf594532a72ab429cf6004003.zip
EULA
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/unreal-tournament/unreal-tournament-436.ebuild3
-rw-r--r--games-fps/unreal-tournament/unreal-tournament-451.ebuild3
-rw-r--r--games-fps/ut2003-demo/ut2003-demo-2206-r2.ebuild9
3 files changed, 11 insertions, 4 deletions
diff --git a/games-fps/unreal-tournament/unreal-tournament-436.ebuild b/games-fps/unreal-tournament/unreal-tournament-436.ebuild
index e381fed9aa3c..a5d6deb78612 100644
--- a/games-fps/unreal-tournament/unreal-tournament-436.ebuild
+++ b/games-fps/unreal-tournament/unreal-tournament-436.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament/unreal-tournament-436.ebuild,v 1.2 2003/09/09 23:44:19 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament/unreal-tournament-436.ebuild,v 1.3 2003/10/05 02:42:53 vapier Exp $
inherit games eutils
@@ -21,6 +21,7 @@ RDEPEND="X? ( virtual/x11 )"
S=${WORKDIR}
pkg_setup() {
+ check_license
games_get_cd System/
games_verify_cd ${PN}
games_pkg_setup
diff --git a/games-fps/unreal-tournament/unreal-tournament-451.ebuild b/games-fps/unreal-tournament/unreal-tournament-451.ebuild
index 6a1341b4205f..8ed2c9974010 100644
--- a/games-fps/unreal-tournament/unreal-tournament-451.ebuild
+++ b/games-fps/unreal-tournament/unreal-tournament-451.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament/unreal-tournament-451.ebuild,v 1.2 2003/09/09 23:44:19 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament/unreal-tournament-451.ebuild,v 1.3 2003/10/05 02:42:53 vapier Exp $
inherit games eutils
@@ -22,6 +22,7 @@ DEPEND="X? ( virtual/x11 )
S=${WORKDIR}
pkg_setup() {
+ check_license
games_get_cd System/
games_verify_cd ${PN}
games_pkg_setup
diff --git a/games-fps/ut2003-demo/ut2003-demo-2206-r2.ebuild b/games-fps/ut2003-demo/ut2003-demo-2206-r2.ebuild
index c7a752ba8629..bd0b5326e072 100644
--- a/games-fps/ut2003-demo/ut2003-demo-2206-r2.ebuild
+++ b/games-fps/ut2003-demo/ut2003-demo-2206-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2003-demo/ut2003-demo-2206-r2.ebuild,v 1.1 2003/09/09 18:10:15 vapier Exp $.
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2003-demo/ut2003-demo-2206-r2.ebuild,v 1.2 2003/10/05 02:42:05 vapier Exp $.
inherit games
@@ -17,8 +17,13 @@ DEPEND="virtual/opengl"
S=${WORKDIR}
+pkg_setup() {
+ check_license
+ games_pkg_setup
+}
+
src_unpack() {
- tail +266 ${DISTDIR}/${A} | tar xf - || die
+ unpack_makeself
tar -zxf setupstuff.tar.gz || die
}