summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2004-10-05 15:25:06 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2004-10-05 15:25:06 +0000
commitf12f3f623c4a067a6c2dfb0f74fc3ca04dd250b3 (patch)
tree76993f6737c6afb5f77586d481c7475aa279f17a /games-fps
parentSet IUSE. Bugs 66410. (diff)
downloadhistorical-f12f3f623c4a067a6c2dfb0f74fc3ca04dd250b3.tar.gz
historical-f12f3f623c4a067a6c2dfb0f74fc3ca04dd250b3.tar.bz2
historical-f12f3f623c4a067a6c2dfb0f74fc3ca04dd250b3.zip
Added USE=cdinstall to copy files from the CD and made some other changes to bring it inline with my current ebuild style. I want to thank vapier for his first ebuild, as it took some of the pressure off me. Closing bug #57067.
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/doom3/ChangeLog7
-rw-r--r--games-fps/doom3/Manifest16
-rw-r--r--games-fps/doom3/doom3-1.1.1282.ebuild81
3 files changed, 76 insertions, 28 deletions
diff --git a/games-fps/doom3/ChangeLog b/games-fps/doom3/ChangeLog
index f18b9f7c14bd..b6491ca9e911 100644
--- a/games-fps/doom3/ChangeLog
+++ b/games-fps/doom3/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-fps/doom3
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/doom3/ChangeLog,v 1.1 2004/10/05 04:29:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/doom3/ChangeLog,v 1.2 2004/10/05 15:25:06 wolf31o2 Exp $
+
+ 05 Oct 2004; Chris Gianelloni <wolf31o2@gentoo.org> doom3-1.1.1282.ebuild:
+ Added USE=cdinstall to copy files from the CD and made some other changes to
+ bring it inline with my current ebuild style. I want to thank vapier for his
+ first ebuild, as it took some of the pressure off me. Closing bug #57067.
*doom3-1.1.1282 (05 Oct 2004)
diff --git a/games-fps/doom3/Manifest b/games-fps/doom3/Manifest
index b7bd6ca7156a..a3b129d1fab0 100644
--- a/games-fps/doom3/Manifest
+++ b/games-fps/doom3/Manifest
@@ -1,15 +1,5 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 82620ea2c3bacf385e3a8473092f85de doom3-1.1.1282.ebuild 1083
-MD5 716d8cb101b3b4d4c4a36dc483f3ad43 ChangeLog 340
+MD5 a7a19d0118903d18a6a12dc01d56aaba doom3-1.1.1282.ebuild 2527
+MD5 7c472e3d120507627e2f805325e2a9e2 ChangeLog 654
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 615c25dcc4ae6f839477113ecc33b0b8 files/digest-doom3-1.1.1282 74
MD5 86cf7753a0c72772dcfd90b35765a3d1 files/doom3 382
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.10 (GNU/Linux)
-
-iD8DBQFBYiSTHTu7gpaalycRApXLAJoDQnTemxVwFsI3PLRzD/+oRxqXPgCgzMLP
-M/YDUdhFV+s2ipxOAZGlgf4=
-=tNL7
------END PGP SIGNATURE-----
+MD5 615c25dcc4ae6f839477113ecc33b0b8 files/digest-doom3-1.1.1282 74
diff --git a/games-fps/doom3/doom3-1.1.1282.ebuild b/games-fps/doom3/doom3-1.1.1282.ebuild
index cf6e9d56d21c..608e822840d6 100644
--- a/games-fps/doom3/doom3-1.1.1282.ebuild
+++ b/games-fps/doom3/doom3-1.1.1282.ebuild
@@ -1,31 +1,48 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/doom3/doom3-1.1.1282.ebuild,v 1.1 2004/10/05 04:29:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/doom3/doom3-1.1.1282.ebuild,v 1.2 2004/10/05 15:25:06 wolf31o2 Exp $
inherit games eutils
-DESCRIPTION="DOOM 3"
-HOMEPAGE="http://www.doom3.com/"
-SRC_URI="ftp://ftp.idsoftware.com/idstuff/doom3/linux/doom3-linux-${PV}.x86.run
- mirror://gentoo/doom3-linux-${PV}.x86.run"
+DESCRIPTION="Doom III - 3rd installment of the classic id 3D first-person shooter"
+HOMEPAGE="http://www.${PN}.com/"
+SRC_URI="ftp://ftp.idsoftware.com/idstuff/doom3/linux/${PN}-linux-${PV}.x86.run"
LICENSE="DOOM3"
SLOT="0"
-KEYWORDS="x86"
-IUSE=""
+KEYWORDS="-* x86 amd64"
+IUSE="cdinstall opengl dedicated"
RESTRICT="nostrip"
-DEPEND="sys-libs/glibc
- virtual/x11"
+DEPEND="app-arch/bzip2
+ app-arch/tar"
+
+RDEPEND="virtual/libc
+ opengl? ( virtual/opengl )
+ dedicated? ( app-misc/screen )
+ amd64? ( app-emulation/emul-linux-x86-baselibs
+ app-emulation/emul-linux-x86-xlibs
+ app-emulation/emul-linux-x86-nvidia )"
S=${WORKDIR}
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+
+pkg_setup() {
+ check_license
+ use cdinstall && cdrom_get_cds Setup/Data/base/pak002.pk4 \
+ Setup/Data/base/pak000.pk4 \
+ Setup/Data/base/pak003.pk4
+ games_pkg_setup
+}
+
src_unpack() {
unpack_makeself
}
src_install() {
- local dir="${GAMES_PREFIX_OPT}/${PN}"
+ dodir ${dir}
insinto ${dir}
doins License.txt README version.info
@@ -35,11 +52,47 @@ src_install() {
insinto ${dir}/base
doins base/* || die "doins base"
+ if use cdinstall; then
+ einfo "Copying files from Disk 1..."
+ doins ${CDROM_ROOT}/Setup/Data/base/pak002.pk4 \
+ || die "copying pak002"
+ cdrom_load_next_cd
+ einfo "Copying files from Disk 2..."
+ doins ${CDROM_ROOT}/Setup/Data/base/pak00* \
+ || die "copying pak000 and pak001"
+ cdrom_load_next_cd
+ einfo "Copying files from Disk 3..."
+ doins ${CDROM_ROOT}/Setup/Data/base/pak00* \
+ || die "copying pak003 and pak004"
+ fi
+
+ games_make_wrapper doom3 ./doom.x86 ${dir}
+ games_make_wrapper doom3-ded ./doomded.x86 ${dir}
- dogamesbin ${FILESDIR}/doom3
- dosed "s:DIR:${dir}:" ${GAMES_BINDIR}/doom3
- dosed "s:EXE:doom.x86:" ${GAMES_BINDIR}/doom3
- games_make_wrapper doom3-dedicated ./doomded.x86 "${dir}" .
+ use cdinstall && find ${Ddir} -exec touch '{}' \;
prepgamesdirs
+ make_desktop_entry doom3 "Doom III" doom3.xpm
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ if use cdinstall; then
+ einfo "To play the game run:"
+ einfo " doom3"
+ else
+ einfo "You need to copy pak000.pk4, pak001.pk4, pak002.pk4, pak003.pk4, and"
+ einfo "pak004.pk4 from either your installation media or your hard drive to"
+ einfo "${dir}/base before running the game."
+ echo
+ einfo "To play the game run:"
+ einfo " doom3"
+ fi
+
+ # IA32 Emulation required for amd64
+ if use amd64 ; then
+ echo
+ ewarn "NOTE: IA32 Emulation must be compiled into your kernel for Doom3 to run."
+ fi
}