summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-05-12 09:02:46 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-05-12 09:02:46 +0000
commitf193081a9f1537598f6fed550a0ec7b44c211741 (patch)
treeeda029f6c89b39343dfe7c3b970a3a8df8c0fcb0 /games-puzzle/construo
parentnative widget stuff now also for gtk (diff)
downloadhistorical-f193081a9f1537598f6fed550a0ec7b44c211741.tar.gz
historical-f193081a9f1537598f6fed550a0ec7b44c211741.tar.bz2
historical-f193081a9f1537598f6fed550a0ec7b44c211741.zip
IUSE; error check; tidy
Diffstat (limited to 'games-puzzle/construo')
-rw-r--r--games-puzzle/construo/construo-0.2.2.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/games-puzzle/construo/construo-0.2.2.ebuild b/games-puzzle/construo/construo-0.2.2.ebuild
index db72e0ce01e0..263f8ea14528 100644
--- a/games-puzzle/construo/construo-0.2.2.ebuild
+++ b/games-puzzle/construo/construo-0.2.2.ebuild
@@ -1,15 +1,16 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/construo/construo-0.2.2.ebuild,v 1.2 2004/02/20 06:53:35 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/construo/construo-0.2.2.ebuild,v 1.3 2004/05/12 09:02:45 mr_bones_ Exp $
inherit games
DESCRIPTION="2d construction toy with objects that react on physical forces"
HOMEPAGE="http://www.nongnu.org/construo/"
SRC_URI="http://freesoftware.fsf.org/download/construo/construo.pkg/${PV}/${P}.tar.gz"
+
LICENSE="GPL-2"
-KEYWORDS="x86"
SLOT="0"
+KEYWORDS="x86"
IUSE=""
DEPEND="virtual/x11
@@ -17,12 +18,15 @@ DEPEND="virtual/x11
virtual/glut"
src_compile() {
- egamesconf --datadir=${GAMES_DATADIR_BASE}
+ egamesconf --datadir="${GAMES_DATADIR_BASE}" || die
emake || die "emake failed"
}
src_install() {
- make DESTDIR=${D} bindir=/usr/games/bin install || die "make install failed"
+ make \
+ DESTDIR="${D}" \
+ bindir="${GAMES_BINDIR}" install \
+ || die "make install failed"
dodoc AUTHORS INSTALL INSTALL.configure NEWS README TODO
prepgamesdirs
}