summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-05-12 09:02:46 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-05-12 09:02:46 +0000
commitf193081a9f1537598f6fed550a0ec7b44c211741 (patch)
treeeda029f6c89b39343dfe7c3b970a3a8df8c0fcb0 /games-puzzle/fbg
parentnative widget stuff now also for gtk (diff)
downloadhistorical-f193081a9f1537598f6fed550a0ec7b44c211741.tar.gz
historical-f193081a9f1537598f6fed550a0ec7b44c211741.tar.bz2
historical-f193081a9f1537598f6fed550a0ec7b44c211741.zip
IUSE; error check; tidy
Diffstat (limited to 'games-puzzle/fbg')
-rw-r--r--games-puzzle/fbg/fbg-0.9-r1.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/games-puzzle/fbg/fbg-0.9-r1.ebuild b/games-puzzle/fbg/fbg-0.9-r1.ebuild
index 869234828bb4..7eade1c46954 100644
--- a/games-puzzle/fbg/fbg-0.9-r1.ebuild
+++ b/games-puzzle/fbg/fbg-0.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/fbg/fbg-0.9-r1.ebuild,v 1.4 2004/03/07 21:33:45 jhuebel Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/fbg/fbg-0.9-r1.ebuild,v 1.5 2004/05/12 09:02:45 mr_bones_ Exp $
inherit games
@@ -11,6 +11,7 @@ SRC_URI="mirror://sourceforge/fbg/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc amd64"
+IUSE=""
DEPEND="virtual/x11
virtual/opengl
@@ -22,16 +23,18 @@ DEPEND="virtual/x11
src_unpack() {
unpack ${A}
cd ${S}
- sed -i "/FBGDATADIR=/s:\".*\":\"${GAMES_DATADIR}/${PN}\":" configure
+ sed -i \
+ -e "/FBGDATADIR=/s:\".*\":\"${GAMES_DATADIR}/${PN}\":" configure \
+ || die "sed configure failed"
}
src_compile() {
egamesconf --disable-fbglaunch || die
- emake || die
+ emake || die "emake failed"
}
src_install() {
- make DESTDIR=${D} install || die
+ make DESTDIR=${D} install || die "make install failed"
dodoc README TODO AUTHORS
# now clean up the install