summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-04-11 02:58:25 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-04-11 02:58:25 +0000
commit28bc557a7dd4895576ee9e3c45005a67094cc4c6 (patch)
tree9eeffbbc714781bb7f5ab95aa6c3e2c7f913d32c /games-puzzle/londonlaw
parentfixed licence item (diff)
downloadhistorical-28bc557a7dd4895576ee9e3c45005a67094cc4c6.tar.gz
historical-28bc557a7dd4895576ee9e3c45005a67094cc4c6.tar.bz2
historical-28bc557a7dd4895576ee9e3c45005a67094cc4c6.zip
initial commit - ebuild and patch from Christoph Brill (egore) via bug #82580
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'games-puzzle/londonlaw')
-rw-r--r--games-puzzle/londonlaw/ChangeLog11
-rw-r--r--games-puzzle/londonlaw/Manifest5
-rw-r--r--games-puzzle/londonlaw/files/digest-londonlaw-0.2.01
-rw-r--r--games-puzzle/londonlaw/files/londonlaw-0.2.0-setup.py.patch37
-rw-r--r--games-puzzle/londonlaw/londonlaw-0.2.0.ebuild45
-rw-r--r--games-puzzle/londonlaw/metadata.xml5
6 files changed, 104 insertions, 0 deletions
diff --git a/games-puzzle/londonlaw/ChangeLog b/games-puzzle/londonlaw/ChangeLog
new file mode 100644
index 000000000000..a3d0d680d8a4
--- /dev/null
+++ b/games-puzzle/londonlaw/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for games-puzzle/londonlaw
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/londonlaw/ChangeLog,v 1.1 2005/04/11 02:58:25 mr_bones_ Exp $
+
+*londonlaw-0.2.0 (10 Apr 2005)
+
+ 10 Apr 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/londonlaw-0.2.0-setup.py.patch, +metadata.xml,
+ +londonlaw-0.2.0.ebuild:
+ initial commit - ebuild and patch from Christoph Brill (egore) via bug #82580
+
diff --git a/games-puzzle/londonlaw/Manifest b/games-puzzle/londonlaw/Manifest
new file mode 100644
index 000000000000..262217e3d74a
--- /dev/null
+++ b/games-puzzle/londonlaw/Manifest
@@ -0,0 +1,5 @@
+MD5 719360461f911831df9e3cd97058b6e2 londonlaw-0.2.0.ebuild 1134
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 ed86538ae4514bb72b05355dd9b521f7 ChangeLog 471
+MD5 0fbd9c9d50f0f69bf3ad3df8f615e080 files/digest-londonlaw-0.2.0 68
+MD5 5f414ab1da49789f7e521e0af4ac1c73 files/londonlaw-0.2.0-setup.py.patch 1528
diff --git a/games-puzzle/londonlaw/files/digest-londonlaw-0.2.0 b/games-puzzle/londonlaw/files/digest-londonlaw-0.2.0
new file mode 100644
index 000000000000..0dfbaa97ef74
--- /dev/null
+++ b/games-puzzle/londonlaw/files/digest-londonlaw-0.2.0
@@ -0,0 +1 @@
+MD5 c24fa28338d748783204df1f2eb2f16e londonlaw-0.2.0.tar.gz 3190143
diff --git a/games-puzzle/londonlaw/files/londonlaw-0.2.0-setup.py.patch b/games-puzzle/londonlaw/files/londonlaw-0.2.0-setup.py.patch
new file mode 100644
index 000000000000..eef8059850bf
--- /dev/null
+++ b/games-puzzle/londonlaw/files/londonlaw-0.2.0-setup.py.patch
@@ -0,0 +1,37 @@
+--- setup.py 2005-02-18 04:51:06.000000000 +0100
++++ setup.py.1 2005-02-20 22:51:31.687411720 +0100
+@@ -10,20 +10,14 @@
+ # Read off the PREFIX value, so we can tell jools where to find its
+ # data files (FIXME: is there a clean way to handle this through distutils?
+ if 'sdist' not in sys.argv and 'clean' not in sys.argv:
+- PREFIX=os.path.normpath(sys.prefix) # default
++ DATA_PREFIX="" # default
+ for arg in sys.argv:
+- index = string.find(arg, "--prefix=")
++ index = string.find(arg, "--install-data=")
+ if index > -1:
+- PREFIX = os.path.normpath(arg[(index+len("--prefix=")):])
+-
+- ROOT = "/" # default
+- for arg in sys.argv:
+- index = string.find(arg, "--root=")
+- if index > -1:
+- ROOT = os.path.normpath(arg[(index+len("--root=")):])
++ DATA_PREFIX = os.path.normpath(arg[(index+len("--install-data=")):])
+
+ config = open("londonlaw/common/config.py", "w")
+- config.write("MEDIAROOT = \"" + os.path.join(PREFIX,"share/londonlaw/guiclient") + "\"\n")
++ config.write("MEDIAROOT = \"" + os.path.join(DATA_PREFIX,"londonlaw/guiclient") + "\"\n")
+ config.close()
+
+
+@@ -37,7 +31,8 @@
+ if os.path.isfile(fullFile):
+ newFiles.append(fullFile)
+ if newFiles != []:
+- installList.append( (os.path.join('share', dirname), newFiles) )
++# installList.append( (os.path.join('share', dirname), newFiles) )
++ installList.append( (dirname, newFiles) )
+
+
+ # Get all data files by walking through the proper directory trees
diff --git a/games-puzzle/londonlaw/londonlaw-0.2.0.ebuild b/games-puzzle/londonlaw/londonlaw-0.2.0.ebuild
new file mode 100644
index 000000000000..a233689063c0
--- /dev/null
+++ b/games-puzzle/londonlaw/londonlaw-0.2.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/londonlaw/londonlaw-0.2.0.ebuild,v 1.1 2005/04/11 02:58:25 mr_bones_ Exp $
+
+inherit python games
+
+DESCRIPTION="Clone of the famous Scotland Yard board game"
+HOMEPAGE="http://www.eecs.umich.edu/~pelzlpj/londonlaw/"
+SRC_URI="http://www.eecs.umich.edu/~pelzlpj/londonlaw/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.3
+ >=dev-python/wxpython-2.4
+ dev-python/twisted"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-setup.py.patch"
+}
+
+src_install() {
+ python_version
+ python setup.py install \
+ --root="${D}" \
+ --prefix="${GAMES_PREFIX}" \
+ --install-lib=/usr/lib/python${PYVER}/site-packages \
+ --install-data="${GAMES_DATADIR}" \
+ || die "install failed"
+ dodoc ChangeLog README
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ einfo "To play, first start the server (london-server), then connect"
+ einfo "with the client (london-client). At least two players are"
+ einfo "needed to play."
+ echo
+}
diff --git a/games-puzzle/londonlaw/metadata.xml b/games-puzzle/londonlaw/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-puzzle/londonlaw/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>