summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-03-19 04:08:00 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-03-19 04:08:00 +0000
commita96f1447568e768da5bfebaa55b304877e4f64a0 (patch)
tree71ae76c2747d3ea7429a75b0a5e9af090971da91 /games-puzzle/monsterz
parentupdate m68k patch (diff)
downloadhistorical-a96f1447568e768da5bfebaa55b304877e4f64a0.tar.gz
historical-a96f1447568e768da5bfebaa55b304877e4f64a0.tar.bz2
historical-a96f1447568e768da5bfebaa55b304877e4f64a0.zip
make sure media-libs/sdl-mixer was built with USE=mikmod; tidy
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'games-puzzle/monsterz')
-rw-r--r--games-puzzle/monsterz/ChangeLog5
-rw-r--r--games-puzzle/monsterz/Manifest4
-rw-r--r--games-puzzle/monsterz/monsterz-0.4.1.ebuild15
3 files changed, 17 insertions, 7 deletions
diff --git a/games-puzzle/monsterz/ChangeLog b/games-puzzle/monsterz/ChangeLog
index 83b5c01319ed..ea4831920686 100644
--- a/games-puzzle/monsterz/ChangeLog
+++ b/games-puzzle/monsterz/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-puzzle/monsterz
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/monsterz/ChangeLog,v 1.1 2005/03/19 00:08:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/monsterz/ChangeLog,v 1.2 2005/03/19 04:08:00 mr_bones_ Exp $
+
+ 18 Mar 2005; Michael Sterrett <mr_bones_@gentoo.org> monsterz-0.4.1.ebuild:
+ make sure media-libs/sdl-mixer was built with USE=mikmod; tidy
*monsterz-0.4.1 (18 Mar 2005)
diff --git a/games-puzzle/monsterz/Manifest b/games-puzzle/monsterz/Manifest
index f5dbbe8bb22a..12a5af7f78c9 100644
--- a/games-puzzle/monsterz/Manifest
+++ b/games-puzzle/monsterz/Manifest
@@ -1,5 +1,5 @@
-MD5 92a8273d3623a9af083d3fbb814a13f2 monsterz-0.4.1.ebuild 1097
+MD5 e87242fdd21334316de65225677a5991 ChangeLog 506
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 0adb6fd831434b3616d2e79b26be73ab ChangeLog 359
+MD5 01c926bea7b51effdc7f58196e6c249e monsterz-0.4.1.ebuild 1260
MD5 48b4619fb74ecdcd08daf11d8bab2419 files/digest-monsterz-0.4.1 67
MD5 b81b7ea24dae05a0df1825c018bbf1c4 files/monsterz-0.4.1-gentoo.patch 1001
diff --git a/games-puzzle/monsterz/monsterz-0.4.1.ebuild b/games-puzzle/monsterz/monsterz-0.4.1.ebuild
index e9293b15d12b..c07eaf2cc47c 100644
--- a/games-puzzle/monsterz/monsterz-0.4.1.ebuild
+++ b/games-puzzle/monsterz/monsterz-0.4.1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/monsterz/monsterz-0.4.1.ebuild,v 1.1 2005/03/19 00:08:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/monsterz/monsterz-0.4.1.ebuild,v 1.2 2005/03/19 04:08:00 mr_bones_ Exp $
-inherit games eutils
+inherit eutils games
DESCRIPTION="a little puzzle game, similar to the famous Bejeweled or Zookeeper"
HOMEPAGE="http://sam.zoy.org/projects/monsterz/"
-SRC_URI="http://sam.zoy.org/projects/monsterz/monsterz-0.4.1.tar.gz"
+SRC_URI="http://sam.zoy.org/projects/monsterz/${P}.tar.gz"
LICENSE="public-domain"
SLOT="0"
@@ -15,6 +15,13 @@ IUSE=""
DEPEND="dev-python/pygame"
+pkg_setup() {
+ if ! built_with_use media-libs/sdl-mixer mikmod ; then
+ die "${PN} requires that media-libs/sdl-mixer be built with USE=mikmod"
+ fi
+ games_pkg_setup
+}
+
src_unpack() {
unpack ${A}
cd "${S}"
@@ -27,7 +34,7 @@ src_unpack() {
src_install() {
local dir=${GAMES_DATADIR}/${PN}
- insinto ${dir}
+ insinto "${dir}"
doins *.wav *.s3m *.png || die "doins failed"
newgamesbin monsterz.py ${PN} || die "dobin failed"
dodir "${GAMES_STATEDIR}"