summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <tristan@gentoo.org>2012-02-01 00:05:11 +0000
committerTristan Heaven <tristan@gentoo.org>2012-02-01 00:05:11 +0000
commita9b45152e1c134177350301e5e02485cf55d5c50 (patch)
tree3031398902d7e26f5fb0c6458e1154ad7fbf90a2 /games-puzzle/world-of-goo
parentMove net-analyzer/rrdtool from DEPEND to RDEPEND wrt #400637 (diff)
downloadhistorical-a9b45152e1c134177350301e5e02485cf55d5c50.tar.gz
historical-a9b45152e1c134177350301e5e02485cf55d5c50.tar.bz2
historical-a9b45152e1c134177350301e5e02485cf55d5c50.zip
Remove bundled libraries, bug #380173
Package-Manager: portage-2.2.0_alpha84/cvs/Linux x86_64
Diffstat (limited to 'games-puzzle/world-of-goo')
-rw-r--r--games-puzzle/world-of-goo/ChangeLog10
-rw-r--r--games-puzzle/world-of-goo/world-of-goo-1.41-r1.ebuild68
2 files changed, 76 insertions, 2 deletions
diff --git a/games-puzzle/world-of-goo/ChangeLog b/games-puzzle/world-of-goo/ChangeLog
index c8cdb4d2f0f1..d1f796a7bed7 100644
--- a/games-puzzle/world-of-goo/ChangeLog
+++ b/games-puzzle/world-of-goo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-puzzle/world-of-goo
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/world-of-goo/ChangeLog,v 1.4 2009/10/25 07:53:40 mr_bones_ Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/world-of-goo/ChangeLog,v 1.5 2012/02/01 00:04:59 tristan Exp $
+
+*world-of-goo-1.41-r1 (01 Feb 2012)
+
+ 01 Feb 2012; Tristan Heaven <tristan@gentoo.org>
+ +world-of-goo-1.41-r1.ebuild:
+ Remove bundled libraries, bug #380173
25 Oct 2009; Michael Sterrett <mr_bones_@gentoo.org>
world-of-goo-1.41.ebuild:
diff --git a/games-puzzle/world-of-goo/world-of-goo-1.41-r1.ebuild b/games-puzzle/world-of-goo/world-of-goo-1.41-r1.ebuild
new file mode 100644
index 000000000000..9b2ea0ec2108
--- /dev/null
+++ b/games-puzzle/world-of-goo/world-of-goo-1.41-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/world-of-goo/world-of-goo-1.41-r1.ebuild,v 1.1 2012/02/01 00:04:59 tristan Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="A puzzle game with a strong emphasis on physics"
+HOMEPAGE="http://2dboy.com/"
+
+if [[ ${PN} == *-demo ]] ; then
+ MY_PN="WorldOfGooDemo"
+ SRC_URI="${MY_PN}.${PV}.tar.gz"
+else
+ MY_PN="WorldOfGoo"
+ SRC_URI="${MY_PN}Setup.${PV}.tar.gz"
+fi
+
+LICENSE="2dboy-EULA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="fetch strip"
+
+RDEPEND="media-libs/libsdl[audio,opengl,video]
+ media-libs/sdl-mixer[vorbis]
+ sys-libs/glibc
+ virtual/opengl
+ virtual/glu
+ >=sys-devel/gcc-3.4"
+DEPEND=""
+
+S=${WORKDIR}/${MY_PN}
+dir=${GAMES_PREFIX_OPT}/${PN}
+
+QA_PREBUILT="${dir:1}/${MY_PN%Demo}.bin32
+ ${dir:1}/${MY_PN%Demo}.bin64"
+
+pkg_nofetch() {
+ if [[ ${PN} == *-demo ]] ; then
+ elog "To download the demo, visit http://worldofgoo.com/dl2.php?lk=demo"
+ elog "and download ${A} and place it in ${DISTDIR}"
+ else
+ elog "Download ${A} from ${HOMEPAGE} and place it in ${DISTDIR}"
+ fi
+}
+
+src_install() {
+ exeinto "${dir}"
+ doexe ${MY_PN%Demo}* || die
+
+ games_make_wrapper ${PN} "${dir}"/${MY_PN%Demo} || die
+
+ insinto "${dir}"
+ doins -r icons properties res || die
+ newicon icons/scalable.svg ${PN}.svg || die
+
+ if [[ ${PN} == *-demo ]] ; then
+ make_desktop_entry ${PN} "World of Goo (Demo)" || die
+ else
+ make_desktop_entry ${PN} "World of Goo" || die
+ fi
+
+ dodoc linux-issues.txt || die
+ dohtml readme.html || die
+
+ prepgamesdirs
+}