summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-02-01 18:59:49 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-02-01 18:59:49 +0000
commitb3f5eb8308cb42de50da70251afe78e8d22c5748 (patch)
tree1c67c64d76a9b4a8b9b80a3f52481ebb5c169d31 /games-puzzle
parentVersion bump. (diff)
downloadhistorical-b3f5eb8308cb42de50da70251afe78e8d22c5748.tar.gz
historical-b3f5eb8308cb42de50da70251afe78e8d22c5748.tar.bz2
historical-b3f5eb8308cb42de50da70251afe78e8d22c5748.zip
initial commit - ebuild submitted by eGore via bug #76950
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/tong/ChangeLog10
-rw-r--r--games-puzzle/tong/Manifest5
-rw-r--r--games-puzzle/tong/files/1.0-makefile.patch30
-rw-r--r--games-puzzle/tong/files/digest-tong-1.01
-rw-r--r--games-puzzle/tong/metadata.xml5
-rw-r--r--games-puzzle/tong/tong-1.0.ebuild41
6 files changed, 92 insertions, 0 deletions
diff --git a/games-puzzle/tong/ChangeLog b/games-puzzle/tong/ChangeLog
new file mode 100644
index 000000000000..12e8741648ed
--- /dev/null
+++ b/games-puzzle/tong/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-puzzle/tong
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/tong/ChangeLog,v 1.1 2005/02/01 18:59:49 mr_bones_ Exp $
+
+*tong-1.0 (01 Feb 2005)
+
+ 01 Feb 2005; Michael Sterrett <mr_bones_@gentoo.org> +metadata.xml,
+ +tong-1.0.ebuild:
+ initial commit - ebuild submitted by eGore via bug #76950
+
diff --git a/games-puzzle/tong/Manifest b/games-puzzle/tong/Manifest
new file mode 100644
index 000000000000..e5797936b8ed
--- /dev/null
+++ b/games-puzzle/tong/Manifest
@@ -0,0 +1,5 @@
+MD5 322e378c43b6f5cd85510dcb9f943973 tong-1.0.ebuild 1070
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 620236b349831ce28692b0e420c912ae ChangeLog 386
+MD5 35e834d1323b4f56d0eceb26e7711cde files/digest-tong-1.0 62
+MD5 81c48728d6b5f4e2585f79ec3fabeeeb files/1.0-makefile.patch 918
diff --git a/games-puzzle/tong/files/1.0-makefile.patch b/games-puzzle/tong/files/1.0-makefile.patch
new file mode 100644
index 000000000000..a2494f0ecb40
--- /dev/null
+++ b/games-puzzle/tong/files/1.0-makefile.patch
@@ -0,0 +1,30 @@
+--- Makefile.orig 2005-02-01 11:49:23.000000000 -0500
++++ Makefile 2005-02-01 11:51:07.000000000 -0500
+@@ -1,11 +1,10 @@
+ #hello world
+ #my first attempt at making a makefile
+
+-SDL_CFLAGS := $(shell sdl-config --cflags)
++CXXFLAGS += $(shell sdl-config --cflags)
+ SDL_LDFLAGS := $(shell sdl-config --libs)
+ MIXER_FLAGS := -lSDL_mixer -lpthread
+ IMG_FLAGS := -lSDL_image
+-CC=g++ -O3 -Wall #-ggdb3
+ SOURCES = tetris.cpp pong.cpp text.cpp option.cpp media.cpp
+ #these sources need to be linked to the SDL libs so may have special flag settings
+ SDL_SOURCES = tong.cpp
+@@ -16,13 +15,7 @@
+ #builds all, builds the target
+
+ all: $(OBJS)
+- $(CC) $(SDL_LDFLAGS) $(MIXER_FLAGS) $(IMG_FLAGS) $(OBJS) -o $(TARGET)
+-
+-%.o: %.cpp
+- $(CC) $(SDL_CFLAGS) -c -o $@ $<
+-
+-tong.o: $(SDL_SOURCES)
+- $(CC) $(SDL_CFLAGS) -c -o $@ $<
++ $(CXX) $(SDL_LDFLAGS) $(MIXER_FLAGS) $(IMG_FLAGS) $(OBJS) -o $(TARGET)
+
+ # clean out the mess
+ clean:
diff --git a/games-puzzle/tong/files/digest-tong-1.0 b/games-puzzle/tong/files/digest-tong-1.0
new file mode 100644
index 000000000000..6fd758cffa64
--- /dev/null
+++ b/games-puzzle/tong/files/digest-tong-1.0
@@ -0,0 +1 @@
+MD5 9f358a012639de1a5a8d3e0b323438de tong-1.0.tar.gz 33291881
diff --git a/games-puzzle/tong/metadata.xml b/games-puzzle/tong/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-puzzle/tong/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-puzzle/tong/tong-1.0.ebuild b/games-puzzle/tong/tong-1.0.ebuild
new file mode 100644
index 000000000000..2cfe1877f673
--- /dev/null
+++ b/games-puzzle/tong/tong-1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/tong/tong-1.0.ebuild,v 1.1 2005/02/01 18:59:49 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="Tetris and Pong in the same place at the same time"
+HOMEPAGE="http://www.nongnu.org/tong/"
+SRC_URI="http://www.nongnu.org/tong/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-mixer"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PV}-makefile.patch"
+ sed -i \
+ -e "s:\"media/:\"${GAMES_DATADIR}/${PN}/media/:" \
+ media.cpp option.cpp option.h pong.cpp tetris.cpp text.cpp \
+ || die "sed failed"
+ cp media/icon.png "${T}/${PN}.png"
+}
+
+src_install() {
+ dogamesbin tong || die "dogamesbin failed"
+ dodir "${GAMES_DATADIR}/${PN}"
+ cp -r media/ "${D}/${GAMES_DATADIR}/${PN}" || die "cp failed"
+ dodoc CHANGELOG README making-of.txt CREDITS
+
+ make_desktop_entry tong TONG ${PN}.png
+ doicon "${T}/${PN}.png"
+ prepgamesdirs
+}