summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-10-25 10:21:09 +0000
committerMike Frysinger <vapier@gentoo.org>2003-10-25 10:21:09 +0000
commit24205fae25e80e20caea0d01db3a905edf5ade63 (patch)
tree0ed61b4ab33eaaf5fa383f9518a2f9603010dd31 /games-rpg/twclone
parentforgot prepgamesdirs (diff)
downloadhistorical-24205fae25e80e20caea0d01db3a905edf5ade63.tar.gz
historical-24205fae25e80e20caea0d01db3a905edf5ade63.tar.bz2
historical-24205fae25e80e20caea0d01db3a905edf5ade63.zip
doesnt really need X
Diffstat (limited to 'games-rpg/twclone')
-rw-r--r--games-rpg/twclone/ChangeLog8
-rw-r--r--games-rpg/twclone/files/0.12-glibc-sendmsg.patch36
-rw-r--r--games-rpg/twclone/files/digest-twclone-0.121
-rw-r--r--games-rpg/twclone/metadata.xml12
-rw-r--r--games-rpg/twclone/twclone-0.12.ebuild32
5 files changed, 89 insertions, 0 deletions
diff --git a/games-rpg/twclone/ChangeLog b/games-rpg/twclone/ChangeLog
new file mode 100644
index 000000000000..162b19d81575
--- /dev/null
+++ b/games-rpg/twclone/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for games-rpg/twclone
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/twclone/ChangeLog,v 1.1 2003/10/25 10:21:09 vapier Exp $
+
+*twclone-0.12 (25 Oct 2003)
+
+ 25 Oct 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me.
diff --git a/games-rpg/twclone/files/0.12-glibc-sendmsg.patch b/games-rpg/twclone/files/0.12-glibc-sendmsg.patch
new file mode 100644
index 000000000000..c19b0afb2aae
--- /dev/null
+++ b/games-rpg/twclone/files/0.12-glibc-sendmsg.patch
@@ -0,0 +1,36 @@
+diff -ur twclone-source-0.12.orig/msgqueue.c twclone-source-0.12/msgqueue.c
+--- twclone-source-0.12.orig/msgqueue.c 2003-10-25 06:11:18.830318400 -0400
++++ twclone-source-0.12/msgqueue.c 2003-10-25 06:11:46.805065592 -0400
+@@ -98,7 +98,7 @@
+ return;
+ }
+
+-void sendmsg (int msgid, char *buffer, long mtype)
++void safesendmsg (int msgid, char *buffer, long mtype)
+ {
+ void *msg = malloc (sizeof (struct msgbuffer));
+
+diff -ur twclone-source-0.12.orig/msgqueue.h twclone-source-0.12/msgqueue.h
+--- twclone-source-0.12.orig/msgqueue.h 2003-10-25 06:11:18.830318400 -0400
++++ twclone-source-0.12/msgqueue.h 2003-10-25 06:11:50.502503496 -0400
+@@ -122,7 +122,7 @@
+ int init_msgqueue ();
+ void clean_msgqueues(int msgidin, int msgidout, char *filename);
+ long getmsg (int msgid, char *buffer, long mtype);
+-void sendmsg (int msgid, char *buffer, long mtype);
++void safesendmsg (int msgid, char *buffer, long mtype);
+ void senddata (int msgid, struct msgcommand *data, long mtype);
+ long getdata (int msgid, struct msgcommand *data, long mtype);
+
+diff -ur twclone-source-0.12.orig/server.c twclone-source-0.12/server.c
+--- twclone-source-0.12.orig/server.c 2003-10-25 06:11:18.831318248 -0400
++++ twclone-source-0.12/server.c 2003-10-25 06:11:58.972215904 -0400
+@@ -205,7 +205,7 @@
+ while (data.command != ct_quit || senderid != threadid) //Main game loop
+ {
+ processcommand (buffer, &data);
+- sendmsg (msgidout, buffer, senderid);
++ safesendmsg (msgidout, buffer, senderid);
+ senderid = getdata (msgidin, &data, 0);
+ }
+ saveallports ();
diff --git a/games-rpg/twclone/files/digest-twclone-0.12 b/games-rpg/twclone/files/digest-twclone-0.12
new file mode 100644
index 000000000000..e880b97beaab
--- /dev/null
+++ b/games-rpg/twclone/files/digest-twclone-0.12
@@ -0,0 +1 @@
+MD5 8ce8c02a830b59dddf69dad009d9b81f twclone-source-0.12.tar.gz 140847
diff --git a/games-rpg/twclone/metadata.xml b/games-rpg/twclone/metadata.xml
new file mode 100644
index 000000000000..a38883184dff
--- /dev/null
+++ b/games-rpg/twclone/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription>
+How many of you remeber the BBS days back in the late 80's and early 90's?
+Back when you would call in play games and go on with your life? Well I'm
+trying to duplicate one of those old games. It was called Trade Wars
+2002(Created by Martech Software). So I decided to make a game similar to it
+that runs in Linux.
+</longdescription>
+</pkgmetadata>
diff --git a/games-rpg/twclone/twclone-0.12.ebuild b/games-rpg/twclone/twclone-0.12.ebuild
new file mode 100644
index 000000000000..e7b55c8af787
--- /dev/null
+++ b/games-rpg/twclone/twclone-0.12.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/twclone/twclone-0.12.ebuild,v 1.1 2003/10/25 10:21:09 vapier Exp $
+
+inherit games
+
+MY_P=${PN}-source-${PV}
+DESCRIPTION="Clone of BBS Door game Trade Wars 2002"
+HOMEPAGE="http://twclone.sourceforge.net/"
+SRC_URI="mirror://sourceforge/twclone/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-glibc-sendmsg.patch
+}
+
+src_install() {
+ emake install DESTDIR=${D} || die
+ dodoc AUTHORS ChangeLog NEWS PROTOCOL README TODO
+ cd ${D}/${GAMES_BINDIR}
+ for f in * ; do
+ mv {,${PN}-}${f}
+ done
+ prepgamesdirs
+}