summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2011-06-18 18:26:02 +0000
committerRichard Freeman <rich0@gentoo.org>2011-06-18 18:26:02 +0000
commitb818d3ae4197beb8322f9c15e12f7c27600ccaba (patch)
treed9effe0e3451b290249032e504c9fa9fb2d1b0c2 /games-rpg
parentVersion bump (diff)
downloadhistorical-b818d3ae4197beb8322f9c15e12f7c27600ccaba.tar.gz
historical-b818d3ae4197beb8322f9c15e12f7c27600ccaba.tar.bz2
historical-b818d3ae4197beb8322f9c15e12f7c27600ccaba.zip
version bump - 372181
Package-Manager: portage-2.1.9.42/cvs/Linux x86_64
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/eternal-lands-data/ChangeLog8
-rw-r--r--games-rpg/eternal-lands-data/eternal-lands-data-1.9.2.ebuild101
-rw-r--r--games-rpg/eternal-lands/ChangeLog8
-rw-r--r--games-rpg/eternal-lands/eternal-lands-1.9.2.ebuild150
-rw-r--r--games-rpg/eternal-lands/files/eternal-lands-1.9.2-glext.patch11
5 files changed, 276 insertions, 2 deletions
diff --git a/games-rpg/eternal-lands-data/ChangeLog b/games-rpg/eternal-lands-data/ChangeLog
index a91e828a1354..82661cc4239b 100644
--- a/games-rpg/eternal-lands-data/ChangeLog
+++ b/games-rpg/eternal-lands-data/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-rpg/eternal-lands-data
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands-data/ChangeLog,v 1.24 2011/01/17 19:58:33 rich0 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands-data/ChangeLog,v 1.25 2011/06/18 18:25:27 rich0 Exp $
+
+*eternal-lands-data-1.9.2 (18 Jun 2011)
+
+ 18 Jun 2011; Richard Freeman <rich0@gentoo.org>
+ +eternal-lands-data-1.9.2.ebuild:
+ version bump - 372181
*eternal-lands-data-1.9.1_p20110117 (17 Jan 2011)
diff --git a/games-rpg/eternal-lands-data/eternal-lands-data-1.9.2.ebuild b/games-rpg/eternal-lands-data/eternal-lands-data-1.9.2.ebuild
new file mode 100644
index 000000000000..be26747ab28f
--- /dev/null
+++ b/games-rpg/eternal-lands-data/eternal-lands-data-1.9.2.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands-data/eternal-lands-data-1.9.2.ebuild,v 1.1 2011/06/18 18:25:27 rich0 Exp $
+
+inherit games
+
+MUSIC_DATE="20060803"
+
+MY_PV="${PV//_/}"
+MY_PV="${MY_PV//./}"
+MY_PN="${PN%*-data}"
+DESCRIPTION="An online MMORPG written in C and SDL"
+HOMEPAGE="http://www.eternal-lands.com"
+SRC_URI="http://www.eternal-lands.com/el_linux_192.zip
+ music? ( mirror://gentoo/el_music_full-${MUSIC_DATE}.zip )
+ sound? ( http://www.eternallands.co.uk/EL_sound_191.zip )"
+# WARNING: The music file is held at
+# http://www.eternal-lands.com/page/music.php
+# We only mirror it so that it is versioned by the date we mirrored it
+# AND prefixed with el_ so as not cause any conflicts. Maybe oneday they will
+# version their music, maybe not.
+
+LICENSE="eternal_lands"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="music sound bloodsuckermaps"
+
+DEPEND="app-arch/unzip
+ !bloodsuckermaps? ( !games-rpg/eternal-lands-bloodsucker )"
+
+PDEPEND="bloodsuckermaps? ( games-rpg/eternal-lands-bloodsucker )"
+
+# Maybe one day upstream will do things in a consistent way.
+S="${WORKDIR}/el_linux"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Move our music files to the correct directory
+ if use music ; then
+ mkdir music
+ mv ../*.ogg ../*.pll music || die
+ fi
+}
+
+src_install() {
+ # These are provided by eternal-lands ebuild
+
+ rm license.txt
+ rm commands.lst
+
+ # don't install maps if using alternate maps
+ if use bloodsuckermaps ; then
+ rm maps/anitora.dds maps/cave1.dds maps/cont2map10.dds
+ rm maps/cont2map11.dds maps/cont2map12.dds maps/cont2map13.dds
+ rm maps/cont2map14.dds maps/cont2map15.dds maps/cont2map16.dds
+ rm maps/cont2map17.dds maps/cont2map18.dds maps/cont2map19.dds
+ rm maps/cont2map1.dds maps/cont2map20.dds maps/cont2map21.dds
+ rm maps/cont2map22.dds maps/cont2map23.dds maps/cont2map24.dds
+ rm maps/cont2map2.dds maps/cont2map3.dds maps/cont2map4.dds
+ rm maps/cont2map5.dds maps/cont2map6.dds maps/cont2map7.dds
+ rm maps/cont2map8.dds maps/cont2map9.dds maps/irilion.dds
+ rm maps/legend.dds maps/map11.dds maps/map12.dds
+ rm maps/map13.dds maps/map14f.dds maps/map15f.dds
+ rm maps/map2.dds maps/map3.dds maps/map4f.dds
+ rm maps/map5nf.dds maps/map6nf.dds maps/map7.dds
+ rm maps/map8.dds maps/map9f.dds maps/seridia.dds
+ rm maps/startmap.dds
+ fi
+
+ insopts -m 0660
+ insinto "${GAMES_DATADIR}/${MY_PN}"
+ doins -r 2dobjects 3dobjects actor_defs animations maps meshes \
+ particles skeletons shaders textures languages shaders skybox \
+ *.lst 3dobjects.txt *.xml \
+ || die "doins failed"
+
+ if use music ; then
+ doins -r music || die "doins music failed"
+ fi
+
+ # Removed sound from above - need to handle sound support
+
+ cd "${WORKDIR}"
+ if use sound ; then
+ doins -r sound || die "doins sound failed"
+ fi
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ # Ensure that the files are writable by the game group for auto
+ # updating.
+ chmod -R g+rw "${ROOT}/${GAMES_DATADIR}/${MY_PN}"
+
+ # Make sure new files stay in games group
+ find "${ROOT}/${GAMES_DATADIR}/${MY_PN}" -type d -exec chmod g+sx {} \;
+}
diff --git a/games-rpg/eternal-lands/ChangeLog b/games-rpg/eternal-lands/ChangeLog
index 14ba866c5fc3..502739110536 100644
--- a/games-rpg/eternal-lands/ChangeLog
+++ b/games-rpg/eternal-lands/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-rpg/eternal-lands
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands/ChangeLog,v 1.56 2011/03/19 19:33:05 rich0 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands/ChangeLog,v 1.57 2011/06/18 18:26:02 rich0 Exp $
+
+*eternal-lands-1.9.2 (18 Jun 2011)
+
+ 18 Jun 2011; Richard Freeman <rich0@gentoo.org> +eternal-lands-1.9.2.ebuild,
+ +files/eternal-lands-1.9.2-glext.patch:
+ version bump - 372181
19 Mar 2011; Richard Freeman <rich0@gentoo.org>
eternal-lands-1.9.1.ebuild, +files/eternal-lands-1.9.1-libpng.patch:
diff --git a/games-rpg/eternal-lands/eternal-lands-1.9.2.ebuild b/games-rpg/eternal-lands/eternal-lands-1.9.2.ebuild
new file mode 100644
index 000000000000..1c4315089624
--- /dev/null
+++ b/games-rpg/eternal-lands/eternal-lands-1.9.2.ebuild
@@ -0,0 +1,150 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands/eternal-lands-1.9.2.ebuild,v 1.1 2011/06/18 18:26:02 rich0 Exp $
+
+EAPI=2
+inherit eutils flag-o-matic games
+
+DESCRIPTION="An online MMORPG written in C and SDL"
+HOMEPAGE="http://www.eternal-lands.com"
+SRC_URI="http://dev.gentoo.org/~rich0/distfiles/elc_1.9.2-20110618.tar.bz2
+ http://dev.gentoo.org/~rich0/distfiles/eternal-lands.png"
+
+LICENSE="eternal_lands"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="debug doc kernel_linux"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ virtual/opengl
+ virtual/glu
+ media-libs/libsdl[X]
+ media-libs/sdl-net
+ media-libs/sdl-image
+ media-libs/openal
+ media-libs/freealut
+ media-libs/libvorbis
+ dev-libs/libxml2
+ media-libs/cal3d[-16bit-indices]
+ media-libs/libpng
+ >=games-rpg/eternal-lands-data-1.9.2"
+
+DEPEND="${RDEPEND}
+ >=app-admin/eselect-opengl-1.0.6-r1
+ app-arch/unzip
+ doc? ( app-doc/doxygen
+ media-gfx/graphviz )"
+
+#ECVS_SERVER="cvs.elc.berlios.de:/cvsroot/elc"
+#ECVS_MODULE="elc"
+#ECVS_USER="anonymous"
+#ECVS_LOCALNAME="elc"
+#ECVS_PASS=""
+#ECVS_CVS_OPTIONS="-dP -z3"
+#ECVS_BRANCH="elc_1_8_0"
+
+#S="${WORKDIR}/${ECVS_MODULE}"
+S="${WORKDIR}/elc"
+
+src_unpack() {
+# cvs_src_unpack
+ OPTIONS="-DDATA_DIR="\\\\\"${GAMES_DATADIR}/${PN}/\\\\\"""
+ S_CLIENT="${WORKDIR}/elc"
+ BROWSER="firefox"
+ unpack ${A}
+ cd "${S}"
+}
+
+src_prepare() {
+ # Add debugging options
+ if use debug ; then
+ OPTIONS="${OPTIONS} -DMEMORY_DEBUG"
+ append-flags -ggdb
+ fi
+
+ # Clean compile flags (make Gentoo friendly)
+ sed -i \
+ -e "s@CFLAGS=\$(PLATFORM) \$(CWARN) -O0 -ggdb -pipe@CFLAGS = ${CFLAGS} ${OPTIONS} @g" \
+ -e "s@CXXFLAGS=\$(PLATFORM) \$(CXXWARN) -O0 -ggdb -pipe@CXXFLAGS = ${CXXFLAGS} ${OPTIONS} @g" \
+ -e 's/lopenal/lopenal -l alut/' \
+ Makefile.linux || die "sed failed"
+
+ sed -i \
+ -e 's/#browser/browser/g' \
+ -e "s/browser = mozilla/#browser = ${BROWSER}/g" \
+ -e "s@#data_dir = /usr/local/games/el/@#data_dir = ${GAMES_DATADIR}/${PN}/@g" \
+ el.ini || die "sed failed"
+
+ # Support BSD in the Linux makefile - it's easier
+ use kernel_linux || sed -i \
+ -e 's/^CFLAGS=.*/& -DBSD/' \
+ Makefile.linux || die "sed failed"
+
+ # Clean up library flag order for --as-needed
+# sed -i -e 's/@$(LINK) $(CFLAGS) $(LDFLAGS) -o $(EXE) $(OBJS)/@$(LINK) $(CFLAGS) -o $(EXE) $(OBJS) $(LDFLAGS)/' Makefile.linux
+
+ # Finally, update the server
+ sed -i -e '/#server_address =/ s/.*/#server_address = game.eternal-lands.com/' \
+ el.ini || die "sed failed"
+
+ sed -i -e 's:FEATURES:EL_FEATURES:' make.defaults
+ sed -i -e 's:FEATURES:EL_FEATURES:' Makefile.linux
+
+ if use debug; then
+ sed -i -e 's/#\(EL_FEATURES += MEMORY_DEBUG\)/\1/' make.defaults
+ sed -i -e 's/#\(EL_FEATURES += MEMORY_DEBUG\)/\1/' Makefile.linux
+ fi
+
+ cp Makefile.linux Makefile
+
+ epatch "${FILESDIR}/${PN}-1.9.2-glext.patch"
+# epatch "${FILESDIR}/${PN}-1.9.1-libpng.patch"
+}
+
+src_compile() {
+ emake || die "make failed"
+
+ if use doc; then
+ emake docs || die "Failed to create documentation, try with USE=-doc"
+ mv ./docs/html/ ../client || die "Failed to move documentation directory"
+ fi
+}
+
+src_install() {
+ doicon "${DISTDIR}/eternal-lands.png" ${PN}.png
+
+ newgamesbin el.x86.linux.bin el \
+ || die "newgamesbin failed"
+ make_desktop_entry el "Eternal Lands" \
+ || die "make_desktop_entry failed"
+ insopts -m 0660
+ insinto "${GAMES_DATADIR}/${PN}"
+
+ doins -r *.ini *.txt commands.lst \
+ || die "doins failed"
+
+ if use doc ; then
+ dohtml -r client/*
+ fi
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "Auto Update is now enabled in Eternal Lands"
+ elog "If an update occurs then the client will suddenly exit"
+ elog "Updates only happen when the game first loads"
+ elog "Please don't report this behaviour as a bug"
+
+ # Ensure that the files are writable by the game group for auto
+ # updating.
+ chmod -R g+rw "${ROOT}/${GAMES_DATADIR}/${PN}"
+
+ # Make sure new files stay in games group
+ find "${ROOT}/${GAMES_DATADIR}/${PN}" -type d -exec chmod g+sx {} \;
+
+}
diff --git a/games-rpg/eternal-lands/files/eternal-lands-1.9.2-glext.patch b/games-rpg/eternal-lands/files/eternal-lands-1.9.2-glext.patch
new file mode 100644
index 000000000000..f096d2fc4253
--- /dev/null
+++ b/games-rpg/eternal-lands/files/eternal-lands-1.9.2-glext.patch
@@ -0,0 +1,11 @@
+--- platform.h.orig 2011-06-18 13:55:09.704489907 -0400
++++ platform.h 2011-06-18 13:55:41.675544567 -0400
+@@ -79,7 +79,7 @@
+ #define GL_GLEXT_LEGACY
+ #include <GL/gl.h>
+ #include <GL/glu.h>
+- #include "glext.h"
++ #include <GL/glext.h>
+ #else // BSD
+ #include <GL/gl.h>
+ #include <GL/glu.h>