summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-03-24 04:57:29 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-03-24 04:57:29 +0000
commit843bdd2da6ecd38e545aa00c3402a112e4c029e3 (patch)
tree43624ef810b1641528d50370f1875c762465693e /games-sports/torcs/torcs-1.2.1.ebuild
parentAdding gnome-a11y stuff (diff)
downloadhistorical-843bdd2da6ecd38e545aa00c3402a112e4c029e3.tar.gz
historical-843bdd2da6ecd38e545aa00c3402a112e4c029e3.tar.bz2
historical-843bdd2da6ecd38e545aa00c3402a112e4c029e3.zip
don't rdepend on sed
Diffstat (limited to 'games-sports/torcs/torcs-1.2.1.ebuild')
-rw-r--r--games-sports/torcs/torcs-1.2.1.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/games-sports/torcs/torcs-1.2.1.ebuild b/games-sports/torcs/torcs-1.2.1.ebuild
index 0dccea00ba55..9c18b9250bdf 100644
--- a/games-sports/torcs/torcs-1.2.1.ebuild
+++ b/games-sports/torcs/torcs-1.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/torcs/torcs-1.2.1.ebuild,v 1.2 2004/02/26 10:36:53 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/torcs/torcs-1.2.1.ebuild,v 1.3 2004/03/24 04:57:29 mr_bones_ Exp $
inherit games
@@ -17,25 +17,28 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
-DEPEND=">=media-libs/plib-1.6
- >=sys-apps/sed-4
+RDEPEND=">=media-libs/plib-1.6
virtual/opengl
virtual/glut
media-libs/libpng
sys-libs/zlib"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
src_compile() {
sed -i "/^instdir =/s:=.*:= ${GAMES_DATADIR}/${PN}:" Make-config.in
egamesconf \
--libdir=${GAMES_LIBDIR}/${PN} \
|| die
- env HOME=${T} make || die
+ env HOME=${T} emake -j1 || die
}
src_install() {
- make DESTDIR=${D} install || die
- dosed "s:DEFAULT_RUNTIME=.*:DEFAULT_RUNTIME=${GAMES_DATADIR}/${PN}:" ${GAMES_BINDIR}/torcs
- mv ${WORKDIR}/{cars,categories,data,menu,tracks} ${D}/${GAMES_DATADIR}/${PN}/
+ make DESTDIR="${D}" install || die "make install failed"
+ dosed "s:DEFAULT_RUNTIME=.*:DEFAULT_RUNTIME=${GAMES_DATADIR}/${PN}:" \
+ "${GAMES_BINDIR}/torcs"
+ mv ${WORKDIR}/{cars,categories,data,menu,tracks} \
+ "${D}/${GAMES_DATADIR}/${PN}/"
dodoc README.linux
dohtml *.html *.png
prepgamesdirs