summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-12-27 18:29:52 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-12-27 18:29:52 +0000
commita61d0e265b8ab309a8ba663d2ef0ad5fd769eb10 (patch)
treec227a726e0cd7e3e25b9db307f73a1c50eaeda18 /games-strategy/crimson/crimson-0.5.2.ebuild
parentremove automagic dependency on libffi, bug #198875 (diff)
downloadhistorical-a61d0e265b8ab309a8ba663d2ef0ad5fd769eb10.tar.gz
historical-a61d0e265b8ab309a8ba663d2ef0ad5fd769eb10.tar.bz2
historical-a61d0e265b8ab309a8ba663d2ef0ad5fd769eb10.zip
version bump
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'games-strategy/crimson/crimson-0.5.2.ebuild')
-rw-r--r--games-strategy/crimson/crimson-0.5.2.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/games-strategy/crimson/crimson-0.5.2.ebuild b/games-strategy/crimson/crimson-0.5.2.ebuild
new file mode 100644
index 000000000000..ba05bd5ff64e
--- /dev/null
+++ b/games-strategy/crimson/crimson-0.5.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/crimson/crimson-0.5.2.ebuild,v 1.1 2007/12/27 18:29:51 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="Tactical war game in the tradition of Battle Isle"
+HOMEPAGE="http://crimson.seul.org/"
+SRC_URI="http://crimson.seul.org/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="test zlib"
+
+RDEPEND="media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf
+ media-libs/sdl-net
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ test? (
+ =app-text/docbook-xml-dtd-4.2*
+ dev-libs/libxml2
+ )"
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --enable-sound \
+ --enable-net \
+ $(use_with zlib) \
+ --enable-cfed \
+ --enable-bi2cf \
+ --enable-comet \
+ --enable-cf2bmp \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ pixmapsdir="/usr/share/pixmaps" \
+ install || die "emake install failed"
+ dodoc NEWS README* THANKS TODO
+ rm -rf "${D}/${GAMES_DATADIR}/applications"
+ make_desktop_entry crimson "Crimson Fields"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ ewarn "Crimson Fields ${PV} is not save-game compatible with previous versions."
+ echo
+ elog "If you have older save files and you wish to continue those games,"
+ elog "you'll need to remerge the version with which you started"
+ elog "those save-games."
+}