summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-06-21 17:52:25 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-06-21 17:52:25 +0000
commit202422fa6aa14bd6a14e718886bd95645c724a23 (patch)
tree3a64a195bd1b1f9c34ece3d25ef292633e05f56c /games-strategy/wesnoth
parentAdded dvd use flag, thanks Benjamin Schleinzer bug# 54621 (diff)
downloadhistorical-202422fa6aa14bd6a14e718886bd95645c724a23.tar.gz
historical-202422fa6aa14bd6a14e718886bd95645c724a23.tar.bz2
historical-202422fa6aa14bd6a14e718886bd95645c724a23.zip
version bump
Diffstat (limited to 'games-strategy/wesnoth')
-rw-r--r--games-strategy/wesnoth/ChangeLog7
-rw-r--r--games-strategy/wesnoth/Manifest4
-rw-r--r--games-strategy/wesnoth/files/digest-wesnoth-0.7.101
-rw-r--r--games-strategy/wesnoth/wesnoth-0.7.10.ebuild41
4 files changed, 51 insertions, 2 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index f3725035eb70..281e95c28799 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.28 2004/06/12 01:24:21 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.29 2004/06/21 17:52:25 mr_bones_ Exp $
+
+*wesnoth-0.7.10 (21 Jun 2004)
+
+ 21 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org> wesnoth-0.7.10.ebuild:
+ version bump
11 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org> wesnoth-0.7.6.ebuild,
wesnoth-0.7.7.ebuild:
diff --git a/games-strategy/wesnoth/Manifest b/games-strategy/wesnoth/Manifest
index b0df1eb94102..faf62549486a 100644
--- a/games-strategy/wesnoth/Manifest
+++ b/games-strategy/wesnoth/Manifest
@@ -1,6 +1,8 @@
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 7ceb543aa7e8a9bfcf6123f2ec732be1 ChangeLog 4022
+MD5 10201d70261150026fefe3aafbb7fd95 ChangeLog 4147
MD5 21bb5a7a1f8656b23bf0772666af7048 wesnoth-0.7.8.ebuild 1120
MD5 59fcf846a191a09b5985332c2da8cba2 wesnoth-0.7.9.ebuild 1125
+MD5 e10ed81100cdd7a0c1e1235c4ddeb0b4 wesnoth-0.7.10.ebuild 1126
MD5 2cd6699b20930421a34650e4a1c03b83 files/digest-wesnoth-0.7.8 67
MD5 412612ed1704ad03f84dc127a5bb9045 files/digest-wesnoth-0.7.9 67
+MD5 8caf74723a1c656cc112cdd5d41dc196 files/digest-wesnoth-0.7.10 68
diff --git a/games-strategy/wesnoth/files/digest-wesnoth-0.7.10 b/games-strategy/wesnoth/files/digest-wesnoth-0.7.10
new file mode 100644
index 000000000000..4da928e1ce7f
--- /dev/null
+++ b/games-strategy/wesnoth/files/digest-wesnoth-0.7.10
@@ -0,0 +1 @@
+MD5 61a6498f4562f70c249a3c40ad23ad40 wesnoth-0.7.10.tar.gz 21797119
diff --git a/games-strategy/wesnoth/wesnoth-0.7.10.ebuild b/games-strategy/wesnoth/wesnoth-0.7.10.ebuild
new file mode 100644
index 000000000000..881a983e7404
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-0.7.10.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-0.7.10.ebuild,v 1.1 2004/06/21 17:52:25 mr_bones_ Exp $
+
+inherit flag-o-matic gcc games
+
+DESCRIPTION="A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="http://www.wesnoth.org/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc sparc amd64"
+IUSE="server editor tools gnome kde"
+
+DEPEND=">=media-libs/libsdl-1.2.7
+ >=media-libs/sdl-image-1.2
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/sdl-ttf-2.0
+ media-libs/sdl-net
+ virtual/x11"
+
+src_compile() {
+ [ "$(gcc-fullversion)" == "3.4.0" ] && filter-flags -ftracer
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable server) \
+ $(use_enable editor) \
+ $(use_enable tools) \
+ $(use_enable gnome) \
+ $(use_enable kde) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ mv "${D}${GAMES_DATADIR}/icons" "${D}/usr/share/"
+ dodoc MANUAL changelog || die "dodoc failed"
+ prepgamesdirs
+}