summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-05-24 23:10:30 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-05-24 23:10:30 +0000
commitd253765118ff880b16f5a564fe771d0106f1a2bd (patch)
tree077619d1189adcfbfa313403ccb460c628c5b0c8 /games-strategy/wesnoth
parentAMD64 keywords (diff)
downloadhistorical-d253765118ff880b16f5a564fe771d0106f1a2bd.tar.gz
historical-d253765118ff880b16f5a564fe771d0106f1a2bd.tar.bz2
historical-d253765118ff880b16f5a564fe771d0106f1a2bd.zip
version bump
Diffstat (limited to 'games-strategy/wesnoth')
-rw-r--r--games-strategy/wesnoth/ChangeLog7
-rw-r--r--games-strategy/wesnoth/Manifest4
-rw-r--r--games-strategy/wesnoth/files/digest-wesnoth-0.7.71
-rw-r--r--games-strategy/wesnoth/wesnoth-0.7.7.ebuild40
4 files changed, 50 insertions, 2 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index 8b77fd5b322a..87dce1f64804 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.24 2004/05/04 04:43:00 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.25 2004/05/24 23:10:30 mr_bones_ Exp $
+
+*wesnoth-0.7.7 (24 May 2004)
+
+ 24 May 2004; Michael Sterrett <mr_bones_@gentoo.org> wesnoth-0.7.7.ebuild:
+ version bump
03 May 2004; Michael Sterrett <mr_bones_@gentoo.org> wesnoth-0.7.1.ebuild,
wesnoth-0.7.2.ebuild, wesnoth-0.7.ebuild:
diff --git a/games-strategy/wesnoth/Manifest b/games-strategy/wesnoth/Manifest
index 077ab5b1a0cc..21e93ded3fb9 100644
--- a/games-strategy/wesnoth/Manifest
+++ b/games-strategy/wesnoth/Manifest
@@ -1,4 +1,6 @@
+MD5 8e69a78da8c7ddba59713f6da921f3ed wesnoth-0.7.7.ebuild 1060
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 55f77fb806797baecbf8666a149b9900 ChangeLog 3530
+MD5 3211378725e7a42249bbaaa653a0627b ChangeLog 3653
MD5 8a9578dd0bbb80276a00175aa2ca8371 wesnoth-0.7.6.ebuild 1060
+MD5 d8fa195a2ff1df49d290b1ed77e38a87 files/digest-wesnoth-0.7.7 67
MD5 85c8760fa128b26e3a29168510ffe3fd files/digest-wesnoth-0.7.6 67
diff --git a/games-strategy/wesnoth/files/digest-wesnoth-0.7.7 b/games-strategy/wesnoth/files/digest-wesnoth-0.7.7
new file mode 100644
index 000000000000..2dfb1ef0473d
--- /dev/null
+++ b/games-strategy/wesnoth/files/digest-wesnoth-0.7.7
@@ -0,0 +1 @@
+MD5 4216a6ac54274589d00858d49f7609aa wesnoth-0.7.7.tar.gz 19686247
diff --git a/games-strategy/wesnoth/wesnoth-0.7.7.ebuild b/games-strategy/wesnoth/wesnoth-0.7.7.ebuild
new file mode 100644
index 000000000000..1be2fd0af3bd
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-0.7.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-0.7.7.ebuild,v 1.1 2004/05/24 23:10:30 mr_bones_ Exp $
+
+inherit flag-o-matic games
+
+DESCRIPTION="A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="http://www.wesnoth.org/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 amd64 ppc ~sparc"
+IUSE="server editor tools gnome kde"
+
+DEPEND=">=media-libs/libsdl-1.2
+ >=media-libs/sdl-image-1.2
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/sdl-ttf-2.0
+ media-libs/sdl-net
+ virtual/x11"
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable server) \
+ $(use_enable editor) \
+ $(use_enable tools) \
+ $(use_enable gnome) \
+ $(use_enable kde) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ mv "${D}${GAMES_DATADIR}/icons" "${D}/usr/share/"
+ dodoc MANUAL changelog || die "dodoc failed"
+ prepgamesdirs
+}