summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-10-15 06:32:44 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-10-15 06:32:44 +0000
commit6cd63be0c05cace67d697986529f7be77a54c74c (patch)
tree248c038e6a917fcb7e796b1dfc7d3dd191789114 /games-strategy
parentVersion bumped. (diff)
downloadhistorical-6cd63be0c05cace67d697986529f7be77a54c74c.tar.gz
historical-6cd63be0c05cace67d697986529f7be77a54c74c.tar.bz2
historical-6cd63be0c05cace67d697986529f7be77a54c74c.zip
version bump (bug #66791)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/glob2/ChangeLog7
-rw-r--r--games-strategy/glob2/Manifest4
-rw-r--r--games-strategy/glob2/files/digest-glob2-0.8.91
-rw-r--r--games-strategy/glob2/glob2-0.8.9.ebuild48
4 files changed, 58 insertions, 2 deletions
diff --git a/games-strategy/glob2/ChangeLog b/games-strategy/glob2/ChangeLog
index 54f011f3e604..47ad06a7443c 100644
--- a/games-strategy/glob2/ChangeLog
+++ b/games-strategy/glob2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/glob2
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/ChangeLog,v 1.13 2004/09/18 03:14:03 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/ChangeLog,v 1.14 2004/10/15 06:32:44 mr_bones_ Exp $
+
+*glob2-0.8.9 (14 Oct 2004)
+
+ 14 Oct 2004; Michael Sterrett <mr_bones_@gentoo.org> +glob2-0.8.9.ebuild:
+ version bump (bug #66791)
*glob2-0.8.8 (17 Sep 2004)
diff --git a/games-strategy/glob2/Manifest b/games-strategy/glob2/Manifest
index fab4bb1fddb0..e5e0b1c255e3 100644
--- a/games-strategy/glob2/Manifest
+++ b/games-strategy/glob2/Manifest
@@ -1,6 +1,8 @@
-MD5 e66d8a0093174ec4328a1afb1b649151 ChangeLog 1467
+MD5 fabbf368d907c5a426780601a7f35f19 ChangeLog 1600
MD5 5aa338ac457c802d85f84394932f46ad glob2-0.8.7.ebuild 959
MD5 be3faa436a456146cab34d1a7ba5e534 metadata.xml 546
MD5 86bbee1610aedd934e30870b03b54b38 glob2-0.8.8.ebuild 1017
+MD5 73ecd2b674d4b4803c43c3d850bbfd68 glob2-0.8.9.ebuild 1160
MD5 43e352a12416a207b6b3375c57086637 files/digest-glob2-0.8.7 64
MD5 8bc921c1e002e9028de41eb49f11e284 files/digest-glob2-0.8.8 64
+MD5 de4d5ea54b6291db91857fb227244587 files/digest-glob2-0.8.9 64
diff --git a/games-strategy/glob2/files/digest-glob2-0.8.9 b/games-strategy/glob2/files/digest-glob2-0.8.9
new file mode 100644
index 000000000000..49173dc3d84a
--- /dev/null
+++ b/games-strategy/glob2/files/digest-glob2-0.8.9
@@ -0,0 +1 @@
+MD5 1461701be76fdb860d8ebb83fba0bd3e glob2-0.8.9.tar.gz 7882466
diff --git a/games-strategy/glob2/glob2-0.8.9.ebuild b/games-strategy/glob2/glob2-0.8.9.ebuild
new file mode 100644
index 000000000000..14839a245516
--- /dev/null
+++ b/games-strategy/glob2/glob2-0.8.9.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/glob2-0.8.9.ebuild,v 1.1 2004/10/15 06:32:44 mr_bones_ Exp $
+
+inherit flag-o-matic games
+
+DESCRIPTION="state of the art Real Time Strategy (RTS) game"
+HOMEPAGE="http://www.ysagoon.com/glob2/"
+SRC_URI="http://www.ysagoon.com/glob2/data/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~amd64"
+IUSE=""
+
+DEPEND="virtual/libc
+ virtual/opengl
+ >=media-libs/libsdl-1.2.0
+ media-libs/libpng
+ media-libs/sdl-net
+ media-libs/sdl-image
+ media-libs/libvorbis
+ =media-libs/freetype-2*
+ sys-libs/zlib"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "s/defaultLanguage = 1/defaultLanguage = 0/" src/Settings.cpp \
+ || die "sed failed"
+}
+
+src_compile() {
+ # comment from bug #64150 to fix compile issue.
+ filter-flags -O?
+ #./configure assumes that vorbis will be installed under PREFIX bug #46352
+ egamesconf \
+ --with-vorbis=/usr \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README TODO
+ prepgamesdirs
+}