summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-11-10 21:34:30 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-11-10 21:34:30 +0000
commit927a357f01f9597acefa7f2263995cc29a68cfb5 (patch)
treeb4e273d2ffdaf4410cbda69cb3a51952e64dd15d /games-strategy
parentversion bump (diff)
downloadhistorical-927a357f01f9597acefa7f2263995cc29a68cfb5.tar.gz
historical-927a357f01f9597acefa7f2263995cc29a68cfb5.tar.bz2
historical-927a357f01f9597acefa7f2263995cc29a68cfb5.zip
version bump
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/Manifest4
-rw-r--r--games-strategy/wesnoth/files/digest-wesnoth-0.5.11
-rw-r--r--games-strategy/wesnoth/wesnoth-0.5.1.ebuild38
3 files changed, 41 insertions, 2 deletions
diff --git a/games-strategy/wesnoth/Manifest b/games-strategy/wesnoth/Manifest
index b38aec9df88d..e5c67fa5a009 100644
--- a/games-strategy/wesnoth/Manifest
+++ b/games-strategy/wesnoth/Manifest
@@ -1,7 +1,7 @@
MD5 780c10b9072e511acd2797e086ddffc6 wesnoth-0.4.8.ebuild 1042
MD5 a30c9d4ce8f9629d6d7323eaab258343 metadata.xml 241
-MD5 5e3f60c1f7e52d98c88a7acd7d995fec ChangeLog 632
-MD5 88e0299b82816b16baf7606ff642e504 wesnoth-0.5.1.ebuild 1194
+MD5 d5cc067e64d26964695c8a87c555033d ChangeLog 755
+MD5 b9292d6bd7a6fbb0e7f19d972d492e07 wesnoth-0.5.1.ebuild 1080
MD5 98d8279a9f3f24a2c5d7cb0df9a3eb2c wesnoth-0.5.ebuild 1191
MD5 12449f4d45609424ab20eb79f5f77baf files/digest-wesnoth-0.4.8 66
MD5 906d61f6bd37904556d48a72fd3d7e7f files/digest-wesnoth-0.5 65
diff --git a/games-strategy/wesnoth/files/digest-wesnoth-0.5.1 b/games-strategy/wesnoth/files/digest-wesnoth-0.5.1
new file mode 100644
index 000000000000..986f28678748
--- /dev/null
+++ b/games-strategy/wesnoth/files/digest-wesnoth-0.5.1
@@ -0,0 +1 @@
+MD5 040fd1aaa3f3913482805301e9e3ec6a wesnoth-0.5.1.tar.gz 10582148
diff --git a/games-strategy/wesnoth/wesnoth-0.5.1.ebuild b/games-strategy/wesnoth/wesnoth-0.5.1.ebuild
new file mode 100644
index 000000000000..d2fc260403af
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-0.5.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-0.5.1.ebuild,v 1.1 2003/11/10 21:34:15 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="http://www.wesnoth.org/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="x86"
+SLOT="0"
+
+DEPEND=">=media-libs/libsdl-1.2
+ >=media-libs/sdl-image-1.2
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/sdl-ttf-2.0
+ media-libs/sdl-net
+ virtual/x11"
+
+src_compile() {
+ CXXFLAGS="${CXXFLAGS} -DWESNOTH_PATH=\\\"${GAMES_DATADIR}/wesnoth\\\""
+ emake || die "emake failed"
+}
+
+src_install() {
+ dogamesbin wesnoth || die "dogamesbin failed"
+ dodoc MANUAL changelog || die "dodoc failed"
+ dodir ${GAMES_DATADIR}/wesnoth || die "dodir failed"
+ cp -r data fonts images music sounds \
+ ${D}${GAMES_DATADIR}/wesnoth/ || die "cp failed"
+
+ # Tidy up the mess
+ find ${D}${GAMES_DATADIR} -type f -exec chmod a-x \{\} \;
+
+ prepgamesdirs
+}