summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-02-14 16:35:14 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-02-14 16:35:14 +0000
commita94eb2e6e48d90dde6c12ba61da75801b5c9ea38 (patch)
tree4e08f9b5d2ebb17cd6ac0bc94fc5f2f5cba52836 /games-util/atlas
parentcleaning up the house (diff)
downloadhistorical-a94eb2e6e48d90dde6c12ba61da75801b5c9ea38.tar.gz
historical-a94eb2e6e48d90dde6c12ba61da75801b5c9ea38.tar.bz2
historical-a94eb2e6e48d90dde6c12ba61da75801b5c9ea38.zip
rev bump to include patch from David Holm (bug #81723)
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'games-util/atlas')
-rw-r--r--games-util/atlas/ChangeLog10
-rw-r--r--games-util/atlas/Manifest7
-rw-r--r--games-util/atlas/atlas-0.2.2-r1.ebuild65
-rw-r--r--games-util/atlas/atlas-0.2.2.ebuild4
-rw-r--r--games-util/atlas/files/0.2.2-fix.patch29
-rw-r--r--games-util/atlas/files/digest-atlas-0.2.2-r11
6 files changed, 110 insertions, 6 deletions
diff --git a/games-util/atlas/ChangeLog b/games-util/atlas/ChangeLog
index f45b4dbecc30..69296fb1d24d 100644
--- a/games-util/atlas/ChangeLog
+++ b/games-util/atlas/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-util/atlas
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/atlas/ChangeLog,v 1.4 2004/06/24 23:31:09 agriffis Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/atlas/ChangeLog,v 1.5 2005/02/14 16:35:14 mr_bones_ Exp $
+
+*atlas-0.2.2-r1 (14 Feb 2005)
+
+ 14 Feb 2005; Michael Sterrett <mr_bones_@gentoo.org> +files/0.2.2-fix.patch,
+ +atlas-0.2.2-r1.ebuild:
+ rev bump to include patch from David Holm (bug #81723)
12 Apr 2004; Jason Wever <weeve@gentoo.org> atlas-0.2.2.ebuild:
Added ~sparc keyword.
diff --git a/games-util/atlas/Manifest b/games-util/atlas/Manifest
index 61346493f24f..d0ee368e40c4 100644
--- a/games-util/atlas/Manifest
+++ b/games-util/atlas/Manifest
@@ -1,4 +1,7 @@
-MD5 ffbfa35216c9d5c26b92367c861b1d41 atlas-0.2.2.ebuild 1701
-MD5 a753e023aa782e2e663291df87b9f5bf ChangeLog 554
+MD5 e5098938526edea2d538147323d3fdb5 ChangeLog 749
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 e7629f3b1b7b8bfa0a58b998e5264015 atlas-0.2.2-r1.ebuild 1745
+MD5 471cdf6e789bde460b4d209ccd41d27a atlas-0.2.2.ebuild 1702
+MD5 db161652379b66290a05d4a6e3631032 files/0.2.2-fix.patch 664
MD5 c22c70a726175c84565f4182fff72185 files/digest-atlas-0.2.2 63
+MD5 c22c70a726175c84565f4182fff72185 files/digest-atlas-0.2.2-r1 63
diff --git a/games-util/atlas/atlas-0.2.2-r1.ebuild b/games-util/atlas/atlas-0.2.2-r1.ebuild
new file mode 100644
index 000000000000..0fabc93847c2
--- /dev/null
+++ b/games-util/atlas/atlas-0.2.2-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/atlas/atlas-0.2.2-r1.ebuild,v 1.1 2005/02/14 16:35:14 mr_bones_ Exp $
+
+inherit games
+
+MY_P="Atlas-${PV}"
+DESCRIPTION="Chart Program to use with Flightgear Flight Simulator"
+HOMEPAGE="http://atlas.sourceforge.net/"
+SRC_URI="mirror://sourceforge/atlas/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~sparc ~x86"
+IUSE=""
+
+DEPEND=">=games-simulation/flightgear-0.9.4
+ >=media-libs/libpng-1.2.5
+ >=media-libs/plib-1.4
+ virtual/glut"
+
+S=${WORKDIR}/${MY_P}
+
+INSDESTTREE="/usr/games/lib/FlightGear"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-fix.patch"
+}
+
+src_compile() {
+ egamesconf --with-fgbase=/usr/games/lib/FlightGear || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ doins "${S}/src/AtlasPalette" || die
+ egamesinstall || die
+ keepdir /usr/games/lib/FlightGear/Atlas/lowres
+ dodoc AUTHORS README
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ einfo "You now can make the maps with the following commands:"
+ einfo "/usr/games/bin/Map --atlas=/usr/games/lib/FlightGear/Atlas"
+ einfo "/usr/games/bin/Map --atlas=/usr/games/lib/FlightGear/Atlas/lowres --size=64"
+ echo
+ einfo "To run Atlas concurrently with FlightGear use the following:"
+ einfo "Atlas --path=[path of map images] --udp=[port number]"
+ einfo "and start fgfs with the following switch (or in .fgfsrc):"
+ einfo "--nmea=socket,out,0.5,[host that you run Atlas on],[port number],udp"
+ echo
+}
+
+pkg_postrm() {
+ einfo "You must manually remove the maps if you don't want them around."
+ einfo "They are found in the following directory:"
+ echo
+ einfo "/usr/games/lib/FlightGear/Atlas"
+ echo
+}
diff --git a/games-util/atlas/atlas-0.2.2.ebuild b/games-util/atlas/atlas-0.2.2.ebuild
index ee63b9483544..9a647990aee5 100644
--- a/games-util/atlas/atlas-0.2.2.ebuild
+++ b/games-util/atlas/atlas-0.2.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/atlas/atlas-0.2.2.ebuild,v 1.7 2004/06/24 23:31:09 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/atlas/atlas-0.2.2.ebuild,v 1.8 2005/02/14 16:35:14 mr_bones_ Exp $
inherit games
diff --git a/games-util/atlas/files/0.2.2-fix.patch b/games-util/atlas/files/0.2.2-fix.patch
new file mode 100644
index 000000000000..2459fa2daccc
--- /dev/null
+++ b/games-util/atlas/files/0.2.2-fix.patch
@@ -0,0 +1,29 @@
+--- src/Overlays.cxx.orig 2005-02-12 13:58:16.527529528 +0100
++++ src/Overlays.cxx 2005-02-12 13:58:47.580808712 +0100
+@@ -490,7 +490,7 @@
+ return;
+
+ strcpy( arpname, fg_root );
+- strcat( arpname, "/Airports/default.apt.gz" );
++ strcat( arpname, "/Airports/apt.dat.gz" );
+
+ gzFile arp;
+
+@@ -580,7 +580,7 @@
+ return;
+
+ strcpy( navname, fg_root );
+- strcat( navname, "/Navaids/default.nav.gz" );
++ strcat( navname, "/Navaids/nav.dat.gz" );
+
+ gzFile nav;
+
+@@ -653,7 +653,7 @@
+ return;
+
+ strcpy( navname, fg_root );
+- strcat( navname, "/Navaids/default.fix.gz" );
++ strcat( navname, "/Navaids/fix.dat.gz" );
+
+ gzFile fix;
+
diff --git a/games-util/atlas/files/digest-atlas-0.2.2-r1 b/games-util/atlas/files/digest-atlas-0.2.2-r1
new file mode 100644
index 000000000000..4c465fa14141
--- /dev/null
+++ b/games-util/atlas/files/digest-atlas-0.2.2-r1
@@ -0,0 +1 @@
+MD5 a69301f7e762d84c9b3089b87ff7b048 Atlas-0.2.2.tar.gz 156796