summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-04-08 07:46:38 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-04-08 07:46:38 +0000
commit0c826dfd65368abcf6c90bc4f8f0953e4ef06652 (patch)
treedbb866d7cc0cf37f043c90bc670bc2f12de20348 /games-util
parentstable x86, bug 307847 (diff)
downloadhistorical-0c826dfd65368abcf6c90bc4f8f0953e4ef06652.tar.gz
historical-0c826dfd65368abcf6c90bc4f8f0953e4ef06652.tar.bz2
historical-0c826dfd65368abcf6c90bc4f8f0953e4ef06652.zip
initial commit - ebuild and patch submitted by Locke 'Wizzleby' Shinseiko via bug #300328
Package-Manager: portage-2.1.7.17/cvs/Linux i686
Diffstat (limited to 'games-util')
-rw-r--r--games-util/grfcodec/ChangeLog12
-rw-r--r--games-util/grfcodec/Manifest5
-rw-r--r--games-util/grfcodec/files/grfcodec-0_pre2306-build.patch144
-rw-r--r--games-util/grfcodec/grfcodec-0_pre2306.ebuild41
-rw-r--r--games-util/grfcodec/metadata.xml5
5 files changed, 207 insertions, 0 deletions
diff --git a/games-util/grfcodec/ChangeLog b/games-util/grfcodec/ChangeLog
new file mode 100644
index 000000000000..55f8861856fc
--- /dev/null
+++ b/games-util/grfcodec/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for games-util/grfcodec
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/grfcodec/ChangeLog,v 1.1 2010/04/08 07:46:37 mr_bones_ Exp $
+
+*grfcodec-0_pre2306 (08 Apr 2010)
+
+ 08 Apr 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ +grfcodec-0_pre2306.ebuild, +files/grfcodec-0_pre2306-build.patch,
+ +metadata.xml:
+ initial commit - ebuild and patch submitted by Locke 'Wizzleby' Shinseiko
+ via bug #300328
+
diff --git a/games-util/grfcodec/Manifest b/games-util/grfcodec/Manifest
new file mode 100644
index 000000000000..988aad15fe1d
--- /dev/null
+++ b/games-util/grfcodec/Manifest
@@ -0,0 +1,5 @@
+AUX grfcodec-0_pre2306-build.patch 4238 RMD160 4c812ee95856da695405720b49729cf55807a8f4 SHA1 38f0050f9b6accef554b274a56067103ab114bda SHA256 d75602f67e0a4430dd6af88d7ecf5a95786d959d10212de72f6c1a8e1b9c5e5b
+DIST grfcodec-r2306-source.tar.bz2 78345 RMD160 9c2833a2e8f465957b24232bd93c020faaaf72e7 SHA1 d66518e6dc98555d9f242309c1c5adef1f2dbea0 SHA256 b7ea9c6ba4c2c3b5236f64190e6c4af4f449ab2b020823d98fedd78654299602
+EBUILD grfcodec-0_pre2306.ebuild 981 RMD160 680c31656e131f4702926b3326e658daeb4efb35 SHA1 b4ab595ccf3654491d445976d0f15e781774671a SHA256 acc7c103dcec08a3ddef6dd241474264243eb9a6248982ea2bae4e5dead4bbe9
+MISC ChangeLog 485 RMD160 dfc2a5c35c9e37ee58009db67f5021ed88147e05 SHA1 2c4505bd77c369d47c6f748c3f6aaadc065239f4 SHA256 8abc5d625dbe41305365415eebf74e9de9eea1b30646f4a72e654a18a9ed22a1
+MISC metadata.xml 158 RMD160 cbd9984bb6b426c8c9cee5022fe0a26261612fea SHA1 be5251fa1dacef5c41b74761bb1c8c54fb633b9e SHA256 1423a4fdd4a79b1728a2056d9e300f7e1074253095d82726218d9e9b953888a3
diff --git a/games-util/grfcodec/files/grfcodec-0_pre2306-build.patch b/games-util/grfcodec/files/grfcodec-0_pre2306-build.patch
new file mode 100644
index 000000000000..3cde281527c8
--- /dev/null
+++ b/games-util/grfcodec/files/grfcodec-0_pre2306-build.patch
@@ -0,0 +1,144 @@
+diff --git a/Makefile b/Makefile
+index 50e420c..c0e877b 100644
+--- a/Makefile
++++ b/Makefile
+@@ -62,29 +62,32 @@ endif
+ else
+ INSTALLPATH=$(INSTALLPATH_MSYS_MINGW)
+ endif
+-else
++else
+ INSTALLPATH=$(INSTALLPATH_LINUX)
+ endif
+ endif
+
+ # use 386 instructions but optimize for pentium II/III
+-CFLAGS = -g -D$(TYPESIZE) -O3 -I. -O1 -idirafter$(BOOST_INCLUDE) -Wall -Wno-uninitialized $(CFLAGAPP)
++CFLAGS += -D$(TYPESIZE) -I. -idirafter$(BOOST_INCLUDE) -Wall -Wno-uninitialized
++CXXFLAGS += -D$(TYPESIZE) -I. -idirafter$(BOOST_INCLUDE) -Wall -Wno-uninitialized
+
+ ifeq ($(DEBUG),1)
+ CFLAGS += -DDEBUG
++CXXFLAGS += -DDEBUG
+ endif
+
+ ifeq ($(MACHINE),mingw32)
+ CFLAGS += -DMINGW
++CXXFLAGS += -DMINGW
+ endif
+
+ ifeq ($(ISCYGWIN),1)
+ ifeq ($(NOCYGWIN),1)
+ CFLAGS += -DMINGW -mno-cygwin
++CXXFLAGS += -DMINGW -mno-cygwin
+ endif
+ endif
+
+-CXXFLAGS = $(CFLAGS)
+
+
+ # Somewhat automatic detection of the correct boost include folder
+@@ -171,7 +174,7 @@ endif
+ PAL_FILES = pals/$(subst &,.bcp pals/,$(PALORDER)).bcp
+
+ # deafult targets
+-all: $(GRFCODEC) $(GRFDIFF) $(GRFMERGE)
++all: version.h $(GRFCODEC) $(GRFDIFF) $(GRFMERGE)
+ remake: clean all
+
+ ${MAKEFILELOCAL}:
+@@ -181,15 +184,15 @@ ${MAKEFILELOCAL}:
+
+ $(GRFCODEC): $(GRFCODECSRC:%.c=%.o)
+ $(_E) [LD] $@
+- $(_C)$(CXX) -o $@ $(CFLAGS) $^ $(LDOPT)
++ $(_C)$(CXX) -o $@ $(CXXFLAGS) $^ $(LDOPT)
+
+ $(GRFDIFF): $(GRFDIFFSRC:%.c=%.o) grfmrg.o
+ $(_E) [LD] $@
+- $(_C)$(CXX) -o $@ $(CFLAGS) $^ $(LDOPT)
++ $(_C)$(CXX) -o $@ $(CXXFLAGS) $^ $(LDOPT)
+
+ $(GRFMERGE): $(GRFMERGESRC:%.c=%.o)
+ $(_E) [LD] $@
+- $(_C)$(CXX) -o $@ $(CFLAGS) $^ $(LDOPT)
++ $(_C)$(CXX) -o $@ $(CXXFLAGS) $^ $(LDOPT)
+
+
+ clean:
+@@ -219,9 +222,7 @@ FORCE:
+ $(_E) [REBUILD] $(@:%_r=%)
+ $(_C)rm -f $(@:%_r=%)
+ $(_C)$(MAKE) ${_S} $(@:%_r=%)
+- $(_E) [STRIP/UPX] $(@:%_r=%)
+ $(_C)$(STRIP) $(@:%_r=%)
+- $(_C)upx $(_Q) --best $(@:%_r=%)
+
+ release: $(GRFCODEC)_r $(GRFDIFF)_r $(GRFMERGE)_r
+
+@@ -230,9 +231,7 @@ grfmrgc.bin: grfmerge.os $(GRFMERGESRC:%.c=%.os)
+ $(_C)rm -f $@
+ $(_E) [LD] $@
+ $(_C)$(CC) -o $@ $(CFLAGS) -Os $^
+- $(_E) [STRIP/UPX] $@
+ $(_C)$(STRIP) $@
+- $(_C)upx $(_Q) --best $@
+
+ grfmrg.c: grfmrgc.bin grfmrgc.pl
+ $(_E) [PERL] $@
+@@ -291,15 +290,18 @@ ttdpal.h: $(PAL_FILES) pal2c.pl
+
+ %.o.d:
+ $(_E) [CPP DEP] $@
+- $(_C)$(CC) $(CFLAGS) -DMAKEDEP -MM -MG $*.c* -MF $@
++ $(_C)$(CC) $(CFLAGS) -DMAKEDEP -MM -MG error.c getopt.c grfcomm.c grfmerge.c path.c -MF $@
++ $(_C)$(CXX) $(CXXFLAGS) -DMAKEDEP -MM -MG file.cc grfcodec.cc grfdiff.cc info.cc pcxfile.cc pcxsprit.cc readinfo.cc sprites.cc -MF $@
+
+ %.os.d:
+ $(_E) [CPP DEP] $@
+- $(_C)$(CC) $(CFLAGS) -DMAKEDEP -MM -MG -MT ${subst .d,,$@} -MF $@ $*.c*
++ $(_C)$(CC) $(CFLAGS) -DMAKEDEP -MM -MG -MT ${subst .d,,$@} -MF $@ error.c getopt.c grfcomm.c grfmerge.c path.c
++ $(_C)$(CXX) $(CXXFLAGS) -DMAKEDEP -MM -MG -MT ${subst .d,,$@} -MF $@ file.cc grfcodec.cc grfdiff.cc info.cc pcxfile.cc pcxsprit.cc readinfo.cc sprites.cc
+
+-%.obj.d: $(wildcard %.c*)
++%.obj.d:
+ $(_E) [CPP DEP] $@
+- $(_C)$(CC) $(CFLAGS) -DMAKEDEP -MM -MG -MT ${subst .d,,$@} -MF $@ $*.c*
++ $(_C)$(CC) $(CFLAGS) -DMAKEDEP -MM -MG -MT ${subst .d,,$@} -MF $@ error.c getopt.c grfcomm.c grfmerge.c path.c
++ $(_C)$(CXX) $(CXXFLAGS) -DMAKEDEP -MM -MG -MT ${subst .d,,$@} -MF $@ file.cc grfcodec.cc grfdiff.cc info.cc pcxfile.cc pcxsprit.cc readinfo.cc sprites.cc
+
+ ifndef NO_MAKEFILE_DEP
+ -include $(GRFCODECSRC:%.c=%.o.d)
+diff --git a/Makefile.common b/Makefile.common
+index c559c0a..fe99591 100644
+--- a/Makefile.common
++++ b/Makefile.common
+@@ -5,9 +5,7 @@ FORCE:
+ $(_E) [REBUILD] $(@:%_r=%)
+ $(_C)rm -f $(@:%_r=%)$(EXE)
+ $(_C)make -f $(MAKEFILE) $(_S) $(@:%_r=%)
+- $(_E) [STRIP/UPX] $(@:%_r=%)
+ $(_C)strip $(@:%_r=%)$(REL_EXE)
+- $(_C)upx $(_Q) --best $(@:%_r=%)$(REL_EXE)
+
+ release: grfcodec_r grfdiff_r grfmerge_r
+
+@@ -16,9 +14,7 @@ grfmrgc.bin: grfmerge.os $(GRFMERGESRC:%.c=%.os)
+ $(_C)rm -f $@
+ $(_E) [LD] $@
+ $(_C)$(CC) -o $@ $(CFLAGS) -Os $^
+- $(_E) [STRIP/UPX] $@
+ $(_C)strip $@
+- $(_C)upx $(_Q) --best $@
+
+ grfmrg.c: grfmrgc.bin grfmrgc.pl
+ $(_E) [PERL] $@
+@@ -32,7 +28,7 @@ ttdpal.h: $(PAL_FILES) pal2c.pl
+
+ readinfo.o: readinfo.cc
+ $(_E) [CPP] $@
+- $(BOOST_WARN)
++ $(BOOST_WARN)
+ $(_C)$(CXX) -c -o $@ -MMD -MG -MF $@.d $(CXXFLAGS) $<
+
+ %.o : %.c
diff --git a/games-util/grfcodec/grfcodec-0_pre2306.ebuild b/games-util/grfcodec/grfcodec-0_pre2306.ebuild
new file mode 100644
index 000000000000..37dfbed13fe1
--- /dev/null
+++ b/games-util/grfcodec/grfcodec-0_pre2306.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/grfcodec/grfcodec-0_pre2306.ebuild,v 1.1 2010/04/08 07:46:37 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils toolchain-funcs
+
+MY_PV=${PV/0_pre/r}
+DESCRIPTION="A suite of programs to modify openttd/Transport Tycoon Deluxe's GRF files"
+HOMEPAGE="http://binaries.openttd.org/extra/grfcodec/"
+SRC_URI="http://binaries.openttd.org/extra/grfcodec/${MY_PV}/${PN}-${MY_PV}-source.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+DEPEND="dev-lang/perl
+ dev-libs/boost"
+RDEPEND=""
+
+src_prepare() {
+ cat > Makefile.local <<-__EOF__
+ CC = $(tc-getCC)
+ CXX = $(tc-getCXX)
+ CFLAGS = ${CFLAGS}
+ CXXFLAGS = ${CXXFLAGS}
+ LDOPTS = ${LDFLAGS}
+ STRIP = :
+ V = 1
+ __EOF__
+
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_install() {
+ dobin ${PN} grf{diff,merge} || die
+ dodoc *.txt Changelog || die
+}
diff --git a/games-util/grfcodec/metadata.xml b/games-util/grfcodec/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-util/grfcodec/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>