summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-07-18 20:30:40 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-07-18 20:30:40 +0000
commit041bbaf6e1e7d9d6949486ad44b27b43ad59c181 (patch)
tree3bdd0212b74fbb75a851719b3e2dbe719845b8be /gnome-base/gconf
parentremoved stale versions (diff)
downloadhistorical-041bbaf6e1e7d9d6949486ad44b27b43ad59c181.tar.gz
historical-041bbaf6e1e7d9d6949486ad44b27b43ad59c181.tar.bz2
historical-041bbaf6e1e7d9d6949486ad44b27b43ad59c181.zip
adding a dep and chaning mirror:// this will fix the gconf-sanity-check bugs
Diffstat (limited to 'gnome-base/gconf')
-rw-r--r--gnome-base/gconf/ChangeLog7
-rw-r--r--gnome-base/gconf/files/digest-gconf-1.2.0-r41
-rw-r--r--gnome-base/gconf/gconf-1.2.0-r4.ebuild78
3 files changed, 84 insertions, 2 deletions
diff --git a/gnome-base/gconf/ChangeLog b/gnome-base/gconf/ChangeLog
index 532d126773eb..847a997cd328 100644
--- a/gnome-base/gconf/ChangeLog
+++ b/gnome-base/gconf/ChangeLog
@@ -1,8 +1,11 @@
# ChangeLog for gnome-base/gconf
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.18 2002/07/07 23:57:59 spider Exp $
-
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.19 2002/07/18 20:30:40 spider Exp $
+*gconf-1.2.0-r4 (18 Jul 2002)
+ 18 Jul 2002; Spider <spider@gentoo.org> gconf-1.2.0-r4.ebuild :
+ added the dep on gtk+, fixed to use mirror://
+
gconf-1.2.0-r3 (06 Jul 2002)
06 Jul 2002; Spider <spider@gentoo.org> gconf-1.2.0-r3.ebuild :
diff --git a/gnome-base/gconf/files/digest-gconf-1.2.0-r4 b/gnome-base/gconf/files/digest-gconf-1.2.0-r4
new file mode 100644
index 000000000000..04dc91a16097
--- /dev/null
+++ b/gnome-base/gconf/files/digest-gconf-1.2.0-r4
@@ -0,0 +1 @@
+MD5 9815ca4ee765e86047d0f096baf8783b GConf-1.2.0.tar.bz2 935782
diff --git a/gnome-base/gconf/gconf-1.2.0-r4.ebuild b/gnome-base/gconf/gconf-1.2.0-r4.ebuild
new file mode 100644
index 000000000000..605ad221df15
--- /dev/null
+++ b/gnome-base/gconf/gconf-1.2.0-r4.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-1.2.0-r4.ebuild,v 1.1 2002/07/18 20:30:40 spider Exp $
+
+inherit gnome2
+
+MY_PN=GConf
+S=${WORKDIR}/${MY_PN}-${PV}
+DESCRIPTION="Gnome Configuration System and Daemon"
+SRC_URI="mirror://gnome/sources/${MY_PN}/${MY_PN}-${PV}.tar.bz2"
+HOMEPAGE="http://www.gnome.org/"
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="x86 ppc"
+
+RDEPEND=">=dev-libs/glib-2.0.1
+ >=gnome-base/ORBit2-2.4.0
+ >=dev-libs/libxml2-2.4.17
+ >=net-libs/linc-0.5.0
+ >=x11-libs/gtk+-2.0.5"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ doc? ( dev-util/gtk-doc )"
+
+LIBTOOL_FIX="1"
+
+kill_gconf () {
+ # this function will kill all running gconfd that could be causing troubles
+ if [ -x /usr/bin/gconftool ]
+ then
+ /usr/bin/gconftool --shutdown
+ fi
+ if [ -x /usr/bin/gconftool-1 ]
+ then
+ /usr/bin/gconftool-1 --shutdown
+ fi
+
+ # and for gconf 2
+ if [ -x /usr/bin/gconftool-2 ]
+ then
+ /usr/bin/gconftool-2 --shutdown
+ fi
+}
+
+pkg_setup () {
+ kill_gconf
+}
+pkg_preinst () {
+ kill_gconf
+ # hack hack
+ dodir /etc/gconf/gconf.xml.mandatory
+ dodir /etc/gconf/gconf.xml.defaults
+ touch ${D}/etc/gconf/gconf.xml.mandatory/.keep
+ touch ${D}/etc/gconf/gconf.xml.defaults/.keep
+
+ dodir /etc/env.d
+ echo 'CONFIG_PROTECT_MASK="/etc/gconf"' >${D}/etc/env.d/50gconf
+
+ dodir /root/.gconfd
+
+}
+pkg_postinst () {
+ kill_gconf
+ gnome2_pkg_postinst
+
+ #change the permissions to avoid some gconf bugs
+ einfo "changing permissions for gconf dirs"
+ find /etc/gconf/ -type d -exec chmod ugo+rx "{}" \;
+ einfo "changing permissions for gconf files"
+ find /etc/gconf/ -type f -exec chmod ugo+r "{}" \;
+
+}
+
+
+DOCS="ABOUT-NLS AUTHORS ChangeLog COPYING README* INSTALL NEWS TODO"
+
+