summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-10-07 22:15:58 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-10-07 22:15:58 +0000
commit3b9e529ee58081b83a4799733f828f7e156889bf (patch)
tree21179d3eea5034e9df09920978082bbd83c844ad /gnome-base/libghttp
parentmo-files didn't play nicely with DESTDIR (diff)
downloadhistorical-3b9e529ee58081b83a4799733f828f7e156889bf.tar.gz
historical-3b9e529ee58081b83a4799733f828f7e156889bf.tar.bz2
historical-3b9e529ee58081b83a4799733f828f7e156889bf.zip
updated to use prefix=/usr install instead of the DESTDIR-version, also fixed so that gets set depending on SRC_URI
Diffstat (limited to 'gnome-base/libghttp')
-rw-r--r--gnome-base/libghttp/libghttp-1.0.9-r1.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/gnome-base/libghttp/libghttp-1.0.9-r1.ebuild b/gnome-base/libghttp/libghttp-1.0.9-r1.ebuild
index 9eee4967a085..474c0bd14207 100644
--- a/gnome-base/libghttp/libghttp-1.0.9-r1.ebuild
+++ b/gnome-base/libghttp/libghttp-1.0.9-r1.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/libghttp/libghttp-1.0.9-r1.ebuild,v 1.1 2001/10/06 10:06:50 hallski Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libghttp/libghttp-1.0.9-r1.ebuild,v 1.2 2001/10/07 22:15:58 hallski Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="libghttp"
-SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${A}"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
HOMEPAGE="http://www.gnome.org/"
@@ -15,16 +14,21 @@ DEPEND="virtual/glibc"
src_compile() {
./configure --host=${CHOST} \
--prefix=/usr \
-
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib
assert
emake || die
}
src_install() {
- make DESTDIR=${D} install || die
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
dodoc AUTHORS COPYING* ChangeLog README NEWS TODO
+
docinto html
dodoc doc/ghttp.html
}