summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-09-16 14:59:12 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-09-16 14:59:12 +0000
commit01e8c231a64185ee22045c0ef9d219a45ee00d58 (patch)
tree4b6ce4fbaa8b1ac24d91f2953007cea1432280df /gnome-extra
parentversion bump (diff)
downloadhistorical-01e8c231a64185ee22045c0ef9d219a45ee00d58.tar.gz
historical-01e8c231a64185ee22045c0ef9d219a45ee00d58.tar.bz2
historical-01e8c231a64185ee22045c0ef9d219a45ee00d58.zip
version bump
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/libgda/Manifest4
-rw-r--r--gnome-extra/libgda/files/digest-libgda-1.0.01
-rw-r--r--gnome-extra/libgda/libgda-1.0.0.ebuild101
-rw-r--r--gnome-extra/libgnomedb/ChangeLog7
-rw-r--r--gnome-extra/libgnomedb/Manifest2
5 files changed, 112 insertions, 3 deletions
diff --git a/gnome-extra/libgda/Manifest b/gnome-extra/libgda/Manifest
index 0ba8016ccf5c..70148a2fee46 100644
--- a/gnome-extra/libgda/Manifest
+++ b/gnome-extra/libgda/Manifest
@@ -1,10 +1,10 @@
-MD5 6cf9c3c371747ddb39b250c5ec490f7c ChangeLog 4151
+MD5 10e28d9c4f764fa78820012131af36ae ChangeLog 4266
MD5 21d7bf915f9fdd61a090b47644a39662 libgda-0.12.1.ebuild 2570
MD5 37f9b04c394742e1ffcb6bf1218b6358 libgda-0.2.95-r1.ebuild 3283
MD5 ec4c66af4e7ca373e370223b7d126a4b libgda-0.2.96-r2.ebuild 3495
MD5 c19c0993d2f98e805569ab396e6e9bcb libgda-0.90.0.ebuild 2571
MD5 6bcaaa395f9f33c972852adc62b6f044 libgda-0.91.0.ebuild 2538
-MD5 6bcaaa395f9f33c972852adc62b6f044 libgda-1.0.0.ebuild 2538
+MD5 fccb16ab9d293633d8534799a15dad21 libgda-1.0.0.ebuild 2536
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
MD5 b8ef30c01c11ee3f373d99d6173d71a9 files/digest-libgda-0.12.1 66
MD5 40bbf8acf6e08a15e8e61573f6f07724 files/digest-libgda-0.2.95-r1 66
diff --git a/gnome-extra/libgda/files/digest-libgda-1.0.0 b/gnome-extra/libgda/files/digest-libgda-1.0.0
new file mode 100644
index 000000000000..459099ad1360
--- /dev/null
+++ b/gnome-extra/libgda/files/digest-libgda-1.0.0
@@ -0,0 +1 @@
+MD5 7e5f5c0943600236ec16df35119af86a libgda-1.0.0.tar.bz2 1026627
diff --git a/gnome-extra/libgda/libgda-1.0.0.ebuild b/gnome-extra/libgda/libgda-1.0.0.ebuild
new file mode 100644
index 000000000000..03bab267e212
--- /dev/null
+++ b/gnome-extra/libgda/libgda-1.0.0.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/libgda-1.0.0.ebuild,v 1.1 2003/09/16 14:58:32 liquidx Exp $
+
+IUSE="odbc postgres mysql ldap firebird freetds sqlite mdb oci8 doc"
+
+inherit gnome2
+
+DESCRIPTION="Gnome Database Access Library"
+HOMEPAGE="http://www.gnome-db.org/"
+SLOT="1"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="~x86 ~ppc"
+
+RDEPEND=">=dev-libs/glib-2.0
+ >=dev-libs/libxml2-2.0
+ >=dev-libs/libxslt-1.0.9
+ >=gnome-base/gnome-vfs-2.0
+ dev-libs/popt
+ sys-libs/ncurses
+ mysql? ( >=dev-db/mysql-3.23.51 )
+ postgres? ( >=dev-db/postgresql-7.2.1 )
+ odbc? ( >=dev-db/unixODBC-2.0.6 )
+ ldap? ( >=net-nds/openldap-2.0.25 )
+ firebird? ( >=dev-db/firebird-1.0 )
+ freetds? ( >=dev-db/freetds-0.5 )
+ sqlite? ( >=dev-db/sqlite-2.4.2 )
+ mdb? ( >=app-office/mdbtools-0.5 )"
+
+DEPEND=">=dev-util/pkgconfig-0.8
+ >=dev-util/intltool-0.22
+ >=sys-devel/gettext-0.11
+ app-text/scrollkeeper
+ doc? ( dev-util/gtk-doc )
+ ${RDEPEND}"
+
+DOCS="AUTHORS COPYING* ChangeLog INSTALL NEWS README"
+
+# problems with parallel builds
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_unpack() {
+ unpack ${A}
+ gnome2_omf_fix ${S}/doc/Makefile.in
+}
+
+src_compile() {
+
+ local myconf
+
+ use mysql \
+ && myconf="${myconf} --with-mysql=/usr" \
+ || myconf="${myconf} --without-mysql"
+
+ use postgres \
+ && myconf="${myconf} --with-postgres=/usr" \
+ || myconf="${myconf} --without-postgres"
+
+ use odbc \
+ && myconf="${myconf} --with-odbc=/usr" \
+ || myconf="${myconf} --without-odbc"
+
+ use ldap \
+ && myconf="${myconf} --with-ldap=/usr" \
+ || myconf="${myconf} --without-ldap"
+
+ use sqlite \
+ && myconf="$myconf --with-sqlite=/usr" \
+ || myconf="$myconf --without-sqlite"
+
+ use freetds \
+ && myconf="$myconf --with-tds=/usr" \
+ || myconf="$myconf --without-tds"
+
+ use firebird \
+ && myconf="${myconf} --with-firebird=/usr" \
+ || myconf="${myconf} --without-firebird"
+
+ use mdb \
+ && myconf="${myconf} --with-mdb=/usr" \
+ || myconf="${myconf} --without-mdb"
+
+ # not in portage (http://linux.techass.com/projects/xdb/)
+ myconf="${myconf} --without-xbase"
+ myconf="${myconf} --without-msql"
+
+ # closed source dbs
+ myconf="${myconf} --without-ibmdb2"
+ myconf="${myconf} --without-sybase"
+ use oci8 || myconf="${myconf} --without-oracle"
+
+ # workaround for readline-4.1 profile - disables building of gda-config-tool
+ if has_version "=sys-libs/readline-4.1*"; then
+ export CONFIG_TOOL_HEADERS="wrong"
+ fi
+
+ gnome2_src_compile ${myconf}
+
+ unset CONFIG_TOOL_HEADERS
+
+}
diff --git a/gnome-extra/libgnomedb/ChangeLog b/gnome-extra/libgnomedb/ChangeLog
index e6f5a3084c99..c0a1385b45a4 100644
--- a/gnome-extra/libgnomedb/ChangeLog
+++ b/gnome-extra/libgnomedb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-extra/libgnomedb
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgnomedb/ChangeLog,v 1.10 2003/09/12 20:45:08 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgnomedb/ChangeLog,v 1.11 2003/09/16 14:59:12 liquidx Exp $
+
+*libgnomedb-1.0.0 (16 Sep 2003)
+
+ 16 Sep 2003; Alastair Tse <liquidx@gentoo.org> libgnomedb-1.0.0.ebuild:
+ version bump
12 Sep 2003; Alastair Tse <liquidx@gentoo.org> libgnomedb-0.12.1.ebuild,
libgnomedb-0.90.0.ebuild, libgnomedb-0.91.0.ebuild:
diff --git a/gnome-extra/libgnomedb/Manifest b/gnome-extra/libgnomedb/Manifest
index f18ae2d7b774..8e0795d1a2b0 100644
--- a/gnome-extra/libgnomedb/Manifest
+++ b/gnome-extra/libgnomedb/Manifest
@@ -2,7 +2,9 @@ MD5 262c304a6c90d5b63e7a8bc978deb7ab ChangeLog 1601
MD5 06166e5e0c8158475fbd7972ae1383c1 libgnomedb-0.12.1.ebuild 1216
MD5 f69ca1d429ce23aeb4cbbf31d0d0c84e libgnomedb-0.90.0.ebuild 1217
MD5 81e5d9a098a95f97f43b3ab6565ad34b libgnomedb-0.91.0.ebuild 1242
+MD5 670b7e4d04975ae5e0e51064a63fdb73 libgnomedb-1.0.0.ebuild 1241
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
MD5 d48a0cec30d90af0c488dc4dbfc3e1a3 files/digest-libgnomedb-0.12.1 70
MD5 7717e09f4661443921c018c804fa2623 files/digest-libgnomedb-0.90.0 70
MD5 3d3b7e45fd366f50be6c165f01552c85 files/digest-libgnomedb-0.91.0 70
+MD5 22bbed9a12b3896021e6ba4f135702c6 files/digest-libgnomedb-1.0.0 69