summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-09-17 20:12:23 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-09-17 20:12:23 +0000
commit6b1ec811d151d4026ccba4243700eabdd37e98a4 (patch)
treee670ce8965515d51cce82213351d41a02fe5e73d /gnome-extra
parentversion bump (diff)
downloadhistorical-6b1ec811d151d4026ccba4243700eabdd37e98a4.tar.gz
historical-6b1ec811d151d4026ccba4243700eabdd37e98a4.tar.bz2
historical-6b1ec811d151d4026ccba4243700eabdd37e98a4.zip
version bump
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/libgsf/Manifest4
-rw-r--r--gnome-extra/libgsf/files/digest-libgsf-1.8.21
-rw-r--r--gnome-extra/libgsf/libgsf-1.8.2.ebuild35
3 files changed, 38 insertions, 2 deletions
diff --git a/gnome-extra/libgsf/Manifest b/gnome-extra/libgsf/Manifest
index b2e85f296af7..c8eb60947068 100644
--- a/gnome-extra/libgsf/Manifest
+++ b/gnome-extra/libgsf/Manifest
@@ -1,10 +1,10 @@
-MD5 832221235b70d116388b2b9fbb971519 ChangeLog 2479
+MD5 b2d96db42d36ae94fc8c0a9c31baa04b ChangeLog 2615
MD5 cd5f88b2186e34ae8b37f9bf965ebf8e libgsf-1.3.0-r1.ebuild 1351
MD5 00684f3ca1965326e38dec2b262f15c7 libgsf-1.6.0.ebuild 1151
MD5 1e96cec7a2fd351ca19bc2e688645229 libgsf-1.7.2.ebuild 1141
MD5 61676b8c96aa4deb8678fb3bd7d8e545 libgsf-1.8.0.ebuild 1021
MD5 bb2a5e9d91a6660f62766a94095f9d82 libgsf-1.8.1.ebuild 1017
-MD5 5617a1014aff49169ad6b9f3ad827868 libgsf-1.8.2.ebuild 901
+MD5 1d41aee72e3f1d82393888f823cf9707 libgsf-1.8.2.ebuild 900
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
MD5 5123d385e9aeecd520617df2aa4dc81f files/digest-libgsf-1.3.0-r1 65
MD5 ec1b3e9e3fc3f4373d56d58ca0335f3d files/digest-libgsf-1.6.0 65
diff --git a/gnome-extra/libgsf/files/digest-libgsf-1.8.2 b/gnome-extra/libgsf/files/digest-libgsf-1.8.2
new file mode 100644
index 000000000000..8cabe743a4f6
--- /dev/null
+++ b/gnome-extra/libgsf/files/digest-libgsf-1.8.2
@@ -0,0 +1 @@
+MD5 3a575469f9a2880d8ca78a70ddb93e78 libgsf-1.8.2.tar.bz2 330342
diff --git a/gnome-extra/libgsf/libgsf-1.8.2.ebuild b/gnome-extra/libgsf/libgsf-1.8.2.ebuild
new file mode 100644
index 000000000000..8ca06077557c
--- /dev/null
+++ b/gnome-extra/libgsf/libgsf-1.8.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgsf/libgsf-1.8.2.ebuild,v 1.1 2003/09/17 20:12:18 liquidx Exp $
+
+inherit gnome2
+
+DESCRIPTION="The GNOME Structured File Library"
+HOMEPAGE="http://www.gnome.org/"
+
+IUSE="gnome doc"
+SLOT="0"
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~x86 ~sparc ~ppc ~hppa"
+
+# FIXME : should add optional bz2 support
+RDEPEND=">=dev-libs/libxml2-2.4.16
+ >=dev-libs/glib-2
+ >=sys-libs/zlib-1.1.4
+ gnome? ( >=gnome-base/libbonobo-2
+ >=gnome-base/gnome-vfs-2 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ >=sys-apps/sed-4
+ doc? ( >=dev-util/gtk-doc-0.9 )"
+
+src_unpack() {
+ unpack ${A}
+ sed -e "s:doc\$(TARGET_DIR):\$(TARGET_DIR):" \
+ -i ${S}/doc/Makefile.in
+}
+
+G2CONF="${G2CONF} $(use_with gnome)"
+
+DOCS="AUTHORS COPYING* ChangeLog INSTALL NEWS README"