summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2012-02-17 10:58:04 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2012-02-17 10:58:04 +0000
commit7c2732b5e229851233957944bd1506103b5b0ad5 (patch)
tree4204ed9b1fe2a6e8651ca5414d19030197877c0e /gnustep-base
parentAdd version 0.72.0 (diff)
downloadhistorical-7c2732b5e229851233957944bd1506103b5b0ad5.tar.gz
historical-7c2732b5e229851233957944bd1506103b5b0ad5.tar.bz2
historical-7c2732b5e229851233957944bd1506103b5b0ad5.zip
Clean and make gnustep-back-* ebuilds closer
Package-Manager: portage-2.2.0_alpha86/cvs/Linux x86_64
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/gnustep-back-art/ChangeLog6
-rw-r--r--gnustep-base/gnustep-back-art/gnustep-back-art-0.22.0.ebuild37
-rw-r--r--gnustep-base/gnustep-back-cairo/ChangeLog6
-rw-r--r--gnustep-base/gnustep-back-cairo/gnustep-back-cairo-0.22.0.ebuild25
-rw-r--r--gnustep-base/gnustep-back-xlib/ChangeLog6
-rw-r--r--gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.22.0.ebuild31
6 files changed, 61 insertions, 50 deletions
diff --git a/gnustep-base/gnustep-back-art/ChangeLog b/gnustep-base/gnustep-back-art/ChangeLog
index 5d938bfadcc5..9ab0f3dc0441 100644
--- a/gnustep-base/gnustep-back-art/ChangeLog
+++ b/gnustep-base/gnustep-back-art/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for gnustep-base/gnustep-back-art
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-back-art/ChangeLog,v 1.83 2012/02/08 14:53:32 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-back-art/ChangeLog,v 1.84 2012/02/17 10:58:04 voyageur Exp $
+
+ 17 Feb 2012; Bernard Cafarelli <voyageur@gentoo.org>
+ gnustep-back-art-0.22.0.ebuild:
+ Clean and make gnustep-back-* ebuilds closer
*gnustep-back-art-0.22.0 (08 Feb 2012)
diff --git a/gnustep-base/gnustep-back-art/gnustep-back-art-0.22.0.ebuild b/gnustep-base/gnustep-back-art/gnustep-back-art-0.22.0.ebuild
index 3a57400a2678..9a2907b7782f 100644
--- a/gnustep-base/gnustep-back-art/gnustep-back-art-0.22.0.ebuild
+++ b/gnustep-base/gnustep-back-art/gnustep-back-art-0.22.0.ebuild
@@ -1,22 +1,20 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-back-art/gnustep-back-art-0.22.0.ebuild,v 1.1 2012/02/08 14:53:32 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-back-art/gnustep-back-art-0.22.0.ebuild,v 1.2 2012/02/17 10:58:04 voyageur Exp $
+EAPI=4
inherit gnustep-base
-S=${WORKDIR}/gnustep-back-${PV}
-
DESCRIPTION="libart_lgpl back-end component for the GNUstep GUI Library"
-
HOMEPAGE="http://www.gnustep.org"
SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/gnustep-back-${PV}.tar.gz"
-KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
-SLOT="0"
-LICENSE="LGPL-2.1"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
IUSE="opengl xim"
-DEPEND="${GNUSTEP_CORE_DEPEND}
+RDEPEND="${GNUSTEP_CORE_DEPEND}
=gnustep-base/gnustep-gui-${PV%.*}*
opengl? ( virtual/opengl virtual/glu )
x11-libs/libICE
@@ -28,26 +26,31 @@ DEPEND="${GNUSTEP_CORE_DEPEND}
x11-libs/libXt
x11-libs/libXft
x11-libs/libXrender
- dev-libs/expat
- media-libs/fontconfig
>=media-libs/freetype-2.1.9
+
>=media-libs/libart_lgpl-2.3
>=gnustep-base/mknfonts-0.5-r1
media-fonts/dejavu
+
!gnustep-base/gnustep-back-cairo
!gnustep-base/gnustep-back-xlib"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}"
-src_compile() {
+S=${WORKDIR}/gnustep-back-${PV}
+
+src_configure() {
egnustep_env
- use opengl && myconf="--enable-glx"
- myconf="$myconf `use_enable xim`"
+ myconf="$(use_enable opengl glx)"
+ myconf="$myconf $(use_enable xim)"
myconf="$myconf --enable-server=x11"
myconf="$myconf --enable-graphics=art"
- econf $myconf || die "configure failed"
- egnustep_make
+ econf $myconf
+}
+
+src_compile() {
+ gnustep-base_src_compile
# Create font lists for DejaVu
einfo "Generating nfonts support files"
@@ -65,8 +68,6 @@ src_compile() {
}
src_install() {
- egnustep_env
-
gnustep-base_src_install
mkdir -p "${D}/${GNUSTEP_SYSTEM_LIBRARY}/Fonts"
diff --git a/gnustep-base/gnustep-back-cairo/ChangeLog b/gnustep-base/gnustep-back-cairo/ChangeLog
index 7260fa92c9c8..0db303e411d7 100644
--- a/gnustep-base/gnustep-back-cairo/ChangeLog
+++ b/gnustep-base/gnustep-back-cairo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for gnustep-base/gnustep-back-cairo
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-back-cairo/ChangeLog,v 1.30 2012/02/08 14:52:32 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-back-cairo/ChangeLog,v 1.31 2012/02/17 10:57:00 voyageur Exp $
+
+ 17 Feb 2012; Bernard Cafarelli <voyageur@gentoo.org>
+ gnustep-back-cairo-0.22.0.ebuild:
+ Clean and make gnustep-back-* ebuilds closer
*gnustep-back-cairo-0.22.0 (08 Feb 2012)
diff --git a/gnustep-base/gnustep-back-cairo/gnustep-back-cairo-0.22.0.ebuild b/gnustep-base/gnustep-back-cairo/gnustep-back-cairo-0.22.0.ebuild
index 5ca627201946..d6a3749ef7fb 100644
--- a/gnustep-base/gnustep-back-cairo/gnustep-back-cairo-0.22.0.ebuild
+++ b/gnustep-base/gnustep-back-cairo/gnustep-back-cairo-0.22.0.ebuild
@@ -1,26 +1,22 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-back-cairo/gnustep-back-cairo-0.22.0.ebuild,v 1.1 2012/02/08 14:52:32 voyageur Exp $
-
-EAPI=2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-back-cairo/gnustep-back-cairo-0.22.0.ebuild,v 1.2 2012/02/17 10:57:00 voyageur Exp $
+EAPI=4
inherit gnustep-base
-S=${WORKDIR}/gnustep-back-${PV}
-
DESCRIPTION="Cairo back-end component for the GNUstep GUI Library."
-
HOMEPAGE="http://www.gnustep.org"
SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/gnustep-back-${PV}.tar.gz"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
-SLOT="0"
-LICENSE="LGPL-2.1"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
IUSE="opengl xim"
+
RDEPEND="${GNUSTEP_CORE_DEPEND}
=gnustep-base/gnustep-gui-${PV%.*}*
opengl? ( virtual/opengl virtual/glu )
-
x11-libs/libICE
x11-libs/libSM
x11-libs/libX11
@@ -30,21 +26,24 @@ RDEPEND="${GNUSTEP_CORE_DEPEND}
x11-libs/libXt
x11-libs/libXft
x11-libs/libXrender
-
>=media-libs/freetype-2.1.9
+
>=x11-libs/cairo-1.2.0[X]
+
!gnustep-base/gnustep-back-art
!gnustep-base/gnustep-back-xlib"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+S=${WORKDIR}/gnustep-back-${PV}
+
src_configure() {
egnustep_env
- use opengl || myconf="--disable-glx"
+ myconf="$(use_enable opengl glx)"
myconf="$myconf $(use_enable xim)"
myconf="$myconf --enable-server=x11"
myconf="$myconf --enable-graphics=cairo"
- econf $myconf || die "configure failed"
+ econf $myconf
}
diff --git a/gnustep-base/gnustep-back-xlib/ChangeLog b/gnustep-base/gnustep-back-xlib/ChangeLog
index 0095f6e03a3f..8a3b596b6bb6 100644
--- a/gnustep-base/gnustep-back-xlib/ChangeLog
+++ b/gnustep-base/gnustep-back-xlib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for gnustep-base/gnustep-back-xlib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-back-xlib/ChangeLog,v 1.63 2012/02/08 14:53:41 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-back-xlib/ChangeLog,v 1.64 2012/02/17 10:56:01 voyageur Exp $
+
+ 17 Feb 2012; Bernard Cafarelli <voyageur@gentoo.org>
+ gnustep-back-xlib-0.22.0.ebuild:
+ Clean and make gnustep-back-* ebuilds closer
*gnustep-back-xlib-0.22.0 (08 Feb 2012)
diff --git a/gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.22.0.ebuild b/gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.22.0.ebuild
index f1790b2312ca..88ee709a031f 100644
--- a/gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.22.0.ebuild
+++ b/gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.22.0.ebuild
@@ -1,21 +1,20 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.22.0.ebuild,v 1.1 2012/02/08 14:53:41 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.22.0.ebuild,v 1.2 2012/02/17 10:56:01 voyageur Exp $
+EAPI=4
inherit gnustep-base
-S=${WORKDIR}/gnustep-back-${PV}
-
DESCRIPTION="Default X11 back-end component for the GNUstep GUI Library"
-
HOMEPAGE="http://www.gnustep.org"
SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/gnustep-back-${PV}.tar.gz"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
-SLOT="0"
-LICENSE="LGPL-2.1"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
IUSE="opengl xim"
-DEPEND="${GNUSTEP_CORE_DEPEND}
+
+RDEPEND="${GNUSTEP_CORE_DEPEND}
=gnustep-base/gnustep-gui-${PV%.*}*
opengl? ( virtual/opengl virtual/glu )
x11-libs/libICE
@@ -27,21 +26,21 @@ DEPEND="${GNUSTEP_CORE_DEPEND}
x11-libs/libXt
x11-libs/libXft
x11-libs/libXrender
- dev-libs/expat
- media-libs/fontconfig
>=media-libs/freetype-2.1.9
+
!gnustep-base/gnustep-back-art
!gnustep-base/gnustep-back-cairo"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/gnustep-back-${PV}
-src_compile() {
+src_configure() {
egnustep_env
- use opengl && myconf="--enable-glx"
- myconf="$myconf `use_enable xim`"
+ myconf="$(use_enable opengl glx)"
+ myconf="$myconf $(use_enable xim)"
myconf="$myconf --enable-server=x11"
myconf="$myconf --enable-graphics=xlib"
- econf $myconf || die "configure failed"
- egnustep_make
+ econf $myconf
}