summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmando Di Cianno <fafhrd@gentoo.org>2004-11-12 03:58:29 +0000
committerArmando Di Cianno <fafhrd@gentoo.org>2004-11-12 03:58:29 +0000
commita9bc49aa10fecdc6e69ff3891b5fc01b82835f0d (patch)
tree7601a6a1b4e03604e833e594167512da2444cb93 /gnustep-libs/steptalk
parentMass Update: gnustep.eclass revamped to allow configurable root install; gnus... (diff)
downloadhistorical-a9bc49aa10fecdc6e69ff3891b5fc01b82835f0d.tar.gz
historical-a9bc49aa10fecdc6e69ff3891b5fc01b82835f0d.tar.bz2
historical-a9bc49aa10fecdc6e69ff3891b5fc01b82835f0d.zip
Mass Update: gnustep.eclass revamped to allow configurable root install; gnustep-base/libs/apps updated to utilize new gnustep.eclass (only versions bumped where files would change); some KEYWORDS were accidentally dropped between version bumps of packages -- this has been resolved; windowmaker correctly supports gnustep now; gnustep-funcs.eclass added -- used where info on an installed gnustep-env is needed rather than making a full GNUstep application
Diffstat (limited to 'gnustep-libs/steptalk')
-rw-r--r--gnustep-libs/steptalk/ChangeLog10
-rw-r--r--gnustep-libs/steptalk/Manifest4
-rw-r--r--gnustep-libs/steptalk/steptalk-0.8.3_pre20040927.ebuild12
3 files changed, 18 insertions, 8 deletions
diff --git a/gnustep-libs/steptalk/ChangeLog b/gnustep-libs/steptalk/ChangeLog
index cba531be69b7..a7ab0d29a444 100644
--- a/gnustep-libs/steptalk/ChangeLog
+++ b/gnustep-libs/steptalk/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for gnustep-libs/steptalk
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/steptalk/ChangeLog,v 1.2 2004/10/18 12:13:11 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/steptalk/ChangeLog,v 1.3 2004/11/12 03:56:25 fafhrd Exp $
+
+ 11 Nov 2004; Armando Di Cianno <fafhrd@gentoo.org>
+ steptalk-0.8.3_pre20040927.ebuild:
+ Mass Update: gnustep.eclass revamped to allow configurable root install;
+ gnustep-base/libs/apps updated to utilize new gnustep.eclass (only versions
+ bumped where files would change); some KEYWORDS were accidentally dropped
+ between version bumps of packages -- this has been resolved; windowmaker
+ correctly supports gnustep now
18 Oct 2004; David Holm <dholm@gentoo.org>
steptalk-0.8.3_pre20040927.ebuild:
diff --git a/gnustep-libs/steptalk/Manifest b/gnustep-libs/steptalk/Manifest
index 250d7d45a4be..6f54e54c0d58 100644
--- a/gnustep-libs/steptalk/Manifest
+++ b/gnustep-libs/steptalk/Manifest
@@ -1,4 +1,4 @@
-MD5 83fc0a68fe5652e36a2a19f46b0885a3 ChangeLog 483
+MD5 d741c934d4727fea1fab4669ace0afa3 steptalk-0.8.3_pre20040927.ebuild 1284
+MD5 a8058bcc89e575d76da0b2b8bbb9d1a5 ChangeLog 911
MD5 2306f8060e1888706195402ce19e8bed metadata.xml 2189
-MD5 29239a55c26235ad5fa382802c0b8371 steptalk-0.8.3_pre20040927.ebuild 1235
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-steptalk-0.8.3_pre20040927 0
diff --git a/gnustep-libs/steptalk/steptalk-0.8.3_pre20040927.ebuild b/gnustep-libs/steptalk/steptalk-0.8.3_pre20040927.ebuild
index 5552f03da448..de53f479778b 100644
--- a/gnustep-libs/steptalk/steptalk-0.8.3_pre20040927.ebuild
+++ b/gnustep-libs/steptalk/steptalk-0.8.3_pre20040927.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/steptalk/steptalk-0.8.3_pre20040927.ebuild,v 1.3 2004/10/21 19:10:16 fafhrd Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/steptalk/steptalk-0.8.3_pre20040927.ebuild,v 1.4 2004/11/12 03:56:25 fafhrd Exp $
ECVS_CVS_COMMAND="cvs -q"
ECVS_SERVER="savannah.gnu.org:/cvsroot/gnustep"
ECVS_USER="anoncvs"
ECVS_AUTH="ext"
ECVS_MODULE="gnustep/dev-libs/${PN/stept/StepT}"
-ECVS_CO_OPTS="-D ${PV/*_pre}"
-ECVS_UP_OPTS="-D ${PV/*_pre}"
+ECVS_CO_OPTS="-P -D ${PV/*_pre}"
+ECVS_UP_OPTS="-dP -D ${PV/*_pre}"
ECVS_TOP_DIR="${DISTDIR}/cvs-src/savannah.gnu.org-gnustep"
inherit gnustep cvs
@@ -25,6 +25,8 @@ IUSE="${IUSE} doc"
DEPEND="${GS_DEPEND}"
RDEPEND="${GS_RDEPEND}"
+egnustep_install_domain "System"
+
src_install() {
cd ${S}
egnustep_env
@@ -36,8 +38,8 @@ src_install() {
mkdir -p ${TMP}/tmpdocs
mv *.* ${TMP}/tmpdocs
mv Reference ${TMP}/tmpdocs
- mkdir -p ${D}${GNUSTEP_SYSTEM_ROOT}/Library/Documentation/Developer/${PN/stept/StepT}
- mv ${TMP}/tmpdocs/* ${D}${GNUSTEP_SYSTEM_ROOT}/Library/Documentation/Developer/${PN/stept/StepT}
+ mkdir -p ${D}$(egnustep_install_domain)/Library/Documentation/Developer/${PN/stept/StepT}
+ mv ${TMP}/tmpdocs/* ${D}$(egnustep_install_domain)/Library/Documentation/Developer/${PN/stept/StepT}
cd ..
fi
egnustep_package_config