summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2010-09-05 23:38:23 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2010-09-05 23:38:23 +0000
commitdea4d3e2837726a4e37aa68b155f96060de8705f (patch)
treef7b81a29c32bf979af565031feb5e3a4e365bb6f /kde-base/kalgebra
parentVersion bump to fix bug #326487 (diff)
downloadhistorical-dea4d3e2837726a4e37aa68b155f96060de8705f.tar.gz
historical-dea4d3e2837726a4e37aa68b155f96060de8705f.tar.bz2
historical-dea4d3e2837726a4e37aa68b155f96060de8705f.zip
Version bump KDE SC 4.5.1
Package-Manager: portage-2.2_rc75/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/kalgebra')
-rw-r--r--kde-base/kalgebra/ChangeLog8
-rw-r--r--kde-base/kalgebra/kalgebra-4.5.1.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/kde-base/kalgebra/ChangeLog b/kde-base/kalgebra/ChangeLog
index ffe1496ffcb9..3eb16fbe4cfc 100644
--- a/kde-base/kalgebra/ChangeLog
+++ b/kde-base/kalgebra/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kalgebra
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalgebra/ChangeLog,v 1.71 2010/08/09 17:33:51 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalgebra/ChangeLog,v 1.72 2010/09/05 23:20:47 tampakrap Exp $
+
+*kalgebra-4.5.1 (05 Sep 2010)
+
+ 05 Sep 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +kalgebra-4.5.1.ebuild:
+ Version bump
09 Aug 2010; Tomáš Chvátal <scarabeus@gentoo.org>
kalgebra-4.4.5.ebuild:
diff --git a/kde-base/kalgebra/kalgebra-4.5.1.ebuild b/kde-base/kalgebra/kalgebra-4.5.1.ebuild
new file mode 100644
index 000000000000..8cef55cb9c20
--- /dev/null
+++ b/kde-base/kalgebra/kalgebra-4.5.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalgebra/kalgebra-4.5.1.ebuild,v 1.1 2010/09/05 23:20:47 tampakrap Exp $
+
+EAPI="3"
+
+KDE_HANDBOOK=1
+KMNAME="kdeedu"
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="MathML-based graph calculator for KDE."
+KEYWORDS=""
+IUSE="debug +plasma readline"
+
+DEPEND="
+ readline? ( sys-libs/readline )
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRACTONLY="libkdeedu/kdeeduui"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.2-solaris-graph2d.patch
+)
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with readline)
+ $(cmake-utils_use_with plasma)
+ $(cmake-utils_use_with opengl OpenGL)
+ )
+
+ kde4-meta_src_configure
+}
+
+src_test() {
+ # disable broken test
+ sed -i -e '/mathmlpresentationtest/ s/^/#DO_NOT_RUN_TEST /' \
+ "${S}"/"${PN}"/analitza/tests/CMakeLists.txt || \
+ die "sed to disable mathmlpresentationtest failed."
+
+ kde4-meta_src_test
+}