summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-03-04 18:00:22 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-03-04 18:00:22 +0000
commit6f430e346de22377dc53caf57d7a8b62b57eb7ed (patch)
tree7bf86d97cf974dfed6c010d3ff5aebc192229757 /kde-base/kdebindings-perl
parentRemoved unneccessary python_copy_sources (diff)
downloadhistorical-6f430e346de22377dc53caf57d7a8b62b57eb7ed.tar.gz
historical-6f430e346de22377dc53caf57d7a8b62b57eb7ed.tar.bz2
historical-6f430e346de22377dc53caf57d7a8b62b57eb7ed.zip
[kde-base] Add KDE SC 4.6.1
Package-Manager: portage-2.2.0_alpha26/cvs/Linux x86_64
Diffstat (limited to 'kde-base/kdebindings-perl')
-rw-r--r--kde-base/kdebindings-perl/ChangeLog8
-rw-r--r--kde-base/kdebindings-perl/kdebindings-perl-4.6.1.ebuild53
2 files changed, 60 insertions, 1 deletions
diff --git a/kde-base/kdebindings-perl/ChangeLog b/kde-base/kdebindings-perl/ChangeLog
index 604f05b218fb..99d433ef16b8 100644
--- a/kde-base/kdebindings-perl/ChangeLog
+++ b/kde-base/kdebindings-perl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdebindings-perl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-perl/ChangeLog,v 1.10 2011/01/30 13:23:34 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-perl/ChangeLog,v 1.11 2011/03/04 17:59:59 alexxy Exp $
+
+*kdebindings-perl-4.6.1 (04 Mar 2011)
+
+ 04 Mar 2011; Alexey Shvetsov <alexxy@gentoo.org>
+ +kdebindings-perl-4.6.1.ebuild:
+ Version bump KDE SC 4.6.1
30 Jan 2011; Theo Chatzimichos <tampakrap@gentoo.org>
kdebindings-perl-4.5.5.ebuild, kdebindings-perl-4.6.0.ebuild:
diff --git a/kde-base/kdebindings-perl/kdebindings-perl-4.6.1.ebuild b/kde-base/kdebindings-perl/kdebindings-perl-4.6.1.ebuild
new file mode 100644
index 000000000000..dd7973d8034c
--- /dev/null
+++ b/kde-base/kdebindings-perl/kdebindings-perl-4.6.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-perl/kdebindings-perl-4.6.1.ebuild,v 1.1 2011/03/04 17:59:59 alexxy Exp $
+
+EAPI=3
+
+KMNAME="kdebindings"
+KMMODULE="perl"
+DECLARATIVE_REQUIRED="optional"
+MULTIMEDIA_REQUIRED="optional"
+QTHELP_REQUIRED="optional"
+WEBKIT_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="KDE Perl bindings"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="akonadi attica debug kate okular phonon plasma qimageblitz qscintilla qwt semantic-desktop"
+
+DEPEND="
+ >=dev-lang/perl-5.10.1
+ $(add_kdebase_dep smoke 'akonadi?,attica?,declarative?,kate?,multimedia?,okular?,phonon?,qimageblitz?,qscintilla?,qthelp?,qwt?,semantic-desktop?,webkit?')
+ semantic-desktop? ( >=dev-libs/soprano-2.4.64 )
+"
+RDEPEND="${DEPEND}"
+
+KMLOADLIBS="smoke"
+
+KMEXTRACTONLY="
+ smoke/
+"
+
+src_configure() {
+ mycmakeargs=(
+ -DDISABLE_Qt3Support=ON
+ $(cmake-utils_use_with akonadi)
+ $(cmake-utils_use_with akonadi KdepimLibs)
+ $(cmake-utils_use_with attica LibAttica)
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_disable kate)
+ $(cmake-utils_use_disable multimedia QtMultimedia)
+ $(cmake-utils_use_with okular)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_disable plasma)
+ $(cmake-utils_use_with qimageblitz QImageBlitz)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_disable qthelp QtHelp)
+ $(cmake-utils_use_disable qwt)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-meta_src_configure
+}